[PATCH] gnu: rubber: Update to 1.5.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 4 Jul 2020 23:37
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20200704213710.32539-1-arunisaac@systemreboot.net
* gnu/packages/tex.scm (rubber): Update to 1.5.1.
[build-system]: Switch to python-build-system.
[inputs]: Remove python-2 and which.
[arguments]: Delete the build phase. Replace the install phase with a custom
phase.
---
gnu/packages/tex.scm | 39 ++++++++++++++++++++++++---------------
1 file changed, 24 insertions(+), 15 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 47645a3e34..7b10433269 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2017, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Danny Milosavljevic <dannym+a@scratchpost.org>
-;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -35,6 +35,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
#:use-module (guix build-system texlive)
@@ -6005,22 +6006,30 @@ other things it comes with full Unicode support.")
(define-public rubber
(package
(name "rubber")
- (version "1.1")
+ (version "1.5.1")
(source (origin
- (method url-fetch)
- (uri (list (string-append "https://launchpad.net/rubber/trunk/"
- version "/+download/rubber-"
- version ".tar.gz")
- (string-append "http://ebeffara.free.fr/pub/rubber-"
- version ".tar.gz")))
- (sha256
- (base32
- "1xbkv8ll889933gyi2a5hj7hhh216k04gn8fwz5lfv5iz8s34gbq"))))
- (build-system gnu-build-system)
- (arguments '(#:tests? #f)) ; no `check' target
+ (method url-fetch)
+ (uri (list (string-append "https://launchpad.net/rubber/trunk/"
+ version "/+download/rubber-"
+ version ".tar.gz")
+ (string-append "http://ebeffara.free.fr/pub/rubber-"
+ version ".tar.gz")))
+ (sha256
+ (base32
+ "178dmrp0mza5gqjiqgk6dqs0c10s0c517pk6k9pjbam86vf47a1p"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f ; no `check' target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; texlive is required to build the PDF documentation; do not
+ ;; build it.
+ (invoke "python" "setup.py" "build" "--pdf=False" "install"
+ (string-append "--prefix=" (assoc-ref outputs "out"))))))))
(native-inputs `(("texinfo" ,texinfo)))
- (inputs `(("python" ,python-2) ; incompatible with Python 3 (print syntax)
- ("which" ,which)))
(home-page "https://launchpad.net/rubber")
(synopsis "Wrapper for LaTeX and friends")
(description
--
2.26.2
M
M
Mathieu Othacehe wrote on 5 Jul 2020 11:42
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 42204@debbugs.gnu.org)
875zb2jo1r.fsf@gnu.org
Hello,

This looks fine, please go ahead!

Thanks,

Mathieu
A
A
Arun Isaac wrote on 5 Jul 2020 12:48
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 42204-done@debbugs.gnu.org)
87sge6teyj.fsf@systemreboot.net
Pushed to master, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl8BsAQACgkQLiXui2GA
K7P+dwf/br9+rY3YjglparQqvmqTscBKr8dBdzPWagavQtWcMn0dI+IjQbb73hQ0
j+s57SrZ8+aJUTNJlVP04yMJdkJ+IZoYbX65bGY76st0byxoIrumVlUWs4oONKMv
Dvdip0+67wmxKJBQvYs25k3X42wEpmzP7EQF3cICzmMbQmrEkKZoOL60+ajJ2Bzn
MSCtXa1HwViYGe1wkXB+6am/0kKV3yAdw6br2PH1rJNJ4RK+XaNniHBhOUqRFkdm
BLpdzxEXm/QDGapl7u7OpRLRoH3eHwjIa2EvQZF1UOFQ6g2PdDHVkFaQpNX64haj
OS9rF2KIoXQcYSLJ3oc3uldJ+FeElg==
=J8tV
-----END PGP SIGNATURE-----

Closed
?