[PATCH 3/3] gnu: Add mycli.

  • Done
  • quality assurance status badge
Details
2 participants
  • guy fleury iteriteka
  • Oleg Pykhalov
Owner
unassigned
Submitted by
guy fleury iteriteka
Severity
normal

Debbugs page

guy fleury iteriteka wrote 5 years ago
(address . guix-patches@gnu.org)
20200704193142.31083-3-gfleury@disroot.org
* gnu/packages/databases.scm(mycli): New variable.
---
gnu/packages/databases.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 2e46f9b..a62eccd 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3568,3 +3569,34 @@ The drivers officially supported by @code{libdbi} are:
PostreSQL, SQLite, ODBC and MySQL.")
(home-page "http://soci.sourceforge.net/")
(license license:boost1.0)))
+
+(define-public mycli
+ (package
+ (name "mycli")
+ (version "1.21.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mycli" version))
+ (sha256
+ (base32
+ "1q9p0yik9cpvpxjs048anvhicfcna84mpl7axv9bwgr48w40lqwg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; tests expect a running MySQL
+ (propagated-inputs
+ `(("python-cli-helpers" ,python-cli-helpers)
+ ("python-click" ,python-click)
+ ("python-configobj" ,python-configobj)
+ ("python-cryptography" ,python-cryptography)
+ ("python-prompt-toolkit" ,python-prompt-toolkit)
+ ("python-pygments" ,python-pygments)
+ ("python-pymysql" ,python-pymysql)
+ ("python-sqlparse" ,python-sqlparse)))
+ (home-page "http://mycli.net")
+ (synopsis
+ "Terminal Client for MySQL with AutoCompletion and Syntax Highlighting")
+ (description
+ "MyCLI is a command line interface for MySQL, MariaDB, and Percona with
+auto-completion and syntax highlighting.")
+ (license license:bsd-3)))
--
2.25.1
Oleg Pykhalov wrote 5 years ago
(address . 42202-done@debbugs.gnu.org)
87h7tvl9h1.fsf@gmail.com
Hi,

guy fleury iteriteka <gfleury@disroot.org> writes:

Toggle quote (11 lines)
> * gnu/packages/databases.scm(mycli): New variable.
> ---
> gnu/packages/databases.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index 2e46f9b..a62eccd 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -42,6 +42,7 @@

[…]

Already in master.

Closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl8cfcoACgkQFn+OpQAa
+pyHdRAAyzDdhgJv5jUc0IMQ5+QeAS3YPLdoTJhTi6XN5Rz3KLnu0U57rnMgFc7t
IXp/2gTLsfiPvuZm5ZPySjAYonf/Ekb9v3MQmJrVyC7mwRfl8I+Thzbjs1hZmHCz
Eg8IEVsEeMP2lggPNMGOEqIp+uQG8pICNZaJtDfZz5a72VD26ctu3CKshF3zpxDH
PziPPtf6BSPQzBWPbjKViGtK05CP23rn/XPbBhB/9zsKPTH/nPtCf80Kxb2VM2hH
dO+roaK8d0x/3xjjBxIWU2u/UmkVg7Z9WsUVuAboDwALGx6Yv1uYXcl9k9+BqmLr
9bZFLAnXz2nO/ft5qo9MKa+SQkJkjRc4lXJwJzBEylFeDXxMoaOXNLJJqF2xnqBL
HdZhYFkleimq/Ak8sheyrA6kXO/QBtun9bwdLYF6gv1eJ67qLSf1PFqhWkW52g5T
ceVjzA5r+riCN8RsdVe/tPaQCpr/b/QSqxRckC0RcxO0wZd5O6eJPY0YRScCG1XG
2ajaIoakGKXFB1qeSuZefsOiU9JvTpL4l426kvm+qAvTIxs5av/Da5kuM5JjRlKc
t6JZ47nssecC8F8zWsfiHcm+1xilD8TAqMJPkStLiqFWxyngM3R5ADo5EmKYLcQU
196HySLfqkRYXVhYhfFBWye08HHnPN8WBQ3nfSctp5fsdalk+z4=
=nKE0
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42202@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42202
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help