[PATCH 1/3] gnu: Add python-terminaltables

  • Done
  • quality assurance status badge
Details
2 participants
  • guy fleury iteriteka
  • Nicolas Goaziou
Owner
unassigned
Submitted by
guy fleury iteriteka
Severity
normal
G
G
guy fleury iteriteka wrote on 4 Jul 2020 21:31
(address . guix-patches@gnu.org)
20200704193142.31083-1-gfleury@disroot.org
* gnu/packages/python-xyz.scm(python-terminaltables): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5eee00a..f09c31a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -82,6 +82,7 @@
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20402,3 +20403,23 @@ For the most part it's transliterated from C, the major differences are:
@end itemize
")
(license license:gpl3+)))
+
+(define-public python-terminaltables
+ (package
+ (name "python-terminaltables")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "terminaltables" version))
+ (sha256
+ (base32
+ "109vhldk6nv1z3hzp4dyqf6rjvlhl0y2k5k7qcm9fcrq5swhxszk"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/Robpol86/terminaltables")
+ (synopsis
+ "Generate simple tables in terminals from a nested list of strings")
+ (description
+ "This package makes easy to draw tables in terminal/console applications
+from a list of lists of strings. It Supports multi-line rows.")
+ (license license:expat)))
--
2.25.1
N
N
Nicolas Goaziou wrote on 8 Jul 2020 12:56
(name . guy fleury iteriteka)(address . gfleury@disroot.org)(address . 42201-done@debbugs.gnu.org)
87v9iy46mv.fsf@nicolasgoaziou.fr
Hello,

guy fleury iteriteka <gfleury@disroot.org> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm(python-terminaltables): New variable.

I pushed the 3 patches. Thank you.

Note that it is usually not a good idea to stuff new packages at the end
of a file: it may introduce merge conflicts.


Regards,
--
Nicolas Goaziou
Closed
?