guy fleury iteriteka wrote 5 years ago
(address . guix-patches@gnu.org)
* gnu/packages/python-xyz.scm(python-cli-helpers): New variable.
---
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f09c31a..4a60627 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20423,3 +20423,35 @@ For the most part it's transliterated from C, the major differences are:
"This package makes easy to draw tables in terminal/console applications
from a list of lists of strings. It Supports multi-line rows.")
(license license:expat)))
+
+(define-public python-cli-helpers
+ (package
+ (name "python-cli-helpers")
+ (version "2.0.1")
+ (source
+ (origin
+ ;; There's no source tarball on PyPI.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dbcli/cli_helpers.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bg2iw9l5dip0kbs00hajdk2v18wvhssbnq8hdf71278qf0wks5l"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-wcwidth" ,python-wcwidth)
+ ("python-configobj" ,python-configobj)
+ ("python-tabulate" ,python-tabulate)
+ ("python-terminaltables" ,python-terminaltables)))
+ (home-page "https://github.com/dbcli/cli_helpers")
+ (synopsis "Helpers for building command-line apps")
+ (description
+ "CLI Helpers is a Python package that makes it easy to perform common
+tasks when building command-line apps. It's a helper library for command-line
+interfaces.")
+ (license license:bsd-3)))
+
--
2.25.1