[PATCH 2/3] gnu: Add python-cli-helpers.

  • Done
  • quality assurance status badge
Details
2 participants
  • guy fleury iteriteka
  • Oleg Pykhalov
Owner
unassigned
Submitted by
guy fleury iteriteka
Severity
normal
G
G
guy fleury iteriteka wrote on 4 Jul 2020 21:31
(address . guix-patches@gnu.org)
20200704193142.31083-2-gfleury@disroot.org
* gnu/packages/python-xyz.scm(python-cli-helpers): New variable.
---
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f09c31a..4a60627 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20423,3 +20423,35 @@ For the most part it's transliterated from C, the major differences are:
"This package makes easy to draw tables in terminal/console applications
from a list of lists of strings. It Supports multi-line rows.")
(license license:expat)))
+
+(define-public python-cli-helpers
+ (package
+ (name "python-cli-helpers")
+ (version "2.0.1")
+ (source
+ (origin
+ ;; There's no source tarball on PyPI.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dbcli/cli_helpers.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bg2iw9l5dip0kbs00hajdk2v18wvhssbnq8hdf71278qf0wks5l"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-wcwidth" ,python-wcwidth)
+ ("python-configobj" ,python-configobj)
+ ("python-tabulate" ,python-tabulate)
+ ("python-terminaltables" ,python-terminaltables)))
+ (home-page "https://github.com/dbcli/cli_helpers")
+ (synopsis "Helpers for building command-line apps")
+ (description
+ "CLI Helpers is a Python package that makes it easy to perform common
+tasks when building command-line apps. It's a helper library for command-line
+interfaces.")
+ (license license:bsd-3)))
+
--
2.25.1
O
O
Oleg Pykhalov wrote on 25 Jul 2020 20:46
(address . 42200-done@debbugs.gnu.org)
87eeozl9ex.fsf@gmail.com
Toggle quote (10 lines)
> * gnu/packages/python-xyz.scm(python-cli-helpers): New variable.
> ---
> gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index f09c31a..4a60627 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm

[…]

Already in master.

Closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl8cfhYACgkQFn+OpQAa
+px1+g/9FiluMM5ds7Mz45g7DQQve3MtYQ73+gfDbcpD5DC94iNhVwsM6J5qhz9w
9nl2Dh1WrQGteZXUTIOC4DRb0C6clciQfb5baMcXOPGTjPmbUSTVrnJ9mCClYczd
iSfpFjf5S+QWelb1Jt5dPc0iOkwGomy+X2jWChIg6EqGvMy6fWM/xeOtdfSt2zND
Nwd8T2XKW99JvXs9jQskd8lCJ2S4E5wXN3QfC4FHS23eQcp69opo5KVrj0TwlBOX
4xgvYuHfRDEwVgsK7jNUMo3fP/RKrUjAxF4Of+4A90szgCmlFntujQgY+anScMYk
OuGpgjxhDYLMLTXXxkvpeFGOZEZ8/VnB0ExE0FWzqUCZVZ7RQdmWaDUrgUrPVWSs
faklcIUxh9LCJYTUWZobisWE6gqJufneEpm1BbZyvSjk14SZsLu6XsKCgob9eTCm
/oDCV9aLA5ZRSpDfq+uvOwvDPycPtryGDH0ZoulIS3R0BAPOo+8kd9NheA4WgtcS
B9JpmgK5ECg/XTWtzGcelTN+Wsn2Gr0DWZDg8hcbLiKJxCZbL8jOYvsQwGQH6+n1
NUVn01Qn3O0RufGZdfTLeO9THst/rD39BoljuZEr+RMOHuTmLnbvnsBTcOYv5ZEw
2klQjlHBBJ6S7rd85/F4fr+LcDUL53NC9WCbrdSOb8I5Sf8fnkw=
=QwP9
-----END PGP SIGNATURE-----

Closed
?