guy fleury iteriteka wrote 5 years ago
(address . guix-patches@gnu.org)
Like gfortran this package is not usable like it is.
use gdc-toolchain instead.
* gnu/packages/gcc.scm(gdc): New variable.
---
gnu/packages/gcc.scm | 5 +++++
1 file changed, 5 insertions(+)
Toggle diff (18 lines)
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 9e88109..201b37e 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -692,6 +692,11 @@ as the 'native-search-paths' field."
(custom-gcc gcc "gfortran" '("fortran")
%generic-search-paths)))
+(define-public gdc
+ (hidden-package
+ (custom-gcc gcc-10 "gdc" '("d")
+ %generic-search-paths)))
+
(define-public libgccjit
(package
(inherit gcc-9)
--
2.25.1