[PATCH 1/2] gnu: Add gdc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • guy fleury iteriteka
Owner
unassigned
Submitted by
guy fleury iteriteka
Severity
normal

Debbugs page

guy fleury iteriteka wrote 5 years ago
(address . guix-patches@gnu.org)
20200704140025.3602-1-gfleury@disroot.org
Like gfortran this package is not usable like it is.
use gdc-toolchain instead.
* gnu/packages/gcc.scm(gdc): New variable.
---
gnu/packages/gcc.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 9e88109..201b37e 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -692,6 +692,11 @@ as the 'native-search-paths' field."
(custom-gcc gcc "gfortran" '("fortran")
%generic-search-paths)))
+(define-public gdc
+ (hidden-package
+ (custom-gcc gcc-10 "gdc" '("d")
+ %generic-search-paths)))
+
(define-public libgccjit
(package
(inherit gcc-9)
--
2.25.1
Efraim Flashner wrote 5 years ago
(address . gfleury@disroot.org)(address . 42197@debbugs.gnu.org)
20200716201748.GK10256@E5400
This looks good to me. Have you tested it with anything? I don't have a
D project to test it out with.


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8QtegACgkQQarn3Mo9
g1G6IA//RBXIgemg46xeUojJr5KcoNjofwcx555YUG8IKjhfh4NdYBLVs15ZOxwt
ofhIddmF2+dMOpIBKKeJqdcwtDulMvOxLQgXQFZtt8xWQYzHlqZ3gPYfwA0mNo7O
jcKn9aiB+S3h+Zt5sd1xdsq2nYu/USbHSCP5kPV5UOifyvs14rkHvF3uI0+tW7Ny
MFGzOiZE6PfG/EUv0P4dkAetqAcQRIy1ltfVR5gBPENOi1oEHwhd7zutKBOtWfbW
Fd02Qq5Ejl9dj1Tyr5T0wIJryexz5OhOOff9Hxsle3OaVXx/b31VCV5O5eKnR4FJ
hylc0RrztDIpCgmJuMRa8SLtRCSOzgOvyWAlRJQUYT9iBPS47dj5AAV+dmUjIkeN
DEy62Xo/slqCcNOIsIin+2qjye+wzVsOrC/HbujC6hx4REBA1JFbeENHeJZD+kpz
EteIoCggoiN8zWTBMjA4jJZ860QyAqSHZsutBfoRENbOD88KLcKs8rU43hlR0zag
fDsXbG6TW+F90YFIWzBsKtgeJSJhoTZpqP+5ypsXEtxxfnlyak4Kui5iYtkFtW2N
xhdGfWXAvGn6p8PZru0ZlR3rw+NrIb56NkjU78jy1/ADqbZPD36BnZYDnnnlmy0d
iDzN2jqyo+uuJBe5YLvzsf31ZmkYPv683EyGXlJydVNcXiUAr9s=
=WDrJ
-----END PGP SIGNATURE-----


gfleury wrote 5 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 42197@debbugs.gnu.org)
db2574a45fe13a3f4d99e01980829517@disroot.org
hello,

16 juillet 2020 22:18 "Efraim Flashner" <efraim@flashner.co.il> a écrit:

Toggle quote (3 lines)
> This looks good to me. Have you tested it with anything? I don't have a
> D project to test it out with.

yes. I compile gtkd and some d simple code i wrote.
but gdc alone don't work like gfortran that why it is hidden.
Toggle quote (5 lines)
>
> --
> Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner wrote 5 years ago
(address . gfleury@disroot.org)(address . 42197-done@debbugs.gnu.org)
20200719172506.GC7307@E5400
On Sat, Jul 18, 2020 at 08:30:02PM +0000, gfleury@disroot.org wrote:
Toggle quote (10 lines)
> hello,
>
> 16 juillet 2020 22:18 "Efraim Flashner" <efraim@flashner.co.il> a écrit:
>
> > This looks good to me. Have you tested it with anything? I don't have a
> > D project to test it out with.
>
> yes. I compile gtkd and some d simple code i wrote.
> but gdc alone don't work like gfortran that why it is hidden.

Sounds good to me. Patch pushed! Thanks.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl8UgfEACgkQQarn3Mo9
g1GLzRAApPhaTNkDLwKEB+hctJLEsHrXulx9ZjF3579OQn1ejmx+/c+e2oD/JhrD
Cnp3Nq8GtIFbhN/N9BvUqc8InBHm/zQWVUGC4rjkH32c5AiE7swAW7EGkzeiMXr/
y0nKh25+BBvuocUWk/91mC71iRXiErc1pYtJI2V/LDepx1JfzTnAXQscGp+SDl2U
b4REwpr+hhBJdAAx2+wqviJtUL+aBqbumDz0Jk41ZBq9QAK6x0WCIf7QM/5SqwPT
q9fOfdlGzVW24eZ3kzeNIfEb46FKmQrEy/1e2RYRBqwpOsJGzbnE1zrcVeP9z20q
wZBDaUrBrJ66qqwpyhVX86zRU2S70l0tsSGtrQQnWjKThKMyTVjvI9DCvZEf6gyn
EZmqzAKOPUvlY+NYbpiGPzDiRhjj+208lJSy7AOxd4JqIz/mIT6/oGJnHmn3celV
UELehm7UOTDrTcTggaq1YOKSuXC1OktatoR07bD3GlIBt+d1vwB2RpHmGouUChYk
ihVJC22p25tGdHSGx7+SOJDoC7vyQD1T0vev7BeMlhIIErTDvx0npdnsEDonLgYN
9iSbPUNHFSxhObsy9Uwz6UVHpn54CyT8ULRWUlJnIA2abUQD8fewj1jrQVXxBDdg
PD2QhxAD9WAJFM2YDb9n9/r+LZiSc07RklUy+iE4yjGCyC70moc=
=wSZB
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42197@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42197
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help