guy fleury iteriteka wrote 5 years ago
(address . guix-patches@gnu.org)
* gnu/packages/commencement.scm(gdc-toolchain): New variable.
---
gnu/packages/commencement.scm | 8 ++++++++
1 file changed, 8 insertions(+)
Toggle diff (27 lines)
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index ef250e0..510bf0b 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3909,5 +3910,12 @@ Fortran development to be installed in user profiles. This includes
gfortran, as well as libc (headers and binaries, plus debugging symbols
in the @code{debug} output), and binutils.")))
+(define-public gdc-toolchain
+ (package (inherit (make-gcc-toolchain gdc))
+ (synopsis "Complete GCC tool chain for D development")
+ (description "This package provides a complete GCC tool chain for
+D development to be installed in user profiles. This includes
+gdc, as well as libc (headers and binaries, plus debugging symbols
+in the @code{debug} output), and binutils.")))
;;; commencement.scm ends here
--
2.25.1