[PATCH 2/2] gnu: Add gdc-toolchain.

  • Done
  • quality assurance status badge
Details
2 participants
  • guy fleury iteriteka
  • Ludovic Courtès
Owner
unassigned
Submitted by
guy fleury iteriteka
Severity
normal

Debbugs page

guy fleury iteriteka wrote 5 years ago
(address . guix-patches@gnu.org)
20200704140025.3602-2-gfleury@disroot.org
* gnu/packages/commencement.scm(gdc-toolchain): New variable.
---
gnu/packages/commencement.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index ef250e0..510bf0b 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3909,5 +3910,12 @@ Fortran development to be installed in user profiles. This includes
gfortran, as well as libc (headers and binaries, plus debugging symbols
in the @code{debug} output), and binutils.")))
+(define-public gdc-toolchain
+ (package (inherit (make-gcc-toolchain gdc))
+ (synopsis "Complete GCC tool chain for D development")
+ (description "This package provides a complete GCC tool chain for
+D development to be installed in user profiles. This includes
+gdc, as well as libc (headers and binaries, plus debugging symbols
+in the @code{debug} output), and binutils.")))
;;; commencement.scm ends here
--
2.25.1
Ludovic Courtès wrote 5 years ago
(name . guy fleury iteriteka)(address . gfleury@disroot.org)(address . 42196-done@debbugs.gnu.org)
87d04lb3kc.fsf@gnu.org
Hi,

guy fleury iteriteka <gfleury@disroot.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/commencement.scm(gdc-toolchain): New variable.

This was commit in 7b2ab96a6efcd30ce12371cac101f1f965ff20b8, closing!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42196@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42196
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help