[PATCH] gnu: Add emacs-literate-calc-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 4 Jul 2020 04:15
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB21054DCA8D09F60A9001AAB1C56B0@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-literate-calc-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d829a38add..3cfb8c4ad6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3520,6 +3520,28 @@ in Lisp modes.")
(description "This package provides dynamic evaluation in Emacs.")
(license license:gpl3+))))
+(define-public emacs-literate-calc-mode
+ (package
+ (name "emacs-literate-calc-mode")
+ (version "20200703.723")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/literate-calc-mode-"
+ version ".el"))
+ (sha256
+ (base32
+ "1ck5ha12jrs6sfhhf3yaydji49bzakrk59agspg5xynxv22aka1v"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/sulami/literate-calc-mode.el")
+ (synopsis "Literate programming for Emacs calc")
+ (description "Displays inline results for calculations, supports
+variables and updates as you type (if you want). Also works in your
+favourite markup mode.")
+ (license license:gpl3+)))
+
(define-public emacs-string-inflection
(package
(name "emacs-string-inflection")
--
2.27.0
N
N
Nicolas Goaziou wrote on 7 Jul 2020 14:37
(address . Morgan.J.Smith@outlook.com)(address . 42183@debbugs.gnu.org)
874kqj7b83.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-literate-calc-mode): New variable.

Thank you.

Toggle quote (2 lines)
> + (version "20200703.723")

Even though there is no actual release, the version, as specified in the
".el" file, is "0.1". So you need to bind a `version' and a `revision',
and add a comment about it at the top of the package.

Toggle quote (6 lines)
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://melpa.org/packages/literate-calc-mode-"
> + version ".el"))

We don't use source from MELPA. Please use `git-fetch' instead.

Toggle quote (4 lines)
> + (sha256
> + (base32
> + "1ck5ha12jrs6sfhhf3yaydji49bzakrk59agspg5xynxv22aka1v"))))

Please move the hash on the same line as `base32'.

Toggle quote (6 lines)
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-s" ,emacs-s)))
> + (home-page "https://github.com/sulami/literate-calc-mode.el")
> + (synopsis "Literate programming for Emacs calc")

-> for Emacs Calc

Toggle quote (4 lines)
> + (description "Displays inline results for calculations, supports
> +variables and updates as you type (if you want). Also works in your
> +favourite markup mode.")

The description should contain complete sentences, e.g.

This library displays inline results... and supports...

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
M
M
Morgan.J.Smith wrote on 11 Jul 2020 04:08
[PATCH] gnu: Add emacs-literate-calc-mode.
(address . 42183@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB2105FB317E0C43BA95F3CBB7C5620@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-literate-calc-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 89fed81059..a438e13234 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3542,6 +3542,30 @@ in Lisp modes.")
(description "This package provides dynamic evaluation in Emacs.")
(license license:gpl3+))))
+(define-public emacs-literate-calc-mode
+ (let ((commit "e855bd718fa7d0d70b8f43264e10664369dd3a37")
+ (revision "0"))
+ (package
+ (name "emacs-literate-calc-mode")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sulami/literate-calc-mode.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mk4cig8g8ibz97mvyan79fkypyanh7r0h7h20ibafq09nb0mw01"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/sulami/literate-calc-mode.el")
+ (synopsis "Literate programming for Emacs Calc")
+ (description "An Emacs minor mode that displays inline results for
+calculations. There is support for variables and real time updates.")
+ (license license:gpl3+))))
+
(define-public emacs-string-inflection
(package
(name "emacs-string-inflection")
--
2.27.0
N
N
Nicolas Goaziou wrote on 14 Jul 2020 11:10
(address . Morgan.J.Smith@outlook.com)(address . 42183-done@debbugs.gnu.org)
87h7ua1mxw.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-literate-calc-mode): New variable.

I tweaked the description and applied your patch. Thank you!

Regards,
--
Nicolas Goaziou
Closed
?