[PATCH 0/3] Add GNOME Builder

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
c7c2875ab149a3fdcea03965a92982806d7beb1a.camel@student.tugraz.at
Hi Guix,

seeing how this has been long on the Guix wishlist, I've decided to
package GNOME Builder. I don't yet have the complete package; support
for clang, flatpak and glade is currently missing, but the basics
should work to some extent. Bear in mind, that I only did some light
usage testing, so there may be bugs I'm missing.

Regards, Leo
Leo Prikler wrote 5 years ago
[PATCH 1/3] gnu: Add sysprof.
(address . 42177@debbugs.gnu.org)
20200703103713.3510-1-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (sysprof): New variable.
---
gnu/packages/gnome.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d2e452d8f2..520129618c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10465,3 +10465,49 @@ GObject introspection bindings.")
(home-page "https://source.puri.sm/Librem5/feedbackd")
(license (list license:lgpl2.1+ ; libfeedbackd
license:lgpl3+)))) ; the rest
+
+(define-public sysprof
+ (package
+ (name "sysprof")
+ (version "3.34.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1l4kr1av7933vb4zql9c5lgzivlw64hyky4nr8xin1v5if6vnjw4"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-Dsystemdunitdir="
+ %output
+ "/share/systemd"))
+ #:tests? #f ; 3/4 test-model-filter barfs some dbus nonsense
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-install-script
+ (lambda _
+ (substitute* "build-aux/meson/post_install.sh"
+ (("gtk-update-icon-cache") "true")
+ (("update-desktop-database") "true"))
+ #t)))))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libdazzle" ,libdazzle)
+ ("polkit" ,polkit)))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin") ; for gdbus-codegen, etc.
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)
+ ("xmllint" ,libxml2)))
+ (home-page "http://www.sysprof.com/")
+ (synopsis "System-wide Performance Profiler")
+ (description "Sysprof is a sampling profiler that uses a kernel module
+to generate stacktraces which are then interpreted by the userspace program
+``sysprof''.")
+ (license (list license:gpl2+
+ license:gpl3+))))
--
2.27.0
Leo Prikler wrote 5 years ago
[PATCH 2/3] gnu: Add template-glib.
(address . 42177@debbugs.gnu.org)
20200703103713.3510-2-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (template-glib): New variable.
---
gnu/packages/gnome.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 520129618c..c0517a5421 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10511,3 +10511,32 @@ to generate stacktraces which are then interpreted by the userspace program
``sysprof''.")
(license (list license:gpl2+
license:gpl3+))))
+
+(define-public template-glib
+ (package
+ (name "template-glib")
+ (version "3.34.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1z9xkin5fyfh071ma9y045jcw83hgx33dfbjraw6cxk0qdmfysr1"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin")
+ ("vala" ,vala)))
+ (home-page "https://gitlab.gnome.org/GNOME/template-glib")
+ (synopsis "Library for template expansion")
+ (description "Template-GLib is a library to help you generate text based
+on a template and user defined state. Template-GLib does not use a language
+runtime, so it is safe to use from any GObject-Introspectable language.")
+ (license license:lgpl2.1+)))
--
2.27.0
Leo Prikler wrote 5 years ago
[PATCH 3/3] gnu: Add gnome-builder.
(address . 42177@debbugs.gnu.org)
20200703103713.3510-3-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (gnome-builder): New variable.
---
gnu/packages/gnome.scm | 66 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 66 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c0517a5421..2ea608d9bb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10540,3 +10540,69 @@ to generate stacktraces which are then interpreted by the userspace program
on a template and user defined state. Template-GLib does not use a language
runtime, so it is safe to use from any GObject-Introspectable language.")
(license license:lgpl2.1+)))
+
+(define-public gnome-builder
+ (package
+ (name "gnome-builder")
+ (version "3.36.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "17pvmd5jypar8dkr6w56hvf7jnq4l1wih2wwgkrv7sblr7rkkar2"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags (list "-Dnetwork_tests=false"
+ ;; TODO: Enable all plugins...
+ "-Dplugin_clang=false"
+ "-Dplugin_flatpak=false"
+ "-Dplugin_glade=false"
+ ;; ... except this one.
+ "-Dplugin_update_manager=false")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-meson
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "build-aux/meson/post_install.py"
+ (("gtk-update-icon-cache") "true")
+ (("update-desktop-database") "true"))
+ (substitute* "src/libide/meson.build"
+ (("/usr/lib")
+ (string-append (assoc-ref inputs "python-pygobject")
+ "/lib")))
+ #t))
+ (add-before 'check 'pre-check
+ (lambda _
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (inputs
+ `(("devhelp" ,devhelp)
+ ("gspell" ,gspell)
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)
+ ("jsonrpc-glib" ,jsonrpc-glib)
+ ("libdazzle" ,libdazzle)
+ ("libgit2-glib" ,libgit2-glib)
+ ("libpeas" ,libpeas)
+ ("python-pygobject" ,python-pygobject)
+ ("sysprof" ,sysprof)
+ ("template-glib" ,template-glib)
+ ("vte" ,vte)
+ ("webkitgtk" ,webkitgtk)))
+ (propagated-inputs
+ `(("gtksourceview" ,gtksourceview))) ; needed for settings
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils) ;for desktop-file-validate
+ ("glib:bin" ,glib "bin")
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)
+ ("xorg-server" ,xorg-server-for-tests)))
+ (home-page "https://wiki.gnome.org/Apps/Builder")
+ (synopsis "Toolsmith for GNOME-based applications")
+ (description "Builder aims to be an IDE for writing GNOME-based software.")
+ (license license:gpl3+)))
--
2.27.0
Ludovic Courtès wrote 5 years ago
Re: [bug#42177] [PATCH 1/3] gnu: Add sysprof.
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 42177@debbugs.gnu.org)
87lfjrxebp.fsf@gnu.org
Hi,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (sysprof): New variable.

Applied with the changes below:
Toggle diff (17 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2d3270782c..3c9596cc1d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10486,9 +10486,8 @@ GObject introspection bindings.")
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)))
(home-page "http://www.sysprof.com/")
- (synopsis "System-wide Performance Profiler")
+ (synopsis "System-wide performance profiler")
(description "Sysprof is a sampling profiler that uses a kernel module
to generate stacktraces which are then interpreted by the userspace program
-``sysprof''.")
- (license (list license:gpl2+
- license:gpl3+))))
+@command{sysprof}.")
+ (license license:gpl3+)))
Ludovic Courtès wrote 5 years ago
Re: [bug#42177] [PATCH 2/3] gnu: Add template-glib.
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 42177@debbugs.gnu.org)
87h7ufxdzl.fsf@gnu.org
Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (template-glib): New variable.

This one was unnecessary: we already have it. :-)
Ludovic Courtès wrote 5 years ago
Re: [bug#42177] [PATCH 3/3] gnu: Add gnome-builder.
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 42177-done@debbugs.gnu.org)
87d053xdyo.fsf@gnu.org
Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (gnome-builder): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42177@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42177
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help