Morgan.J.Smith wrote 5 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/emacs-xyz.scm (emacs-bluetooth): New variable.
---
gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1941379dea..8aaa19e615 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23403,3 +23403,32 @@ easily. Four pre-set options are: @samp{shell}, @samp{terminal},
@samp{ansi-term}, and @samp{eshell}. You can also set your custom shell if
you use some other configuration.")
(license license:gpl3+))))
+
+(define-public emacs-bluetooth
+ (package
+ (name "emacs-bluetooth")
+ (version "0.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/rstocker/emacs-bluetooth")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vxpi3jkx066dg57m0yaf3m689zai938rn0s7qn7aga7m8lcmvm0"))))
+ (build-system emacs-build-system)
+ (inputs `(("bluez" ,bluez)))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://gitlab.com/rstocker/emacs-bluetooth")
+ (synopsis "Manage Bluetooth devices using an Emacs UI")
+ (description "Supports the following actions:
+(un-)pairing devices,
+(dis-)connecting,
+discovery mode,
+setting device properties (alias, blocked, trusted),
+setting adapter properties (powered, discoverable, pairable),
+showing device information (alias, address, RSSI, class, services),
+Imenu integration")
+ (license license:gpl3+)))
--
2.27.0