[PATCH] gnu: Add emacs-bluetooth.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 5 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB21058AB9518FA0EA9DEF9A31C56A0@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-bluetooth): New variable.
---
gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1941379dea..8aaa19e615 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23403,3 +23403,32 @@ easily. Four pre-set options are: @samp{shell}, @samp{terminal},
@samp{ansi-term}, and @samp{eshell}. You can also set your custom shell if
you use some other configuration.")
(license license:gpl3+))))
+
+(define-public emacs-bluetooth
+ (package
+ (name "emacs-bluetooth")
+ (version "0.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/rstocker/emacs-bluetooth")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vxpi3jkx066dg57m0yaf3m689zai938rn0s7qn7aga7m8lcmvm0"))))
+ (build-system emacs-build-system)
+ (inputs `(("bluez" ,bluez)))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://gitlab.com/rstocker/emacs-bluetooth")
+ (synopsis "Manage Bluetooth devices using an Emacs UI")
+ (description "Supports the following actions:
+(un-)pairing devices,
+(dis-)connecting,
+discovery mode,
+setting device properties (alias, blocked, trusted),
+setting adapter properties (powered, discoverable, pairable),
+showing device information (alias, address, RSSI, class, services),
+Imenu integration")
+ (license license:gpl3+)))
--
2.27.0
Nicolas Goaziou wrote 5 years ago
(address . Morgan.J.Smith@outlook.com)(address . 42171-done@debbugs.gnu.org)
87tuyo5i1l.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-bluetooth): New variable.

Thanks.

I switched to GNU ELPA repository and pushed. I fumbled in the patch
attribution in the process, sorry about that.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42171@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42171
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help