[PATCH] gnu: Add emacs-org-beautify-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 5 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB210503FE5C80E22F0AA438B8C56A0@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-org-beautify-theme): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1941379dea..c435e312b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -76,6 +76,7 @@
;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23403,3 +23404,24 @@ easily. Four pre-set options are: @samp{shell}, @samp{terminal},
@samp{ansi-term}, and @samp{eshell}. You can also set your custom shell if
you use some other configuration.")
(license license:gpl3+))))
+
+(define-public emacs-org-beautify-theme
+ (package
+ (name "emacs-org-beautify-theme")
+ (version "0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonnay/org-beautify-theme")
+ (commit "df6a1114fda313e1689363e196c8284fbe2a2738")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lkz7736swimad12khwbbqc4gxjydgr1k45p4mx03s25pv1w920y"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jonnay/org-beautify-theme")
+ (synopsis "Theme to make org mode look more beautiful")
+ (description "Adds padding between headings, increases the size of
+titles, strike through completed TODO headings, changes org blocks,
+changes org check boxes, and more.")
+ (license license:gpl3+)))
--
2.27.0
Nicolas Goaziou wrote 5 years ago
(address . Morgan.J.Smith@outlook.com)(address . 42170-done@debbugs.gnu.org)
8736686xi8.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-beautify-theme): New variable.

Thank you.

I fixed indentation, added a comment explaining why we don't use
a specific tag, slightly fixed description, and committed your patch.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42170@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42170
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help