python-grequests broken, add zope dependencies to fix.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Efraim Flashner
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal
C
C
Christopher Lemmer Webber wrote on 1 Jul 2020 22:39
(address . bug-guix@gnu.org)
87zh8jynpy.fsf@dustycloud.org
Fix attached. Ok to push?
From 1fc31863857361e9f88d92cbea2099fd7ea03b10 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Wed, 1 Jul 2020 16:36:29 -0400
Subject: [PATCH] gnu: python-grequests: Fix tests by adding zope dependencies.

* gnu/packages/python-web.scm (python-grequests): Add zope
dependencies to native-inputs for tests.
---
gnu/packages/python-web.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 030abef9c2..c929e254f7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2010,7 +2010,9 @@ library.")
`(("python-gevent" ,python-gevent)
("python-requests" ,python-requests)))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-nose" ,python-nose)
+ ("python-zope.interface" ,python-zope-interface)
+ ("python-zope.event" ,python-zope-event)))
(home-page "https://github.com/kennethreitz/grequests")
(synopsis "Python library for asynchronous HTTP requests")
(description "GRequests is a Python library that allows you to use
--
2.26.2
E
E
Efraim Flashner wrote on 2 Jul 2020 09:27
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 42158@debbugs.gnu.org)
20200702072733.GF6387@E5400
On Wed, Jul 01, 2020 at 04:39:05PM -0400, Christopher Lemmer Webber wrote:
Toggle quote (3 lines)
> Fix attached. Ok to push?
>

Looks good to me. I will note however that the test suite doesn't seem
to actually be run.

Toggle quote (8 lines)
> From 1fc31863857361e9f88d92cbea2099fd7ea03b10 Mon Sep 17 00:00:00 2001
> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
> Date: Wed, 1 Jul 2020 16:36:29 -0400
> Subject: [PATCH] gnu: python-grequests: Fix tests by adding zope dependencies.
>
> * gnu/packages/python-web.scm (python-grequests): Add zope
> dependencies to native-inputs for tests.

should be:

* gnu/packages/python-web.scm (python-grequests)[native-inputs]:
Add python-zope.interface, python-zope.event.


Toggle quote (24 lines)
> ---
> gnu/packages/python-web.scm | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 030abef9c2..c929e254f7 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -2010,7 +2010,9 @@ library.")
> `(("python-gevent" ,python-gevent)
> ("python-requests" ,python-requests)))
> (native-inputs
> - `(("python-nose" ,python-nose)))
> + `(("python-nose" ,python-nose)
> + ("python-zope.interface" ,python-zope-interface)
> + ("python-zope.event" ,python-zope-event)))
> (home-page "https://github.com/kennethreitz/grequests")
> (synopsis "Python library for asynchronous HTTP requests")
> (description "GRequests is a Python library that allows you to use
> --
> 2.26.2
>


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl79jGUACgkQQarn3Mo9
g1EXshAAoNU4mK+tlpRYs55EBHvnB3RiTcOZIbw4bK1bTUOr6kgj8mb1SicjvpyU
jxATskA4hv6P9O8dCP0NH1+jFXx5uygzXNfyvHWgSzF5fKDPSPulqgbKY+NdNNK2
zS1oV4VJNRY1pT4Z4Es/vgOFuKd6RIGQHA4JwSKc4b/Lu4f67shTIN37jBKcRSyj
jZrUb/6dCsnoC8+5nkxKvwx+BiIYFxKOKvPGJHWu7M808YggSnN4EM6fjFAxs9AD
cb2VIvbABlN8EJvYZfO8HqutCs0u6mIAGqzvrPW+sKXXY+LSZ0QrwJRtgC4xPipl
yfaYDIGBN7OfSXD5kMy4z1c+Q9cEYYt//VzvcJEKi1oNrQQjVEXSaWyj5jJcvfOp
6/4E72gm/TsDrfsfOm3J3gvljwFuvou6lp+rlLVC4fpcd84TRIMXS5xiuboZOQ7/
VyDzFPTGi48zl0x8Tk6Qz5aPEOiuBLloTGGZBMXN0nKK/+G/9kP6ikCYppjK8Rk0
EqGd6V5oFX4xpAQDadO/d62U6Wy9nvayq3qDgJOxIiuoJ7Xinv5/QWpkLh2whxP8
oZbi+jBazgCSIhEfDXRmsWmSmlWzBCdcW57aYdIEYd+lEoQt7yVZsYe9KGNyhWJL
Hxg41IaCPsuI33DMljL4tkzwvz/a4ip+pFeNL1Dg3100bXAiKSI=
=bgNL
-----END PGP SIGNATURE-----


C
C
Christopher Lemmer Webber wrote on 2 Jul 2020 14:16
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 42158-done@debbugs.gnu.org)
87a70iyuvu.fsf@dustycloud.org
Efraim Flashner writes:

Toggle quote (7 lines)
> On Wed, Jul 01, 2020 at 04:39:05PM -0400, Christopher Lemmer Webber wrote:
>> Fix attached. Ok to push?
>>
>
> Looks good to me. I will note however that the test suite doesn't seem
> to actually be run.

Huh. Well at least it's no longer breaking, which is what was happening
for me before.

Toggle quote (14 lines)
>> From 1fc31863857361e9f88d92cbea2099fd7ea03b10 Mon Sep 17 00:00:00 2001
>> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
>> Date: Wed, 1 Jul 2020 16:36:29 -0400
>> Subject: [PATCH] gnu: python-grequests: Fix tests by adding zope dependencies.
>>
>> * gnu/packages/python-web.scm (python-grequests): Add zope
>> dependencies to native-inputs for tests.
>
> should be:
>
> * gnu/packages/python-web.scm (python-grequests)[native-inputs]:
> Add python-zope.interface, python-zope.event.
>

Done. Changed and pushed!

Toggle quote (22 lines)
>> ---
>> gnu/packages/python-web.scm | 4 +++-
>> 1 file changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
>> index 030abef9c2..c929e254f7 100644
>> --- a/gnu/packages/python-web.scm
>> +++ b/gnu/packages/python-web.scm
>> @@ -2010,7 +2010,9 @@ library.")
>> `(("python-gevent" ,python-gevent)
>> ("python-requests" ,python-requests)))
>> (native-inputs
>> - `(("python-nose" ,python-nose)))
>> + `(("python-nose" ,python-nose)
>> + ("python-zope.interface" ,python-zope-interface)
>> + ("python-zope.event" ,python-zope-event)))
>> (home-page "https://github.com/kennethreitz/grequests")
>> (synopsis "Python library for asynchronous HTTP requests")
>> (description "GRequests is a Python library that allows you to use
>> --
>> 2.26.2
>>
Closed
?