Christopher Lemmer Webber wrote 5 years ago
(address . bug-guix@gnu.org)
Fix attached. Ok to push?
From 1fc31863857361e9f88d92cbea2099fd7ea03b10 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Wed, 1 Jul 2020 16:36:29 -0400
Subject: [PATCH] gnu: python-grequests: Fix tests by adding zope dependencies.
* gnu/packages/python-web.scm (python-grequests): Add zope
dependencies to native-inputs for tests.
---
gnu/packages/python-web.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Toggle diff (17 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 030abef9c2..c929e254f7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2010,7 +2010,9 @@ library.")
`(("python-gevent" ,python-gevent)
("python-requests" ,python-requests)))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-nose" ,python-nose)
+ ("python-zope.interface" ,python-zope-interface)
+ ("python-zope.event" ,python-zope-event)))
(home-page "https://github.com/kennethreitz/grequests")
(synopsis "Python library for asynchronous HTTP requests")
(description "GRequests is a Python library that allows you to use
--
2.26.2