[PATCH] gnu: Add r-transphylo

  • Done
  • quality assurance status badge
Details
2 participants
  • Antoine Côté
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Antoine Côté
Severity
normal
A
A
Antoine Côté wrote on 29 Jun 2020 17:05
(address . guix-patches@gnu.org)(name . Antoine Côté)(address . antoine.cote@posteo.net)
20200629150517.28452-1-antoine.cote@posteo.net
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70af2d30f0..749eee7856 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Danjela Lura <danielaluraa@gmail.com>
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
+;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22372,3 +22373,27 @@ using @dfn{SHAP} (Shapley additive explanation) visualization plots for
and force plot. It relies on the @code{XGBoost} package to produce SHAP
values.")
(license license:expat)))
+
+(define-public r-transphylo
+ (package
+ (name "r-transphylo")
+ (version "1.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "TransPhylo" version))
+ (sha256
+ (base32
+ "1506c97y8dnhd0c38rgvmg70q0l3xmmn07mjglhnw7hi5n5y9mv9"))))
+ (properties `((upstream-name . "TransPhylo")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ape" ,r-ape) ("r-rcpp" ,r-rcpp)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://cran.r-project.org/web/packages/TransPhylo/")
+ (synopsis
+ "Inference of Transmission Tree from a Dated Phylogeny")
+ (description
+ "Inference of transmission tree from a dated phylogeny. Includes methods to simulate and analyse outbreaks. The methodology is described in Didelot et al. (2014) <doi:10.1093/molbev/msu121>, Didelot et al. (2017) <doi:10.1093/molbev/msw275>.")
+ (license license:gpl2+)))
--
2.27.0
R
R
Ricardo Wurmus wrote on 11 Sep 2020 10:53
(name . Antoine Côté)(address . antoine.cote@posteo.net)(address . 42126-done@debbugs.gnu.org)
87blic3dad.fsf@elephly.net
Hi Antoine,

thank you for your patch!

I have updated the description and synopsis, fixed the indentation, and
pushed the patch to the “master” branch with commit 5412b14ba6.

My apologies for the delay!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42126@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42126
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch