[PATCH] gnu: Add guix-simplyblack-sddm-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 28 Jun 2020 01:37
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@gmail.com)
20200627233757.189714-1-plattfot@gmail.com
* gnu/packages/display-managers.scm (guix-simplyblack-sddm-theme): New variable.
---
gnu/packages/display-managers.scm | 32 +++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index c96b693dc3..ba587b2333 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -27,9 +27,11 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system qt)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -123,6 +125,36 @@ create smooth, animated user interfaces.")
;; QML files are MIT licensed and images are CC BY 3.0.
(license (list license:gpl2+ license:expat license:cc-by3.0))))
+(define-public guix-simplyblack-sddm-theme
+ (package
+ (name "guix-simplyblack-sddm-theme")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/plattfot/guix-simplyblack-sddm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fwny6b0xpjs8ad2b16pyxd27gf0sr0nillmhc2h5k0q7dva21vi"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (sddm-themes (string-append out "/share/sddm/themes")))
+ (mkdir-p sddm-themes)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ (string-append sddm-themes "/guix-simplyblack-sddm"))))))
+ (home-page "https://github.com/plattfot/guix-simplyblack-sddm")
+ (synopsis "Guix based theme for SDDM")
+ (description "Simple theme for SDDM, black background with Guix's
+logo. Based on Arch linux's archlinux-simplyblack theme.")
+ ;; Theme under cc-by-sa3.0, guix logo under license:cc-by-sa4.0
+ (license (list license:cc-by-sa3.0 license:cc-by-sa4.0))))
+
(define-public lightdm
(package
(name "lightdm")
--
2.26.2
L
L
Ludovic Courtès wrote on 3 Jul 2020 23:42
(name . Fredrik Salomonsson)(address . plattfot@gmail.com)(address . 42098-done@debbugs.gnu.org)
87lfk0mg0z.fsf@gnu.org
Hi Fredrik,

Fredrik Salomonsson <plattfot@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/display-managers.scm (guix-simplyblack-sddm-theme): New variable.

Applied with the changes below, thanks!

Ludo’.
Toggle diff (23 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index ba587b2333..ef6e549d09 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 L p R n d n <guix@lprndn.info>
+;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -150,8 +151,9 @@ create smooth, animated user interfaces.")
(string-append sddm-themes "/guix-simplyblack-sddm"))))))
(home-page "https://github.com/plattfot/guix-simplyblack-sddm")
(synopsis "Guix based theme for SDDM")
- (description "Simple theme for SDDM, black background with Guix's
-logo. Based on Arch linux's archlinux-simplyblack theme.")
+ (description
+ "This package provides a simple theme for SDDM, black background with
+Guix's logo. Based on Arch linux's archlinux-simplyblack theme.")
;; Theme under cc-by-sa3.0, guix logo under license:cc-by-sa4.0
(license (list license:cc-by-sa3.0 license:cc-by-sa4.0))))
Closed
?