[PATCH 0/2] gnu: emacs-nov-el: Update to 0.3.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 5 years ago
(address . guix-patches@gnu.org)(name . Simon South)(address . simon@simonsouth.net)
cover.1593287683.git.simon@simonsouth.net
These two patches together update emacs-nov-el, an Emacs major mode for
reading EPUB documents, to version 0.3.1.

The first patch undoes changes made in commits f0dab65 and 3d84967 to use a
commit identifier in place of a version tag, as the upstream repository has
now restored these tags.

The second patch updates the package to version 0.3.1.

--
Simon South
simon@simonsouth.net


Simon South (2):
gnu: emacs-nov-el: Use version tag instead of commit.
gnu: emacs-nov-el: Update to 0.3.1.

gnu/packages/emacs-xyz.scm | 65 ++++++++++++++++++--------------------
1 file changed, 31 insertions(+), 34 deletions(-)

--
2.26.2
Simon South wrote 5 years ago
[PATCH 1/2] gnu: emacs-nov-el: Use version tag instead of commit.
(address . 42093@debbugs.gnu.org)(name . Simon South)(address . simon@simonsouth.net)
9ee7db8615b71c43ddc1ffbb3c38e218c0580d74.1593287683.git.simon@simonsouth.net
* gnu/packages/emacs-xyz.scm (emacs-nov-el): Remove let binding and associated
comment; correct indentation.
[source]: Use version tag as commit identifier now that upstream has restored
this information.
---
gnu/packages/emacs-xyz.scm | 65 ++++++++++++++++++--------------------
1 file changed, 31 insertions(+), 34 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8b03ce347c..c83a7f5d95 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12550,39 +12550,36 @@ the format.")
(license license:gpl3+)))
(define-public emacs-nov-el
- ;; Upstream does not tag releases. Specify raw commit hash matching the
- ;; release.
- (let ((commit "ea0c835c1b5e6e70293f4bd64e9c89bdc42f8596"))
- (package
- (name "emacs-nov-el")
- (version "0.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://depp.brause.cc/nov.el.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "04phmm14ywgicjsl2bsg6w9rapd71vdkxdp5wp0brj6px27y85jz"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'embed-path-to-unzip
- (lambda _
- (substitute* "nov.el"
- (("\\(executable-find \"unzip\"\\)")
- (string-append "\"" (which "unzip") "\"")))
- #t)))))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-esxml" ,emacs-esxml)))
- (inputs
- `(("unzip" ,unzip)))
- (home-page "https://depp.brause.cc/nov.el/")
- (synopsis "Major mode for reading EPUBs in Emacs")
- (description "@code{nov.el} provides a major mode for reading EPUB
+ (package
+ (name "emacs-nov-el")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://depp.brause.cc/nov.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04phmm14ywgicjsl2bsg6w9rapd71vdkxdp5wp0brj6px27y85jz"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'embed-path-to-unzip
+ (lambda _
+ (substitute* "nov.el"
+ (("\\(executable-find \"unzip\"\\)")
+ (string-append "\"" (which "unzip") "\"")))
+ #t)))))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-esxml" ,emacs-esxml)))
+ (inputs
+ `(("unzip" ,unzip)))
+ (home-page "https://depp.brause.cc/nov.el/")
+ (synopsis "Major mode for reading EPUBs in Emacs")
+ (description "@code{nov.el} provides a major mode for reading EPUB
documents.
Features:
@@ -12599,7 +12596,7 @@ Features:
@item Image rescaling
@end itemize
")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public epipe
(package
--
2.26.2
Simon South wrote 5 years ago
[PATCH 2/2] gnu: emacs-nov-el: Update to 0.3.1.
(address . 42093@debbugs.gnu.org)(name . Simon South)(address . simon@simonsouth.net)
03fea9627d225e175cd42a43649daa2f0824aa45.1593287684.git.simon@simonsouth.net
* gnu/packages/emacs-xyz.scm (emacs-nov-el): Update to 0.3.1.
---
gnu/packages/emacs-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c83a7f5d95..c92d77e95e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12552,7 +12552,7 @@ the format.")
(define-public emacs-nov-el
(package
(name "emacs-nov-el")
- (version "0.3.0")
+ (version "0.3.1")
(source
(origin
(method git-fetch)
@@ -12561,7 +12561,7 @@ the format.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "04phmm14ywgicjsl2bsg6w9rapd71vdkxdp5wp0brj6px27y85jz"))))
+ (base32 "13r7lvyyyv62m57m4s4xjs4qz2ckhqk6ib514px7qzc7mdzcz9i9"))))
(build-system emacs-build-system)
(arguments
`(#:phases
--
2.26.2
Efraim Flashner wrote 5 years ago
Re: [bug#42093] [PATCH 0/2] gnu: emacs-nov-el: Update to 0.3.1.
(name . Simon South)(address . simon@simonsouth.net)(address . 42093-done@debbugs.gnu.org)
20200628075446.GC1070@E5400
On Sat, Jun 27, 2020 at 04:08:52PM -0400, Simon South wrote:
Toggle quote (25 lines)
> These two patches together update emacs-nov-el, an Emacs major mode for
> reading EPUB documents, to version 0.3.1.
>
> The first patch undoes changes made in commits f0dab65 and 3d84967 to use a
> commit identifier in place of a version tag, as the upstream repository has
> now restored these tags.
>
> The second patch updates the package to version 0.3.1.
>
> --
> Simon South
> simon@simonsouth.net
>
>
> Simon South (2):
> gnu: emacs-nov-el: Use version tag instead of commit.
> gnu: emacs-nov-el: Update to 0.3.1.
>
> gnu/packages/emacs-xyz.scm | 65 ++++++++++++++++++--------------------
> 1 file changed, 31 insertions(+), 34 deletions(-)
>
> --
> 2.26.2
>

Both patches look good. Patches pushed!


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl74TMYACgkQQarn3Mo9
g1Eseg/9FBoqoDl6iopEPCRRZUnUUEpSdhQA926lTHgJjoAjAs8Gkl4k/wR0rZRm
60cGod1hbQIo4HoUrtJqSaaGDIDg2uPWsF31lds5GLWcC5KVFuUzhM8S4eY+9ora
JdAdR3zuyPUS2/10vNuc4Y3dNbHqWvk5bOlPZBfR9RKwyxn3RboBNO2vHibgB3Hj
2Naj98VA1CdXnZoAMO6qu4mhiplQZD/Q5nCAZcy9xoKLqvmMIrbu9RGxVMNO57Vb
Km1aPTvaoomJ44DkldRaNLxF6lqVIeTpwmKbWenBx84IcmX0C9oreLuG1/oiNDcl
43m1LfB3XukfqhKcThXLoPcHJCSRdVvL4Btg272Ixk+Ewyi3i9qHOUtHGnrBEA0q
h2m6MBeFAF1fdFa0uVCcey/9RgqAvAmDbQP82JExZsX3mog3OCc/C3O7JLwFPa0n
csaP/ZkO8qqDTd5b9UtgERX3WeYco2Rv/ptm1XACSIsEZiPxiRvoVrjha5BUXUjp
YAJ2c+orCweZkmn7RUoFahE4EZJvZj21VUk5ligI6rnjoOSMC9J+lUA6RYBHUThc
kJOepWvofVClWGyo2jCSCMDeh2e5MdgifvAGZWK5V84bHd2npwGsBxE7vlI8kDn8
tUUgP0VyB5cd48gTO0/2WRSZVbXonjQoGh8H+XTne0rkqoNrhuk=
=pWZ/
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42093@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42093
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help