[PATCH] gnu: Add r-shapforxgboost.

  • Done
  • quality assurance status badge
Details
2 participants
  • Peter Lo
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Peter Lo
Severity
normal
P
P
Peter Lo wrote on 27 Jun 2020 19:48
(address . guix-patches@gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200627174858.10656-1-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-shapforxgboost): New variable.
---
gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..8e2a9433c1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,38 @@ across a wide array of bioinformatic R packages.")
and clustering large sequence datasets using fast alignment-free k-mer
counting and recursive k-means partitioning.")
(license license:gpl3)))
+
+(define-public r-shapforxgboost
+ (package
+ (name "r-shapforxgboost")
+ (version "0.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "SHAPforxgboost" version))
+ (sha256
+ (base32
+ "0k6bg27wqnkzv82bcahbapmqhiz6rvnx81m23zbjw58c7lwshgnq"))))
+ (properties
+ `((upstream-name . "SHAPforxgboost")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bbmisc" ,r-bbmisc)
+ ("r-data-table" ,r-data-table)
+ ("r-ggextra" ,r-ggextra)
+ ("r-ggforce" ,r-ggforce)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggpubr" ,r-ggpubr)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-xgboost" ,r-xgboost)))
+ (home-page
+ "https://github.com/liuyanguu/SHAPforxgboost")
+ (synopsis "SHAP Plots for 'XGBoost'")
+ (description
+ "The aim of @code{SHAPforxgboost} is to aid in visual data
+investigations using SHAP (SHapley Additive exPlanation) visualization
+plots for @code{XGBoost}. It provides summary plot, dependence plot,
+interaction plot, and force plot. It relies on the 'dmlc/xgboost'
+package to produce SHAP values. Please refer to 'slundberg/shap' for
+the original implementation of SHAP in 'Python'.")
+ (license license:expat)))
--
2.17.1
R
R
Ricardo Wurmus wrote on 27 Jun 2020 23:18
(name . Peter Lo)(address . peterloleungyau@gmail.com)(address . 42090-done@debbugs.gnu.org)
87k0zsp5qy.fsf@elephly.net
Hi Peter,

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-shapforxgboost): New variable.

Thank you!

I made a couple of minor changes and pushed it to the master branch with
commit bc36937431.

--
Ricardo
Closed
?