[PATCH] gnu: Add r-rselenium and its dependencies.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Lo Peter
Owner
unassigned
Submitted by
Lo Peter
Severity
normal
L
L
Lo Peter wrote on 27 Jun 2020 13:46
(address . guix-patches@gnu.org)
CAEM+zmjrsv8pa15RAcpNLXCfBGCjp09agBSNTT6gJe1nni6QSA@mail.gmail.com
Dear all,

I am submitting a patch series for r-rselenium and its dependencies.

Regards,
Peter Lo
P
P
Peter Lo wrote on 27 Jun 2020 13:48
[PATCH 1/4] gnu: Add r-semver.
(address . 42080@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200627114823.10738-1-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-semver): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab5e57c0e2..218071e891 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22325,3 +22325,30 @@ across a wide array of bioinformatic R packages.")
and clustering large sequence datasets using fast alignment-free k-mer
counting and recursive k-means partitioning.")
(license license:gpl3)))
+
+(define-public r-semver
+ (package
+ (name "r-semver")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "semver" version))
+ (sha256
+ (base32
+ "10wpkyms2cix3bsin2q0qhkbl445pwwpa5gm2s4jjw1989namkxy"))))
+ (properties `((upstream-name . "semver")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-rcpp" ,r-rcpp)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page
+ "https://github.com/johndharrison/semver")
+ (synopsis "'Semantic Versioning V2.0.0' Parser")
+ (description
+ "Tools and functions for parsing, rendering and operating on
+semantic version strings. Semantic versioning is a simple set of
+rules and requirements that dictate how version numbers are assigned
+and incremented as outlined at <http://semver.org>.")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 27 Jun 2020 13:48
[PATCH 2/4] gnu: Add r-binman.
(address . 42080@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200627114823.10738-2-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-binman): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 218071e891..88e84d5866 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22352,3 +22352,34 @@ semantic version strings. Semantic versioning is a simple set of
rules and requirements that dictate how version numbers are assigned
and incremented as outlined at <http://semver.org>.")
(license license:expat)))
+
+(define-public r-binman
+ (package
+ (name "r-binman")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "binman" version))
+ (sha256
+ (base32
+ "0hm0h285p4v9lhrqjy8s22f1s1vmfpfla5iaycpj8vw3qb3632az"))))
+ (properties `((upstream-name . "binman")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-httr" ,r-httr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-semver" ,r-semver)
+ ("r-xml2" ,r-xml2)
+ ("r-yaml" ,r-yaml)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/ropensci/binman")
+ (synopsis "A Binary Download Manager")
+ (description
+ "Tools and functions for managing the download of binary files.
+Binary repositories are defined in 'YAML' format. Defining new
+pre-download, download and post-download templates allow additional
+repositories to be added.")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 27 Jun 2020 13:48
[PATCH 3/4] gnu: Add r-wdman.
(address . 42080@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200627114823.10738-3-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-wdman): New variable.
---
gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 88e84d5866..e2eb06b5db 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22383,3 +22383,38 @@ Binary repositories are defined in 'YAML' format. Defining new
pre-download, download and post-download templates allow additional
repositories to be added.")
(license license:expat)))
+
+(define-public r-wdman
+ (package
+ (name "r-wdman")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "wdman" version))
+ (sha256
+ (base32
+ "1yf41lsrr9dbf5n4f5hv9mlmzl736fhnp9gxkm2g9apws6gsig02"))))
+ (properties `((upstream-name . "wdman")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-binman" ,r-binman)
+ ("r-processx" ,r-processx)
+ ("r-semver" ,r-semver)
+ ("r-yaml" ,r-yaml)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://docs.ropensci.org/wdman")
+ (synopsis
+ "'Webdriver'/'Selenium' Binary Manager")
+ (description
+ "There are a number of binary files associated with the
+'Webdriver'/'Selenium' project (see
+<http://www.seleniumhq.org/download/>,
+<https://sites.google.com/a/chromium.org/chromedriver/>,
+<https://github.com/mozilla/geckodriver>,
+<http://phantomjs.org/download.html> and
+<https://github.com/SeleniumHQ/selenium/wiki/InternetExplorerDriver>
+for more information). This package provides functions to download
+these binaries and to manage processes involving them.")
+ (license license:expat)))
--
2.17.1
P
P
Peter Lo wrote on 27 Jun 2020 13:48
[PATCH 4/4] gnu: Add r-rselenium.
(address . 42080@debbugs.gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20200627114823.10738-4-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-rselenium): New variable.
---
gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e2eb06b5db..48a619956e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22418,3 +22418,39 @@ repositories to be added.")
for more information). This package provides functions to download
these binaries and to manage processes involving them.")
(license license:expat)))
+
+(define-public r-rselenium
+ (package
+ (name "r-rselenium")
+ (version "1.7.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RSelenium" version))
+ (sha256
+ (base32
+ "1xn5fdbzmq7b1f5fc9ls23g177bmnd8bn4p4d8aafr6z3jwkmfir"))))
+ (properties `((upstream-name . "RSelenium")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-binman" ,r-binman)
+ ("r-catools" ,r-catools)
+ ("r-httr" ,r-httr)
+ ("r-openssl" ,r-openssl)
+ ("r-wdman" ,r-wdman)
+ ("r-xml" ,r-xml)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "http://docs.ropensci.org/RSelenium")
+ (synopsis "R Bindings for 'Selenium WebDriver'")
+ (description
+ "This package provides a set of R bindings for the 'Selenium 2.0
+WebDriver' (see <https://selenium.dev/documentation/en/> for more
+information) using the 'JsonWireProtocol' (see
+<https://github.com/SeleniumHQ/selenium/wiki/JsonWireProtocol> for
+more information). 'Selenium 2.0 WebDriver' allows driving a web
+browser natively as a user would either locally or on a remote machine
+using the Selenium server it marks a leap forward in terms of web
+browser automation. Selenium automates web browsers (commonly
+referred to as browsers). Using RSelenium you can automate browsers
+locally or remotely.")
+ (license license:agpl3+)))
--
2.17.1
L
L
Ludovic Courtès wrote on 13 Jul 2020 12:52
Re: [bug#42080] [PATCH] gnu: Add r-rselenium and its dependencies.
(name . Lo Peter)(address . peterloleungyau@gmail.com)(address . 42080-done@debbugs.gnu.org)
87r1tfsn4c.fsf@gnu.org
Hi Peter,

Lo Peter <peterloleungyau@gmail.com> skribis:

Toggle quote (2 lines)
> I am submitting a patch series for r-rselenium and its dependencies.

I’ve applied the whole series, thanks! I tweaked synopses and
descriptions here and there to placate ‘guix lint’ and to more closely
follow the guidelines at:


Thank you,
Ludo’.
Closed
L
L
Lo Peter wrote on 14 Jul 2020 03:00
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 42080-done@debbugs.gnu.org)
CAEM+zmiw7J9ZEC8_ibikCKeLnsy-tt=ce7zb0Y90T3-xCpqbGw@mail.gmail.com
Great, thanks!

On Mon, Jul 13, 2020 at 6:52 PM Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (15 lines)
>
> Hi Peter,
>
> Lo Peter <peterloleungyau@gmail.com> skribis:
>
> > I am submitting a patch series for r-rselenium and its dependencies.
>
> I’ve applied the whole series, thanks! I tweaked synopses and
> descriptions here and there to placate ‘guix lint’ and to more closely
> follow the guidelines at:
>
> https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html
>
> Thank you,
> Ludo’.
Closed
?