[PATCH] gnu: mumble: Fix mumble-overlay.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20200625134618.13491-1-leo.prikler@student.tugraz.at
The canonical mumble-overlay script searches for libmumble.so.1 in various
directories, none of which are relevant in Guix installations and
additionally does some work to match the architecture of the library to that
of the command that will be executed.
This work is unnecessary in Guix and only causes the script to fail, so we
instead just hardcode the path.

* gnu/packages/telephony.scm (mumble)[#:phases]: Add fix-mumble-overlay.
---
gnu/packages/telephony.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 4c84ddc85a..542d36a841 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -588,6 +588,16 @@ address of one of the participants.")
(substitute* "src/mumble/Settings.cpp"
(("bUsage = true;") "bUsage = false;"))
#t))
+ (add-before 'configure 'fix-mumble-overlay
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-output-to-file "scripts/mumble-overlay"
+ (lambda ()
+ (format #t "#!~a~%" (which "bash"))
+ (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
+ (string-append (assoc-ref outputs "out")
+ "/lib/mumble/libmumble.so.1"))
+ (format #t "exec \"${@}\"")))
+ #t))
(add-before 'install 'disable-murmur-ice
(lambda _
(substitute* "scripts/murmur.ini.system"
--
2.26.2
Ludovic Courtès wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 42040-done@debbugs.gnu.org)
87wo3qevru.fsf@gnu.org
Hi,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (9 lines)
> The canonical mumble-overlay script searches for libmumble.so.1 in various
> directories, none of which are relevant in Guix installations and
> additionally does some work to match the architecture of the library to that
> of the command that will be executed.
> This work is unnecessary in Guix and only causes the script to fail, so we
> instead just hardcode the path.
>
> * gnu/packages/telephony.scm (mumble)[#:phases]: Add fix-mumble-overlay.

Applied, thanks!

The original ‘script/mumble-overlay’ script is surprisingly complex.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42040@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42040
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help