[PATCH] gnu: Add ruby-minitest-global-expectations.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
20200624201311.6607-1-mail@cbaines.net
This will be required to update ruby-minitest-hooks.

* gnu/packages/ruby.scm (ruby-minitest-global-expectations): New variable.
---
gnu/packages/ruby.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 08c55e4e3c..baac8af7ee 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3487,6 +3487,30 @@ written using either the unit test or spec style.")
(home-page "https://github.com/splattael/minitest-around")
(license license:expat)))
+(define-public ruby-minitest-global-expectations
+ (package
+ (name "ruby-minitest-global-expectations")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri
+ "minitest-global_expectations"
+ version))
+ (sha256
+ (base32
+ "1pp3k2608spj4kvqy2y16hs18an917g6vwgvphrfhjviac83090x"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-minitest" ,ruby-minitest)))
+ (synopsis "Adjust minitest behaviour for calling expectation methods")
+ (description
+ "Minitest-global_expectations allows continued use of expectation methods
+on all objects. Calling expectation methods on all objects was deprecated in
+minitest 5.12, and is planned to be removed from minitest 6.")
+ (home-page "https://github.com/jeremyevans/minitest-global_expectations")
+ (license license:expat)))
+
(define-public ruby-minitest-sprint
(package
(name "ruby-minitest-sprint")
--
2.26.2
Christopher Baines wrote 4 years ago
(address . 42035-done@debbugs.gnu.org)
87pn5ch5un.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (43 lines)
> This will be required to update ruby-minitest-hooks.
>
> * gnu/packages/ruby.scm (ruby-minitest-global-expectations): New variable.
> ---
> gnu/packages/ruby.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
> index 08c55e4e3c..baac8af7ee 100644
> --- a/gnu/packages/ruby.scm
> +++ b/gnu/packages/ruby.scm
> @@ -3487,6 +3487,30 @@ written using either the unit test or spec style.")
> (home-page "https://github.com/splattael/minitest-around")
> (license license:expat)))
>
> +(define-public ruby-minitest-global-expectations
> + (package
> + (name "ruby-minitest-global-expectations")
> + (version "1.0.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (rubygems-uri
> + "minitest-global_expectations"
> + version))
> + (sha256
> + (base32
> + "1pp3k2608spj4kvqy2y16hs18an917g6vwgvphrfhjviac83090x"))))
> + (build-system ruby-build-system)
> + (propagated-inputs
> + `(("ruby-minitest" ,ruby-minitest)))
> + (synopsis "Adjust minitest behaviour for calling expectation methods")
> + (description
> + "Minitest-global_expectations allows continued use of expectation methods
> +on all objects. Calling expectation methods on all objects was deprecated in
> +minitest 5.12, and is planned to be removed from minitest 6.")
> + (home-page "https://github.com/jeremyevans/minitest-global_expectations")
> + (license license:expat)))
> +
> (define-public ruby-minitest-sprint
> (package
> (name "ruby-minitest-sprint")

Pushed to master as ff9d33a9038a1375235485093b2557a4c2949e34.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+PaSBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdASA//aiLMCYGw1GWXPY1Q03IV+LAubBVTEEvD
+xd/7Ug7FYhYVSbeqTGHJM+Kh50J/cfRnQw+tcYc3xz6LJ1N1kB1ZUy8Xlhh6nMS
YMl0RDVVEC9tfiFg5XjbJEEb6ax9H25506jlXhHqU6hYVkPzPJALOrAlYFzla3WD
eqq2f2+aIkpzLiyw8+j7IUb4/CPA49bxp+uZ4GG7JqJV808n8A2LGWChYh2P3zt0
6Hb14Dtf0LqTJ/qlorIouBMdKGry1gS/VMAuKImLWny9fqw63WzGAFjvouqcMIu3
jNfb4p+BSMYa9rLsTb6ugfBgQnXOkrf6PAgnPStNW7NNZWMzdhGGvHKhZgblRJ21
YRPSfT17rACVroaWykANGAQs1bSlZcmjS4hdqYOFQo03rA2pts8sSOkSGBkD5RjT
f7c0WzSABXdrzg2HmOGkF4K74Mj3JMlZdUmF2WAq7qVYE3+mwKthwYSTevZCR2ee
QbwKQhLrKjDDxw3G03RjqUbrmX5VZXqvu3bJzb2rrj5o34iPcDirqtxEyX/C+RH/
EdPTqlKT6sbCKUbEVtE4d51JTJivfeAnKay8H0TlW6rkn8Vf7OQLtd0J4UOEwcsW
5frDjZ1j14+SrDzdjvr1+3QQG1+ypQtJJnq17i2t75hMzLo++a2pYCac4SOjKqoO
xlNnMX4ifI8=
=Rzwx
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 42035@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 42035
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help