Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
This will be required to update ruby-minitest-hooks.
* gnu/packages/ruby.scm (ruby-minitest-global-expectations): New variable.
---
gnu/packages/ruby.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 08c55e4e3c..baac8af7ee 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3487,6 +3487,30 @@ written using either the unit test or spec style.")
(home-page "https://github.com/splattael/minitest-around")
(license license:expat)))
+(define-public ruby-minitest-global-expectations
+ (package
+ (name "ruby-minitest-global-expectations")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri
+ "minitest-global_expectations"
+ version))
+ (sha256
+ (base32
+ "1pp3k2608spj4kvqy2y16hs18an917g6vwgvphrfhjviac83090x"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-minitest" ,ruby-minitest)))
+ (synopsis "Adjust minitest behaviour for calling expectation methods")
+ (description
+ "Minitest-global_expectations allows continued use of expectation methods
+on all objects. Calling expectation methods on all objects was deprecated in
+minitest 5.12, and is planned to be removed from minitest 6.")
+ (home-page "https://github.com/jeremyevans/minitest-global_expectations")
+ (license license:expat)))
+
(define-public ruby-minitest-sprint
(package
(name "ruby-minitest-sprint")
--
2.26.2