[PATCH 0/5] Update python-plotly and python-pandas

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Marius Bakke
  • Pierre Langlois
Owner
unassigned
Submitted by
Pierre Langlois
Severity
normal
P
P
Pierre Langlois wrote on 20 Jun 2020 20:22
(address . guix-patches@gnu.org)
87r1u9ha11.fsf@gmx.com
Hi Guix!

Recently I wanted to use python-plotly and realized our package could do
with an update, but to do that I also had to update the python-pandas
package otherwise tests wouldn't pass.

So in the end I got 5 patches all together :-).

* gnu: deeptools: Deprecate in favor of python-deeptools.

deeptools and python-deeptools are the same package, I looked at
them since they depend on plotly. I thought I'd merge them as a
drive-by fix.

* gnu: python-pandas: Update to 1.0.5.

I also had to keep versions 0.25 for the python-biom-format package.

* gnu: Add python-retrying.
* gnu: Add python-xarray.

New dependencies.

* gnu: python-plotly: Update to 4.8.1.

I've also had to keep the version 2.4.1 around for the
python-deeptools package.

WDYT?

Thanks,
Pierre
P
P
Pierre Langlois wrote on 20 Jun 2020 20:28
[PATCH 1/5] gnu: deeptools: Deprecate in favor of python-deeptools.
(address . 41968@debbugs.gnu.org)(name . Pierre Langlois)(address . pierre.langlois@gmx.com)
87k101h9rk.fsf@gmx.com
From b46bef2216620ac085bea41762904b16f2c6aec5 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Sat, 20 Jun 2020 18:42:04 +0200
Subject: [PATCH 1/5] gnu: deeptools: Deprecate in favor of python-deeptools.

And make sure python-deeptools's tests are running.

* gnu/packages/bioinformatics.scm (python-deeptools): Fetch source using git.
[native-inputs]: Add python-mock and python-nose.
(deeptools): Mark as deprecated.
---
gnu/packages/bioinformatics.scm | 61 +++++++--------------------------
1 file changed, 13 insertions(+), 48 deletions(-)

Toggle diff (105 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 95f8b16db3..580488fc49 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
+;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,7 @@
#:use-module (guix build-system ruby)
#:use-module (guix build-system scons)
#:use-module (guix build-system trivial)
+ #:use-module (guix deprecation)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages algebra)
@@ -2406,12 +2408,18 @@ interval trees with associated meta-data. It is primarily used by the
(name "python-deeptools")
(version "3.4.3")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "deepTools" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deeptools/deepTools.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1azgjniss5ff6a90nicdjkxyjwqmi3gzfn09gra42hwlz19hipxb"))))
+ "0l09vyynz6s6w7fnyd94rpys4a6aja6kp4gli64pngdxdz3md1nl"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
(propagated-inputs
`(("python-matplotlib" ,python-matplotlib)
("python-numpy" ,python-numpy)
@@ -2436,6 +2444,8 @@ annotations of the genome.")
;; remainder of the code is licensed under the MIT license.
(license (list license:bsd-3 license:expat))))
+(define-deprecated deeptools python-deeptools)
+
(define-public cutadapt
(package
(name "cutadapt")
@@ -2599,51 +2609,6 @@ trees (phylogenies) and characters.")
with Python.")
(license license:expat)))
-(define-public deeptools
- (package
- (name "deeptools")
- (version "3.1.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/deeptools/deepTools.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1vggnf52g6q2vifdl4cyi7s2fnfqq0ky2zrkj5zv2qfzsc3p3siw"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; This phase fails, but it's not needed.
- (delete 'reset-gzip-timestamps))))
- (inputs
- `(("python-plotly" ,python-plotly)
- ("python-scipy" ,python-scipy)
- ("python-numpy" ,python-numpy)
- ("python-numpydoc" ,python-numpydoc)
- ("python-matplotlib" ,python-matplotlib)
- ("python-pysam" ,python-pysam)
- ("python-py2bit" ,python-py2bit)
- ("python-pybigwig" ,python-pybigwig)))
- (native-inputs
- `(("python-mock" ,python-mock) ;for tests
- ("python-nose" ,python-nose) ;for tests
- ("python-pytz" ,python-pytz))) ;for tests
- (home-page "https://github.com/deeptools/deepTools")
- (synopsis "Tools for normalizing and visualizing deep-sequencing data")
- (description
- "DeepTools addresses the challenge of handling the large amounts of data
-that are now routinely generated from DNA sequencing centers. To do so,
-deepTools contains useful modules to process the mapped reads data to create
-coverage files in standard bedGraph and bigWig file formats. By doing so,
-deepTools allows the creation of normalized coverage files or the comparison
-between two files (for example, treatment and control). Finally, using such
-normalized and standardized files, multiple visualizations can be created to
-identify enrichments with functional annotations of the genome.")
- (license license:gpl3+)))
-
(define-public delly
(package
(name "delly")
--
2.26.2
P
P
P
Pierre Langlois wrote on 20 Jun 2020 20:30
[PATCH 3/5] gnu: Add python-retrying.
(address . 41968@debbugs.gnu.org)(name . Pierre Langlois)(address . pierre.langlois@gmx.com)
87blldh9p3.fsf@gmx.com
From f5ab03bda4a872db340349ef837776314501513e Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Thu, 18 Jun 2020 00:57:49 +0200
Subject: [PATCH 3/5] gnu: Add python-retrying.

* gnu/packages/python-xyz.scm (python-retrying): New variable.
---
gnu/packages/python-xyz.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e95dec21c2..4a22b42ac2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -61,7 +61,7 @@
;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019, 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019, 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
@@ -17701,6 +17701,39 @@ on regular expressions.")
`(("python2-enum34" ,python2-enum34)
,@(package-propagated-inputs reparser))))))
+(define-public python-retrying
+ (package
+ (name "python-retrying")
+ (version "1.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rholder/retrying.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kqipkbdaw5s1xg0gi29awm03vp1x8dz24pjidgxagvkvrjpzhi7"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/rholder/retrying")
+ (synopsis "Library for adding retry behavior")
+ (description "Retrying is a general-purpose retrying library to simplify
+the task of adding retry behavior to just about anything.
+
+Features:
+
+@itemize
+@item Generic Decorator API.
+@item Specify stop condition (i.e. limit by number of attempts).
+@item Specify wait condition (i.e. exponential backoff sleeping between attempts).
+@item Customize retrying on Exceptions.
+@item Customize retrying on expected returned result.
+@end itemize")
+ (license license:asl2.0)))
+
(define-public python-precis-i18n
(package
(name "python-precis-i18n")
--
2.26.2
P
P
Pierre Langlois wrote on 20 Jun 2020 20:30
[PATCH 4/5] gnu: Add python-xarray.
(address . 41968@debbugs.gnu.org)(name . Pierre Langlois)(address . pierre.langlois@gmx.com)
877dw1h9ob.fsf@gmx.com
From 27ec21904f769c1e8114f767972d9037e1e9f68a Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Thu, 18 Jun 2020 00:58:02 +0200
Subject: [PATCH 4/5] gnu: Add python-xarray.

* gnu/package/python-science.scm (python-xarray): New variable.
---
gnu/packages/python-science.scm | 35 +++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 55fc1be4f9..9348894530 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -354,3 +354,38 @@ doing practical, real world data analysis in Python.")
(("if 'NULL byte' in msg:")
"if 'NULL byte' in msg or 'line contains NUL' in msg:"))
#t)))))))
+
+(define-public python-xarray
+ (package
+ (name "python-xarray")
+ (version "0.15.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "xarray" version))
+ (sha256
+ (base32
+ "1yx8j66b7rn10m2l6gmn8yr9cn38pi5cj0x0wwpy4hdnhy6i7qv4"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest"))))))
+ (home-page "https://github.com/pydata/xarray")
+ (synopsis "N-D labeled arrays and datasets")
+ (description "Xarray (formerly xray) makes working with labelled
+multi-dimensional arrays simple, efficient, and fun!
+
+Xarray introduces labels in the form of dimensions, coordinates and attributes
+on top of raw NumPy-like arrays, which allows for a more intuitive, more
+concise, and less error-prone developer experience. The package includes a
+large and growing library of domain-agnostic functions for advanced analytics
+and visualization with these data structures.")
+ (license license:asl2.0)))
--
2.26.2
P
P
P
Pierre Langlois wrote on 22 Jun 2020 18:44
Re: bug#41968: Acknowledgement ([PATCH 0/5] Update python-plotly and python-pandas)
(address . 41968-done@debbugs.gnu.org)
87eeq73v9i.fsf@gmx.com
Thanks for merging Ludo!

Closing.

Pierre
Closed
M
M
Marius Bakke wrote on 24 Jun 2020 21:08
87zh8s704v.fsf@gnu.org
Pierre Langlois <pierre.langlois@gmx.com> writes:

Toggle quote (2 lines)
> Thanks for merging Ludo!

By the way, consider applying for commit access, as you have delivered a
steady stream of quality patches. I'll vouch for you. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7zpJAACgkQoqBt8qM6
VPrpWwf/QUcCDmyBNQHwFULBrZqIiwtm7NW4w5BSPrf4g/a2KUL1s1it8f96od50
v99iTkrV2979w+KG20feWB44B+70cdKkTMiUoWPy0YUXnfd4wrE4Z6f7ziK1g4dn
JUX8+8drxb4uzvehRAbQ5N+wn4Y3uRW7FuR/YWtMAWU0loAQMD2eIN+ANscrVC90
JevhLaWez1kX1PWHiw6W1ch0oq7ls1gTgTCb0yQUXOAhUJ3YwI3UrDRzJteFFSBw
l+zeR06ufvOEyJ6OITZUwmoa1kjXy+UySdOZxPhkFPkv6t7NHH7My0XTAQkq9VNg
mnL/Vv+IyfO3FmUmNguAwGjXQmO/EQ==
=ax2/
-----END PGP SIGNATURE-----

Closed
L
L
Leo Famulari wrote on 26 Jun 2020 05:20
Re: [bug#41968] Acknowledgement ([PATCH 0/5] Update python-plotly and python-pandas)
(name . Marius Bakke)(address . marius@gnu.org)
20200626032054.GA5771@jasmine.lan
On Wed, Jun 24, 2020 at 09:08:00PM +0200, Marius Bakke wrote:
Toggle quote (7 lines)
> Pierre Langlois <pierre.langlois@gmx.com> writes:
>
> > Thanks for merging Ludo!
>
> By the way, consider applying for commit access, as you have delivered a
> steady stream of quality patches. I'll vouch for you. :-)

Yes, please!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl71aY8ACgkQJkb6MLrK
fwj/PQ/+KUHSRr2M7kUlPFyPbDt5Mw16YWYORH3aDeIEv49GwaO4Ob+Ezz9mCMwr
8xOthVIKexTGzG8+tmfW+fVvo86yLy0QrJXQ8wHF/rmCenIIb4brlAdoBZD7SEav
nTN2EyFtrWzBh+2RbbB2Hdmbyk5fZdmHnc4vwoeV4WGDYFoJAtgQE9jYzBdvRBSd
MkSDXYSpOfmK1NVXzvZv1K++bSBFMc05OuqHUIcQCBfB4fYG+G9fUoPyjQMaxgMa
WOEGy/Wbz4QqiIzZcjoLLgjaOHh0snvpjAdnYSdS2yfc34yXNUwRdYlZuflsZZhG
G1Ko+2L3/zcKifUZS/YGAsstHH63Hte+Xm4PfcixW6MFRxezjNGaC3SXA0LSmqlY
A9V0SZskygLFWGV3O//S/+CuFAPNggpUbCxbw3UlAI03dn7FrJol4ePGkrXffrWm
Cxtt/2mXjwwpCRIv/3f2eIsMMrl6gYlY+XldZndvIhH9dViLu+9te4fmoCrX8tP2
Gsq7MOCj4cZNsAQw96v3xjykS/hGtVqJyOvo4KOALkd/IK9LmzjQ5oze8mK8bIke
Qbxww0P9m2BnUi1fx9VZUdA5RxpwJjTrw/PdSZfH31sWIW8TzuJ1GgLtcXfa986a
aRqUc8e4zL6z/+gtAtB4wBVkIFbocMAfR55a6IIp0N2L0ssYtfs=
=K/eN
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41968@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41968
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch