Update crawl to 0.25.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal

Debbugs page

Christopher Lemmer Webber wrote 5 years ago
(address . guix-patches@gnu.org)
87sgevcfyg.fsf@dustycloud.org
Patch attached. The new version of Crawl is amazing. Completely
reworked spell system and everything!

However, apparently the -nodeps.tar.xz release is normally made before
the Debian release... since I expressed interest in packaging 0.25.0
asap one of the devs made the tarball themselves, but apparently from an
OSX machine, and it left all these ._* doodads in it, which broke
compilation. I added a couple of lines to get rid of them.

I'm not sure if they're going to release another tarball that removes
those; I guess if they do, that'll have a different hash. In the
meanwhile this does work.

I'm not sure if I should push it or not given the above. Maybe we
should wait to see if the dev responds to me on IRC about the ._* files.
(Apparently after the tournament is done, a 0.25.1 release is likely
soon anyway.)

- Chris
From 288f754bded0d4c306b3b29e1f8d11a90516b48f Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 16 Jun 2020 09:06:20 -0400
Subject: [PATCH] gnu: crawl: Update to 0.25.0.

* gnu/packages/games.scm (crawl): Update to 0.25.0.
---
gnu/packages/games.scm | 16 +++++++++++++---
1 file changed, 13 insertions(+), 3 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 10ac8cb550..e95effa992 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5264,7 +5264,7 @@ fish. The whole game is accompanied by quiet, comforting music.")
(define-public crawl
(package
(name "crawl")
- (version "0.24.0")
+ (version "0.25.0")
(source
(origin
(method url-fetch)
@@ -5277,8 +5277,18 @@ fish. The whole game is accompanied by quiet, comforting music.")
(string-append "http://crawl.develz.org/release/stone_soup-"
version "-nodeps.tar.xz")))
(sha256
- (base32 "0kdq6s12myxfdg75ma9x3ys2nd0xwb3xm2ynlmhg4628va0pnixr"))
- (patches (search-patches "crawl-upgrade-saves.patch"))))
+ (base32 "0rn1wjxdqw33caiwisfypm1j8cid3c9pz01ahicl17144zs29z3d"))
+ (patches (search-patches "crawl-upgrade-saves.patch"))
+ ;; The 0.25.0 -nodeps.tar.xz was built from an OSX machine; normally
+ ;; apparently it's built from a Debian machine before the Debian
+ ;; packages are made. These ._* files are binary and have the string
+ ;; "Mac OS X" in them... removing these seems to result in compilation
+ ;; again.
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file (find-files "." "^\\._"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("lua51" ,lua-5.1)
--
2.26.2
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAl7oxTcACgkQS8Alkl/4
9NNfOw//Xmy4itls+zzYJK/dK54Exl0oEV4fyoGmrFH7WYeattakRlFWRdrKSehC
ZHp+e4J/Da4n7p4Z26XP72Fwzt9z8vWDSpbLtDwjAvWLz6bq6913IgD9Qc3M2pb3
YT77zmSTAEQa7wLpTLUMUyDVKmkjVTLzRyG9HM0TItwRA2nQ0MvtLW92VRxb9wmH
lV6bhN4V0CuTEAxx1dgr/wRodsQ+zc6Jlal/auHMEyJymEOdWAp/azI1ShlsLXkW
C+TMsBFShR6z+bxTNSsr7V/d2bG8jVpVESQKPt1jXFSpCWGgNr6VKbENZ7bKi5IQ
0eicoIZNxPOh3Egmxf2c2mgj3mA0Vo7TByYEiEtqWeIFnn3mamB/O8HGuEfjyUwD
XrMQV3xBWhnBnRbay5APUshJ5FOxzrgponQfpfQ3kxn+8CjLAHtHZ5L/PlQvMgPE
G43WWHETstLQZ3+1RcMZgLLcGiLPmoj3KjKHCtFYZRQalWDRe0+eylpE/3wFxVx1
hT74jQMT+TIbmdpFh0eawzTADXgvrpf+vWaQIZwpFNVIgK1aYMmMppt1R/Z758lk
weG5+dQ7dDWeGtDCFw6gJSZUKTBfKMa6Q8ZGBpAwu0fFq5ZoqdrznACs898AKPJk
X+tSUko/PS2fuLLrivERskk+LW7/nvPopApsnF+iM6XdashECDs=
=JPAZ
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 5 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 41892@debbugs.gnu.org)
87d05zuiw4.fsf@elephly.net
Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

Toggle quote (3 lines)
> Patch attached. The new version of Crawl is amazing. Completely
> reworked spell system and everything!

This looks good to me.

Toggle quote (3 lines)
> I'm not sure if I should push it or not given the above. Maybe we
> should wait to see if the dev responds to me on IRC about the ._* files.

I think it’s fine. That’s one of the use cases for snippets.

--
Ricardo
Christopher Lemmer Webber wrote 5 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 41892-done@debbugs.gnu.org)
87o8pide2g.fsf@dustycloud.org
Ricardo Wurmus writes:

Toggle quote (12 lines)
> Christopher Lemmer Webber <cwebber@dustycloud.org> writes:
>
>> Patch attached. The new version of Crawl is amazing. Completely
>> reworked spell system and everything!
>
> This looks good to me.
>
>> I'm not sure if I should push it or not given the above. Maybe we
>> should wait to see if the dev responds to me on IRC about the ._* files.
>
> I think it’s fine. That’s one of the use cases for snippets.

Ok! It's pushed then.

(If someone notices that the hash becomes mismatched, it's probably
because the source did a re-upload removing those files... I don't know
if they will; haven't heard as such.)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41892@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41892
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help