[PATCH] gnu: libmateweather: Add patch to rename a timezone city.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Jonathan Brielmaier
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 5 years ago
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200615101001.30670-1-jonathan.brielmaier@web.de
This let the check phase succeed again.

* gnu/packages/mate.scm (libmateweather)[source]: Add patch.
* gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch: New
file.
* gnu/local.mk (dist_patch_DATA): Register it.
---
gnu/local.mk | 1 +
gnu/packages/mate.scm | 4 ++-
...ibmateweather-rename-godthab-to-nuuk.patch | 34 +++++++++++++++++++
3 files changed, 38 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch

Toggle diff (67 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 7333427850..c6293e4b1c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1186,6 +1186,7 @@ dist_patch_DATA = \
%D%/packages/patches/libmad-length-check.patch \
%D%/packages/patches/libmad-md_size.patch \
%D%/packages/patches/libmad-mips-newgcc.patch \
+ %D%/packages/patches/libmateweather-rename-godthab-to-nuuk.patch \
%D%/packages/patches/libmp4v2-c++11.patch \
%D%/packages/patches/libmpeg2-arm-private-symbols.patch \
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 8b548b5d8e..9b5d49b164 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -264,7 +264,9 @@ desktop and the mate-about program.")
name "-" version ".tar.xz"))
(sha256
(base32
- "094mnlczxq9crjj8z7dzs1zmwscdkbp54l3qjaf4a4bhd8lihv8d"))))
+ "094mnlczxq9crjj8z7dzs1zmwscdkbp54l3qjaf4a4bhd8lihv8d"))
+ (patches
+ (search-patches "libmateweather-rename-godthab-to-nuuk.patch"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
diff --git a/gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch b/gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch
new file mode 100644
index 0000000000..2cbe32d7b5
--- /dev/null
+++ b/gnu/packages/patches/libmateweather-rename-godthab-to-nuuk.patch
@@ -0,0 +1,34 @@
+https://github.com/mate-desktop/libmateweather/pull/77
+Makes check phase green again.
+
+From ea13e06563fb5fa53f8a9643156a64825e986acb Mon Sep 17 00:00:00 2001
+From: rbuj <robert.buj@gmail.com>
+Date: Fri, 22 May 2020 20:19:57 +0200
+Subject: [PATCH] Locations: America/Godthab was renamed to America/Nuuk
+
+---
+ data/Locations.xml.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/Locations.xml.in b/data/Locations.xml.in
+index 5488867..62529b9 100644
+--- a/data/Locations.xml.in
++++ b/data/Locations.xml.in
+@@ -6482,7 +6482,7 @@
+ -->
+ <name>Danmarkshavn</name>
+ </timezone>
+- <timezone id="America/Godthab">
++ <timezone id="America/Nuuk">
+ <!-- The primary timezone for Greenland, although sources
+ seem to point towards calling the area "Western
+ Greenland" rathern than just "Greenland".
+@@ -6502,7 +6502,7 @@
+ <name>Thule AFB</name>
+ </timezone>
+ </timezones>
+- <tz-hint>America/Godthab</tz-hint>
++ <tz-hint>America/Nuuk</tz-hint>
+ <city>
+ <!-- A city in Greenland.
+ The local name in Kalaallisut is "Uummannaq".
--
2.26.2
Efraim Flashner wrote 5 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 41869@debbugs.gnu.org)
20200615102935.GE1990@E5400
This looks like it could just be a snippet in the origin


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7nTY0ACgkQQarn3Mo9
g1Fn+xAAjCF3aVlv5pXGQv4vEVEFWG82vSzPzS5cjWQJ14p2a/7Yt5pLuQUNXe5s
gd6g7rc6q80c1TU96Ys6NsyCf34FywiKzpMZh7T0TltY81A58/gK3VBIUs7OyZIW
NcvbM1AUs+IzaruwMC2/cWHtAZdla7I+sbtBPNx/cUqOB1zQmCx/wBvazi21BzNO
1u4yhGWM4bYarwKXjyQ6qWy1jIdLbBc0jxtS6VafvAc+Kz89IG5tt7Izzxn609cF
OIl4qkEnpoGZKAq+RnbtzhDfO4bTfsnD7I7gruL70umFB8SZu9Dpx91pMBXpMj+d
UggSQOP8zU0Y+9tUawUE9Mxw0Vx84Qc3tP/kkEySFetv9IdJQpgwg5nYlvDihkfQ
ne4Jz21DFQMQjU6nHeDlnt7YIBmcSlUFYI6yZL41O7EH3EBGCiWBhVLqj5nAj8Gh
1CSr60ZdgX9k2b9A8N70YgmOAvkVJoqQ8vy9TVkTH1ZaMA6Yy5pKLJjNJiAxF+Ft
HzKVt2u9zdrHU1TQjrxLNiiBd+oNx2cy67CofFOfrxIRV1qwesKmB/e+1uFRNmC7
c9CXtY5jEyhhK2PwEJRR0lPl8LvORJueQiYyE4a6vvPfXYz1vrh4EtvuqkFwBvsV
nqjS/rFqYcYzndUlwNRSh43qBE+b//w1b9HN1E+Bf8MRU7L2ZqU=
=/2SY
-----END PGP SIGNATURE-----


Jonathan Brielmaier wrote 5 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 41869@debbugs.gnu.org)
ad7df21d-a05a-bcd9-68f0-8c55aecf6de8@web.de
Could be, but I'm more a fan of patches because it will fail after the
next update of the package. Snippets are easier to forget for clean up...

On 15.06.20 12:29, Efraim Flashner wrote:
Toggle quote (1 lines)
> This looks like it could just be a snippet in the origin
Jonathan Brielmaier wrote 5 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
ad202018-277a-a3ba-c2c2-e85fa585e9db@web.de
Closing. Mathieu did it in e23ec7144c264902ac13fa75e01a206e4d907e5a

On 15.06.20 12:38, Jonathan Brielmaier wrote:
Toggle quote (5 lines)
> Could be, but I'm more a fan of patches because it will fail after the
> next update of the package. Snippets are easier to forget for clean up...
>
> On 15.06.20 12:29, Efraim Flashner wrote:
>> This looks like it could just be a snippet in the origin
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41869@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41869
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help