* gnu/packages/bittorrent.scm (transmission): Update to 3.0.0.
[source]: Remove obsolete patch.
[inputs]: Remove unused inputs inotify-tools, cyrus-sasl, and file.
[license]: Correct the license field.
* gnu/packages/patches/transmission-CVE-2018-10756.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
---
gnu/local.mk | 1 -
gnu/packages/bittorrent.scm | 25 +++----
.../patches/transmission-CVE-2018-10756.patch | 71 -------------------
3 files changed, 9 insertions(+), 88 deletions(-)
delete mode 100644 gnu/packages/patches/transmission-CVE-2018-10756.patch
Toggle diff (175 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 583274235b..3b7415b540 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1541,7 +1541,6 @@ dist_patch_DATA = \
%D%/packages/patches/tipp10-fix-compiling.patch \
%D%/packages/patches/tipp10-remove-license-code.patch \
%D%/packages/patches/tk-find-library.patch \
- %D%/packages/patches/transmission-CVE-2018-10756.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
%D%/packages/patches/tomb-fix-errors-on-open.patch \
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 8b041cb3f5..c132aaead6 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Tomáš ?ech <sleep_walker@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -42,7 +42,6 @@
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
- #:use-module (gnu packages file)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -50,7 +49,6 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libevent)
- #:use-module (gnu packages linux)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages nettle)
#:use-module (gnu packages ncurses)
@@ -67,16 +65,15 @@
(define-public transmission
(package
(name "transmission")
- (version "2.94")
+ (version "3.00")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/transmission/transmission-releases/raw/"
- "master/transmission-" version ".tar.xz"))
- (patches (search-patches "transmission-CVE-2018-10756.patch"))
+ (uri (string-append "https://github.com/transmission/transmission"
+ "/releases/download/" version "/transmission-"
+ version ".tar.xz"))
(sha256
(base32
- "0zbbj7rlm6m7vb64x68a64cwmijhsrwx9l63hbwqs7zr9742qi1m"))))
+ "1wjmn96zrvmk8j1yz2ysmqd7a2x6ilvnwwapcvfzgxs2wwpnai4i"))))
(build-system glib-or-gtk-build-system)
(outputs '("out" ; library and command-line interface
"gui")) ; graphical user interface
@@ -92,8 +89,7 @@
(gui (assoc-ref outputs "gui")))
(mkdir-p (string-append gui "/bin"))
(rename-file (string-append out "/bin/transmission-gtk")
- (string-append gui
- "/bin/transmission-gtk"))
+ (string-append gui "/bin/transmission-gtk"))
;; Move the '.desktop' and icon files as well.
(mkdir (string-append gui "/share"))
@@ -104,12 +100,9 @@
'("applications" "icons" "pixmaps")))
#t)))))
(inputs
- `(("inotify-tools" ,inotify-tools)
- ("libevent" ,libevent)
+ `(("libevent" ,libevent)
("curl" ,curl)
- ("cyrus-sasl" ,cyrus-sasl)
("openssl" ,openssl)
- ("file" ,file)
("zlib" ,zlib)
("gtk+" ,gtk+)))
(native-inputs
@@ -131,7 +124,7 @@ DHT, µTP, PEX and Magnet Links.")
;; or any future license endorsed by Mnemosyne LLC.
;;
;; A few files files carry an MIT/X11 license header.
- (license l:gpl3+)))
+ (license (list l:gpl2 l:gpl3))))
(define-public libtorrent
(package
diff --git a/gnu/packages/patches/transmission-CVE-2018-10756.patch b/gnu/packages/patches/transmission-CVE-2018-10756.patch
deleted file mode 100644
index f9bdcf60aa..0000000000
--- a/gnu/packages/patches/transmission-CVE-2018-10756.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-Fix CVE-2018-10756:
-
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10756
-
-Patch copied from Fedora:
-
-https://src.fedoraproject.org/rpms/transmission/blob/master/f/2123adf8e5e1c2b48791f9d22fc8c747e974180e.patch
-
---- a/libtransmission/variant.c 2018-05-01 12:21:08.000000000 -0500
-+++ b/libtransmission/variant.c 2020-05-18 10:21:27.554214128 -0500
-@@ -820,7 +820,7 @@
- struct SaveNode
- {
- const tr_variant * v;
-- tr_variant sorted;
-+ tr_variant* sorted;
- size_t childIndex;
- bool isVisited;
- };
-@@ -849,26 +849,33 @@
-
- qsort (tmp, n, sizeof (struct KeyIndex), compareKeyIndex);
-
-- tr_variantInitDict (&node->sorted, n);
-+ node->sorted = tr_new(tr_variant, 1);
-+ tr_variantInitDict (node->sorted, n);
- for (i=0; i<n; ++i)
-- node->sorted.val.l.vals[i] = *tmp[i].val;
-+ node->sorted->val.l.vals[i] = *tmp[i].val;
- node->sorted.val.l.count = n;
-
- tr_free (tmp);
-
-- node->v = &node->sorted;
-+ v = node->sorted;
- }
- else
- {
-- node->v = v;
-+ node->sorted = NULL;
- }
-+
-+ node->v = v;
- }
-
- static void
- nodeDestruct (struct SaveNode * node)
- {
-- if (node->v == &node->sorted)
-- tr_free (node->sorted.val.l.vals);
-+ //TR_ASSERT(node != NULL);
-+ if (node->sorted != NULL)
-+ {
-+ tr_free(node->sorted->val.l.vals);
-+ tr_free(node->sorted);
-+ }
- }
-
- /**
---- a/libtransmission/variant.c 2020-05-18 10:21:49.000000000 -0500
-+++ b/libtransmission/variant.c 2020-05-18 10:24:34.673648865 -0500
-@@ -853,7 +853,7 @@
- tr_variantInitDict (node->sorted, n);
- for (i=0; i<n; ++i)
- node->sorted->val.l.vals[i] = *tmp[i].val;
-- node->sorted.val.l.count = n;
-+ node->sorted->val.l.count = n;
-
- tr_free (tmp);
-
-
--
2.26.2