gnu: icecat: Fix WebGL support

  • Done
  • quality assurance status badge
Details
2 participants
  • Ekaitz Zarraga
  • Julien Lepiller
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal

Debbugs page

Ekaitz Zarraga wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
XakVOmUEFcVCD_hh-kAWioIFCmcyksGVimPWaiEeLlVZFuKha6EhqWU4EuSiaNP5yhMZxdPqTellQMcaQEMlGuG6DxaIS4515hkYu1S0JaU=@elenq.tech
Hi,

I think this fixes WebGL support in IceCat:


Best!


From 382d45f95433be2f4c675b03e035daa253421371 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Thu, 11 Jun 2020 22:33:49 +0200
Subject: [PATCH] gnu: icecat: Fix WebGL support

* gnu/packages/gnuzilla.scm (icecat): Wrap mesa
---
gnu/packages/gnuzilla.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 7bf9850e97..570398ecd9 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1112,11 +1112,13 @@ from forcing GEXP-PROMISE."
(lib (string-append out "/lib"))
(gtk (assoc-ref inputs "gtk+"))
(gtk-share (string-append gtk "/share"))
+ (mesa (assoc-ref inputs "mesa"))
+ (mesa-lib (string-append mesa "/lib"))
(pulseaudio (assoc-ref inputs "pulseaudio"))
(pulseaudio-lib (string-append pulseaudio "/lib")))
(wrap-program (car (find-files lib "^icecat$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
- `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib)))
+ `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,mesa-lib)))
#t))))))
(home-page "https://www.gnu.org/software/gnuzilla/")
(synopsis "Entirely free browser derived from Mozilla Firefox")
--
2.26.2
Julien Lepiller wrote 5 years ago
(address . 41815-done@debbugs.gnu.org)(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
20200612013507.2037863f@tachikoma.lepiller.eu
Le Thu, 11 Jun 2020 20:40:48 +0000,
Ekaitz Zarraga <ekaitz@elenq.tech> a écrit :

Toggle quote (10 lines)
> Hi,
>
> I think this fixes WebGL support in IceCat:
>
> http://issues.guix.gnu.org/34135#10
>
> Best!
>
>

Pushed as 9c6ea3cb5617a1928073f41f174765ab14adbaa9, thank you!

Note that I added dots at the end of your log message, and removed
indentation on the third line of the log message.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41815@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41815
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help