[PATCH] gnu: x265: Build with assembly files.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87sgf6hmv7.fsf@rohleder.de
simple oneliner that made my ffmpeg encoding with hevc 3-4 times as fast.
also tested vlc build and decoding that video.
From 6fc19fa31df6c48e4118144fa3e0ecf738e45ce3 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 7 Jun 2020 18:01:38 +0200
Subject: [PATCH] gnu: x265: Build with assembly files.

* gnu/packages/video.scm (x265): Build with assembly files.
---
gnu/packages/video.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8d9d5ecfd1..c822075c57 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -625,6 +625,7 @@ available.")
(delete-file-recursively "source/compat/getopt")
#t))))
(build-system cmake-build-system)
+ (native-inputs `(("nasm" ,nasm)))
(arguments
`(#:tests? #f ; tests are skipped if cpu-optimized code isn't built
#:configure-flags
--
2.26.2
--
If you think the system is working, ask someone who's waiting for a prompt.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl7dEv0ACgkQfHr/vv7y
yyWqgAgAl7dwFD74D8+WQ9g0Q5gjcjjxnFUMnT12gWznJlYEN8LCAZwD43cl0DSX
S7KjgZTK7g31SlGlpezDX2GgAS6y25biuGEPqr+olQapTVprtZv+MgKH9ecfPV0D
KUxQiauKrRs+RMEAE+IEOru0zQW0rwSPO5DnqP8gTvrNjxjmyDvaG0ChjN7BDJO8
WPOz3dBoyjDQOsE4TbqDCADx8YTTAjtbrY9QYcvLd+wqKjh/5tIu2DcRSNbPeYXF
xy9VEEQ78iq+D4CXtO1AXAXFjKWwBvyirI/m79GIO+aFn1wGnbFjZmmchDAGe0x+
vUrgITsFI6M4WLMJLF25I+CmDpmoaQ==
=wGRo
-----END PGP SIGNATURE-----

Efraim Flashner wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 41750-done@debbugs.gnu.org)
20200608100321.GE24239@E5400
I thought this wasn't enabled due to it failing on aarch64 or armhf but
it turns out that wasn't the case. Patch pushed! Thanks.


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7eDOkACgkQQarn3Mo9
g1E7Zw//eVb90aZEgf0Sk2SKLGomq24dp6SrRQ3EsnxCMviZRunRDy42u0pE7HYt
wShWOuowsgJL/vWLC6QbnwktySnNyrcZHhI/uvkYS9wivG98q/oj61Ct/TGMu9vF
3SYgVUriSZ394EmzstVEfGqfIVWr6N48ALJLos410MS1x7zx/wsnVWDXLXCuMrTu
CO8+ZaWC8OVxUuctViXTi3MnmrIZG8rmzb+g5BVGBTZnQ3QfLh8yJXBSara9MQND
bTQyO9ivvEEuligR41bPIgP0j6LaMj7h+9+J0aNDae1L1MTdRWdhTW+2xmqj3+sP
VuLxXBMw2JQLZSCY4EtlFnnL3DRIYjNEe5ViX17Q9z1hodoEN6TqLmBnAotv/WiF
PEfJs/KEqlAJH8IVFhimoGEgrc68oL7FIsUrzz0XNjqUOjv2rxHgRzPRhHcIRkXk
geI+E15md/luXXjd2zG+UU5VTZMN5qmLyA93nuHGZhvpahwYRejZtE1Ts/hJOcTd
f1nKFuqrS/FvJJzSujbDoph5sLmH7VKbqLfYvhE753glClTlox9Lp8+YONmtYzcd
IDLT0V4j6xT+KDb+1zSD+OqXShutDv6HnVUI+hukfNii41TIqin+OLMNuDDgokQr
CKlR7KaLVcSqdMh5zHF1KbaZaZtaAqM2oFPeS97KXLmEA29o4/M=
=+ZPa
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41750@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41750
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help