[PATCH] Update StumpWM Contrib Package Names and Add New Ones

  • Done
  • quality assurance status badge
Details
3 participants
  • Katherine Cox-Buday
  • Oleg Pykhalov
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
K
K
Katherine Cox-Buday wrote on 5 Jun 2020 00:44
(address . guix-patches@gnu.org)
CA+TvSRjAg3EnyCTB6MPOs1dTznnGLyST-85We3gx=2XDP0Xk0Q@mail.gmail.com

From 2152f4e60c2c45e6494ff84216289eb5f7cf064e Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Thu, 4 Jun 2020 17:41:53 -0500
Subject: [PATCH 6/6] gnu: Add sbcl-stumpwm-kbd-layouts.

* gnu/packages/wm.scm (sbcl-stumpwm-kbd-layouts): New variable.
---
gnu/packages/wm.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 723c0dda1f..46ac1dcadc 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1841,6 +1841,22 @@ between windows.")
(filter (lambda (a) (string-contains a "linux")) %supported-systems))
(license license:gpl3+)))
+(define-public sbcl-stumpwm-kbd-layouts
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-kbd-layouts")
+ (arguments
+ '(#:asd-system-name "kbd-layouts"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir (lambda _ (chdir "util/kbd-layouts") #t)))))
+ (home-page
+ "https://github.com/stumpwm/stumpwm-contrib/tree/master/util/kbd-layouts")
+ (synopsis "Keyboard layout switcher for StumpWM")
+ (description "Keyboard layout switcher for StumpWM")
+ (license license:gpl3+)))
+
(define-public lemonbar
(let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
(revision "1"))
--
2.26.2
From e76387d2b27785270365566ce136ce7af586f394 Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Thu, 4 Jun 2020 17:41:21 -0500
Subject: [PATCH 4/6] gnu: Add sbcl-stumpwm-wifi.

* gnu/packages/wm.scm (sbcl-stumpwm-wifi): New variable.
---
gnu/packages/wm.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 6165c805da..b1747d6c58 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1801,6 +1801,24 @@ between windows.")
(filter (lambda (a) (string-contains a "linux")) %supported-systems))
(license license:gpl3+)))
+(define-public sbcl-stumpwm-wifi
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-wifi")
+ (arguments
+ '(#:asd-system-name "wifi"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir (lambda _ (chdir "modeline/wifi") #t)))))
+ (home-page
+ "https://github.com/stumpwm/stumpwm-contrib/tree/master/modeline/wifi")
+ (synopsis "Modeline support for wifi connectivity")
+ (description "Modeline support for wifi connectivity.")
+ (supported-systems
+ (filter (lambda (a) (string-contains a "linux")) %supported-systems))
+ (license license:gpl3+)))
+
(define-public lemonbar
(let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
(revision "1"))
--
2.26.2
From a45951534b47a68afdd94e1179499682d9548d05 Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Thu, 4 Jun 2020 17:40:56 -0500
Subject: [PATCH 3/6] gnu: Add sbcl-stumpwm-net.

* gnu/packages/wm.scm (sbcl-stumpwm-net): New variable.
---
gnu/packages/wm.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index daeddc3c0f..6165c805da 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1783,6 +1783,24 @@ windows in the current X session.")
between windows.")
(license (list license:gpl2+ license:gpl3+ license:bsd-2))))
+(define-public sbcl-stumpwm-net
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-net")
+ (arguments
+ '(#:asd-system-name "net"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir (lambda _ (chdir "modeline/net") #t)))))
+ (home-page
+ "https://github.com/stumpwm/stumpwm-contrib/tree/master/modeline/net")
+ (synopsis "Modeline support for network connectivity")
+ (description "Modeline support for network connectivity.")
+ (supported-systems
+ (filter (lambda (a) (string-contains a "linux")) %supported-systems))
+ (license license:gpl3+)))
+
(define-public lemonbar
(let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
(revision "1"))
--
2.26.2
From 7bb66377c87433761fd5cc115a2b858f427ffe12 Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Thu, 4 Jun 2020 17:41:43 -0500
Subject: [PATCH 5/6] gnu: Add sbcl-stumpwm-stumptray.

* gnu/packages/wm.scm (sbcl-stumpwm-stumptray): New variable.
---
gnu/packages/wm.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b1747d6c58..723c0dda1f 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1819,6 +1819,28 @@ between windows.")
(filter (lambda (a) (string-contains a "linux")) %supported-systems))
(license license:gpl3+)))
+(define-public sbcl-stumpwm-stumptray
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-stumptray")
+ (arguments
+ '(#:asd-system-name "stumptray"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir (lambda _ (chdir "modeline/stumptray") #t)))))
+ (inputs
+ `(("stumpwm" ,stumpwm "lib")
+ ("xembed" ,sbcl-clx-xembed)
+ ("alexandria" ,sbcl-alexandria)))
+ (home-page
+ "https://github.com/stumpwm/stumpwm-contrib/tree/master/modeline/stumptray")
+ (synopsis "Modeline support for stumptray connectivity")
+ (description "Modeline support for stumptray connectivity.")
+ (supported-systems
+ (filter (lambda (a) (string-contains a "linux")) %supported-systems))
+ (license license:gpl3+)))
+
(define-public lemonbar
(let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
(revision "1"))
--
2.26.2
From 44a42f6ad1fd83b123152144190238287db6edee Mon Sep 17 00:00:00 2001
From: Katherine Cox-Buday <cox.katherine.e@gmail.com>
Date: Thu, 4 Jun 2020 17:30:01 -0500
Subject: [PATCH 1/6] gnu: Add clx-xembed.

* gnu/packages/lisp-xyz.scm (sbcl-clx-xembed, cl-clx-xembed, ecl-clx-xembed):
New variable.
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b78eec7f4d..2faeb1e657 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11555,3 +11555,35 @@ accompaniment to the standard ANSI facilities.")
(define-public cl-osicat
(sbcl-package->cl-source-package sbcl-osicat))
+
+(define-public sbcl-clx-xembed
+ (let ((commit "a5c4b844d31ee68ffa58c933cc1cdddde6990743")
+ (revision "1"))
+ (package
+ (name "sbcl-clx-xembed")
+ (version (git-version "0.1" revision commit))
+ (home-page "https://github.com/laynor/clx-xembed")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/laynor/clx-xembed.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1abx4v36ycmfjdwpjk4hh8058ya8whwia7ds9vd96q2qsrs57f12"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-system-name "xembed"))
+ (inputs
+ `(("sbcl-clx" ,sbcl-clx)))
+ (synopsis "CL(x) xembed protocol implementation ")
+ (description "CL(x) xembed protocol implementation")
+ ;; MIT License
+ (license license:expat))))
+
+(define-public cl-clx-xembed
+ (sbcl-package->cl-source-package sbcl-clx-xembed))
+
+(define-public ecl-clx-xembed
+ (sbcl-package->ecl-package sbcl-clx-xembed))
--
2.26.2
O
O
Oleg Pykhalov wrote on 9 Jun 2020 21:11
(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)(address . 41718-done@debbugs.gnu.org)
875zc09hrt.fsf@gmail.com
Hi.

Thank you! I successfully tested my StumpWM config on a virtual machine
with current changes and pushed them to master.

Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl7f3sYACgkQFn+OpQAa
+pwMiA/+Iej/a3M2JFAS3gWtX1x+O3KRttZP5jk7DXrd6BpfAwbYmr2agZgJ2bux
iLC73DYjSBc/jZMVhKaxcrhAXSFly5MUGzVqQXI7ycAzs2IkPF27QnH8pbqvZxh9
YTL86l0Umir+cfwpYccLSUJhlegEF37xuuUxytlvFKih53DFFPhobVqqd6wROYdq
Rw+JnQPkXZLr/AQhhq+YWhwoJOT6eJ7rr8IURe1LVVWFYt07sTF2TUCAfxMKpOg+
fFpcWC9lx04bSZ//dQnShfOQX2N7A881Yz1uAPuZu6oSk3yQA42ZG/dk9czRikh6
ovbinXaRHBENZjjySsUS8KClYoZrnwqXs5DqyIzRcG3U8zpa5TB90of62Zy3UvWu
4m44gfwb6tfISbXCEYCy61mO3OIWCkMEPQy6z4md8Vebcq6I7gMsk2LzE+iGqVRG
gu+6n0xEkysnBzWTWHvdyczY4+CfAbdu9qF6cmxiSzfx7/gGMCb/TdtkGmivdYW0
2MFUw7puQE9Lp1eWTvno+lyPO8rhILnWtfuL0ykdav7U/ZsG83FxHT0gKW/dKPZ3
P1wLPw7YOL+KX69Qjda3OiyUoAm0jrYCcHdC1D+rsHDuSUN0J2l4xVTghPA266vp
SC6Z90NGuOSA5/zzQCfK8AIa56Dsjf4Aj3OqeNsRDauWm7tHDao=
=N9YL
-----END PGP SIGNATURE-----

Closed
T
T
Tobias Geerinckx-Rice wrote on 10 Jun 2020 00:00
Re: bug#41718: [PATCH] Update StumpWM Contrib Package Names and Add New Ones
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
877dwfq4qg.fsf@nckx
Katherine, Oleg,

Thanks for the patches and testing! I pushed a bug-fix in commit
9bb102dc1c47275d2906a9f4e0b813e1940176d3:

+(define-public stumpish
+ (package
+ (inherit stumpwm-contrib)
+ (name "stumpish")
+ (inputs
+ `(("bash" ,bash)
+ ("rlwrap" ,rlwrap)))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:tests? #f

The ‘tests?’ keyword isn't understood by the trivial build system,
and broke ‘guix pull’.

Oleg Pykhalov ???
Toggle quote (4 lines)
> Thank you! I successfully tested my StumpWM config on a virtual
> machine
> with current changes and pushed them to master.

It's interesting that this didn't throw an error. I guess the
only way to test such things is to ‘guix pull’ yourself, which can
be tedious and slow.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXuAGhwAKCRANsP+IT1Vt
eZhqAP9PzLM/B+HpeoktHeKDiWLFQoYsTPyYKbODwSkCR0TNZAD+NteifqYTU3UR
ravaEqGST8PQ6jmdt0cjhDQvwqywWg0=
=Emwj
-----END PGP SIGNATURE-----

Closed
K
K
Katherine Cox-Buday wrote on 10 Jun 2020 00:46
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
87v9jzzwlx.fsf@gmail.com
Tobias Geerinckx-Rice <me@tobias.gr> writes:

Toggle quote (3 lines)
> The ‘tests?’ keyword isn't understood by the trivial build system, and
> broke ‘guix pull’.

Ugh. That was leftover from my own testing anyway, and was meant to be
removed. I'm sorry about that. Ironically I broke myself and I was
wondering why `guix pull` wasn't working. Serves me right!

Toggle quote (4 lines)
> It's interesting that this didn't throw an error. I guess the only
> way to test such things is to ‘guix pull’ yourself, which can be
> tedious and slow.

Yes, that's very strange... is that something that's correctable?

--
Katherine
Closed
?