[WIP] gnu: Add aufs-standalone.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 5 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20200601131903.19100-1-dannym@scratchpost.org
* gnu/packages/linux.scm (aufs-standalone): New variable.
---
gnu/packages/linux.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

This package would need a patched Linux kernel (see aufs5-base.patch,
aufs5-mmap.patch and aufs5-standalone.patch)--that's using a definition
of "standalone" I wasn't previously aware of. So I will not try to
develop this package further for the time being.

Toggle diff (45 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0a154fd6cc..771fba4593 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -986,6 +986,40 @@ It grants direct and undocumented access to your hardware that may cause damage
and should be used with caution, especially on untested models.")
(license license:gpl3+)))) ; see README.md (no licence headers)
+(define-public aufs-standalone
+ (let ((commit "230a4e746cb37dc760530233521f732bb932212c") ; branch 5.4
+ (revision "0"))
+ (package
+ (name "aufs-standalone")
+ (version (git-version "5.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sfjro/aufs5-standalone.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wq40m8acqqhr2p0sh81wzcdrcabzmvjd15x0y7mdkhwmhyhas9h"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f ; No tests exist
+ #:make-flags
+ (list "CONFIG_AUFS_FS=m"
+ ;; See config.mk
+ "EXTRA_CFLAGS=-DCONFIG_AUFS_BRANCH_MAX_127=y -DCONFIG_AUFS_SBILIST=y -DCONFIG_AUFS_DEBUG=y")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "fs/aufs")
+ #t)))))
+ (home-page "https://github.com/sfjro/aufs5-standalone/tree/aufs5.4")
+ (synopsis "Linux kernel module aufs")
+ (description "This package provides the Linux kernel module
+@code{aufs}.")
+ (license license:gpl2+))))
+
(define-public rtl8812au-aircrack-ng-linux-module
(let ((commit "945d6ed6505c32f0993b1dba576388e92e78101b")
(revision "0"))
Mathieu Othacehe wrote 5 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 41644@debbugs.gnu.org)
87v9k9x1q3.fsf@gnu.org
Hey Danny,

Toggle quote (5 lines)
> This package would need a patched Linux kernel (see aufs5-base.patch,
> aufs5-mmap.patch and aufs5-standalone.patch)--that's using a definition
> of "standalone" I wasn't previously aware of. So I will not try to
> develop this package further for the time being.

Hehe, not that standalone indeed. Maybe we can close this ticket then?

Thanks,

Mathieu
Danny Milosavljevic wrote 5 years ago
(no subject)
(address . control@debbugs.gnu.org)
20200603010754.19d4ebcb@scratchpost.org
close 41644
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl7W28oACgkQ5xo1VCww
uqUSmQf+OWQ1Fg0FoGpCLKX0O4tBv6ap3Ki0i0CyrC3CKL416m81/sbydTUHe+kK
BQ895LF7Tq1J3lDLn2NmMFM6gBBo1sZcbeO/IG26PME+joJ1XV+NhFUBsrOZ6y5v
EHm2jCgHICYLZh4S+H5gDmMqFg4c7ChaiNQmQibr7OaY2LQfMLYCJN8dUthFegNh
4+Cy4mSBDhoNtWFW3lpUhZpYZ/8NPWEW3Xc3hSSc7WnXof0E3VNuwpWBKkPbHd4E
rM2ro+oPSe9EBv44rzPB8hP2LDDcY3mJs0E17CAXoHFiwRpcWqPf87alopW2l1C3
jD07FTxvyRItp1e63Y4dCl0ctc2y9Q==
=dCgz
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 41644@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41644
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help