[PATCH] gnu: python-astroid: Update to 2.4.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87ftbhyx9a.fsf@rohleder.de
on current (8e3a1a62ae) master, gnome doesnt build, because totem tests
fail.
in order to fix this, i tried adding python-toml and python-astroid to
native-inputs of totem.
then the tests fail, because python-astroid seems to old, so here is a
patch for that.
now, the tests still fail, but we might be a small step closer... ;)

I only tested this lightly with building the other 3 deps:
"python-language-server rtv tuir" and python2-astroid.
From 7b4e21f9709b642f20695c9ea6a8e512baa808da Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sat, 30 May 2020 21:27:49 +0200
Subject: [PATCH] gnu: python-astroid: Update to 2.4.1.

* gnu/packages/python-xyz.scm (python-astroid): Update to 2.4.1.
---
gnu/packages/python-xyz.scm | 18 +++---------------
1 file changed, 3 insertions(+), 15 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index baec999247..79816ddc2f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -80,6 +80,7 @@
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13905,13 +13906,13 @@ clone, while other processes access the original tree.")
(define-public python-astroid
(package
(name "python-astroid")
- (version "2.3.3")
+ (version "2.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astroid" version))
(sha256
- (base32 "0fnibsl2cb5mvzbfm7sycj85smx48f8w8m7ks1sqlmpr9ps0gski"))))
+ (base32 "1h99jal7ax07xna1djw5z7hpgb8vjrl3hrrg49p1phljwniww5sc"))))
(build-system python-build-system)
(propagated-inputs
`(("python-lazy-object-proxy" ,python-lazy-object-proxy)
@@ -13923,19 +13924,6 @@ clone, while other processes access the original tree.")
("python-nose" ,python-nose)
("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-spurious-test
- (lambda _
- ;; This can be removed after upgrading from python-3.7
- ;; https://github.com/PyCQA/astroid/issues/593
- ;; https://bugs.python.org/issue34056
- (delete-file "astroid/tests/unittest_modutils.py")
- #t))
- (replace 'check
- (lambda _
- (invoke "pytest" "astroid"))))))
(home-page "https://github.com/PyCQA/astroid")
(synopsis "Common base representation of python source code for pylint and
other projects")
--
2.26.2
--
Life's too short to do DOS support.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl7SxCEACgkQfHr/vv7y
yyU/6Qf/RaDJ+KZ+aSY682/iX2Ps3szDbLpAl0aKFVsnG2qzDSZ7NKDMNmbG7d6i
wbRQ0X8r0L2ykCSb9oafPsIwLoDNCtbaLI9OEmgNxhfi3GaXTIY5JpF7y1FU08pP
wBFSOORYIH2v7a6YJ6bZnZJUNqC0Bj0l9Sy4LDCU1j8J3oEGYOeXlObl4/eV1x6C
6McBb4/Wm28Se5Eb3uh59T8mKy3t1pa0jP+g38fwTVFweTZFFtEPt6WIHHLUWyUM
tvSNBX5wFI22X2I9ZHHrjNdEjBd5VjA+p+ekLOhpNbea2n1qmxLlDaAfWJZRw8NM
xXIAVEvY+d/Z+RmChHh4BjBu/qAxug==
=TtFa
-----END PGP SIGNATURE-----

Marius Bakke wrote 5 years ago
87eer1xgxy.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (8 lines)
> on current (8e3a1a62ae) master, gnome doesnt build, because totem tests
> fail.
> in order to fix this, i tried adding python-toml and python-astroid to
> native-inputs of totem.
> then the tests fail, because python-astroid seems to old, so here is a
> patch for that.
> now, the tests still fail, but we might be a small step closer... ;)

Uff, thanks for the heads-up, I have reverted the pylint update.

Toggle quote (3 lines)
> I only tested this lightly with building the other 3 deps:
> "python-language-server rtv tuir" and python2-astroid.

Heh, that's what I did too because I did not have WebKitGTK readily
available for testing the Totem build. ;-)

However now I do, and can confirm that Totem still builds with this
patch.

I also added a follow-up patch to remove the unused nose and typing-ast
inputs.

Applied!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SzPoACgkQoqBt8qM6
VPp8mQgA0U1ikcNK0yxaxQvzrJ6KwfrCmGM+NpydHm9sLADpNSWIz/SbMBnkwjnE
zXKjGZN65692Qo5G2ig57lb8J0O/sLiYPbYBCgGkhEBx6U6oXZAl7hoGLY1wx3hf
B/DOLchKbdMfLfKUEZ02TgtGCXN/TTg0nEianYLfqF3Z2fvDAGZl0HRcDfUuCxDX
rjavxfD0Ev0Jt6S8IF+0F8W7NDB5KowB1tb/0/b69544ul9XYb5y14q+F3uaIDZS
xutdijWQZ6PERm62d4xiGEv/fKjWaItYpRYkR8tt1AzuE1rpsdtfmI+u9fq3DTG4
z58LE3bqx5z9gvfcPIfHs4SGznxi8A==
=/dCL
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41620@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41620
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help