[PATCH 0/1] Fix: make update-guix-package

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)
a060c408-97e7-c454-df79-f2d3f2f3c960@gmail.com
I was trying to build the binary tarball to test changes, and stumbled
upon the following failure:

------------->8------------------------------------------8<-----------
$ make update-guix-package
git rev-parse HEAD
915b949cfd8f41cac550c641ed0f9a1cf37f4d42
./pre-inst-env
"/gnu/store/cqp4hvbfi8y3g8v61jrpi875wc0iqx9q-profile/bin/guile" \
./build-aux/update-guix-package.scm \
"`git rev-parse HEAD`"
Backtrace:
In ice-9/boot-9.scm:
1736:10 13 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
12 (apply-smob/0 #<thunk 7f5bdb96d980>)
In ice-9/boot-9.scm:
718:2 11 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
In ice-9/eval.scm:
619:8 10 (_ #(#(#<directory (guile-user) 7f5bdb58ff00>)))
In ice-9/boot-9.scm:
2806:4 9 (save-module-excursion _)
4351:12 8 (_)
1736:10 7 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
630:22 6 (thunk)
In build-aux/update-guix-package.scm:
116:9 5 (_ #<store-connection 256.99 7f5bdb9a23c0>)
In guix/utils.scm:
308:22 4 (edit-expression _ #<procedure 7f5bc23f3000 at build-a…> …)
In build-aux/update-guix-package.scm:
78:30 3 (_ "(let ((version \"1.1.0\")\n (commit \"bdc801…")
In guix/base32.scm:
144:17 2 (_ _)
114:17 1 (bytevector-quintet-fold-right #<procedure 7f5bd94114e…> …)
In ice-9/boot-9.scm:
1669:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1669:16: In procedure raise-exception:
In procedure bv-length: Wrong type argument in position 1 (expecting
bytevector): #<content-hash
sha256:1wf30g45kh4nmcapd4vrcl6m2wjzly7v7dv8z0r584770i2yh836>
make: *** [Makefile:6323: update-guix-package] Error 1
------------->8------------------------------------------8<-----------

I copied the modification from:
c7d2dd69004b020de5d86898d2497ab3c8435c37

To fix it, is this the right thing to do ?

--
Vincent Legoll
Vincent Legoll wrote 5 years ago
[PATCH] update-guix-package: Use 'origin-hash'.
(address . 41568@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20200527211348.6077-1-vincent.legoll@gmail.com
* gnu/packages/package-management.scm (main): Use 'origin-hash' instead
of 'origin-sha256'.
---
build-aux/update-guix-package.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/build-aux/update-guix-package.scm b/build-aux/update-guix-package.scm
index 83f6eca6bb..f695e91cfd 100644
--- a/build-aux/update-guix-package.scm
+++ b/build-aux/update-guix-package.scm
@@ -112,7 +112,8 @@ COMMIT."
#:select? version-controlled?))
(hash (query-path-hash store source))
(location (package-definition-location))
- (old-hash (origin-sha256 (package-source guix))))
+ (old-hash (content-hash-value
+ (origin-hash (package-source guix)))))
(edit-expression location
(update-definition commit hash
#:old-hash old-hash
--
2.26.2
Tobias Geerinckx-Rice wrote 5 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 41568-done@debbugs.gnu.org)
87blm84gf1.fsf@nckx
Vincent,

Strange, it works fine here on
023eea68f53a6d2979f558fc7590f43aee3aff43:

~/guix λ guix environment guix -- make update-guix-package
git rev-parse HEAD
aa77b5745dea6591f162c3f2260425479c0da596
./pre-inst-env "/gnu/store/…-profile/bin/guile"
\
./build-aux/update-guix-package.scm \
"`git rev-parse HEAD`"
source code for commit aa77b5745dea6591f162c3f2260425479c0da596:
/gnu/store/…-guix-1.1.0-5.aa77b57-checkout
(GC root: guix-1.1.0-5.aa77b57-checkout)
~/guix λ

Vincent Legoll 写道:
Toggle quote (4 lines)
> * gnu/packages/package-management.scm (main): Use 'origin-hash'
> instead
> of 'origin-sha256'.

Your change still looks correct so I've pushed it as
6bfb3eb75dc012e3a0e53da2dc29777c10b6a1ee.

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXs904gAKCRANsP+IT1Vt
ediuAP9cul0rlL0cCy2BiwP3gYmAAiFKQzNCzXVPYRvHXOAtjwEAxh47v6Plx/zq
g/zU8v+r7znUXpbkHinXIqo5SBOPkQc=
=jKFL
-----END PGP SIGNATURE-----

Closed
Vincent Legoll wrote 5 years ago
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 41568-done@debbugs.gnu.org)
40721ad0-1b1b-19b3-3e0d-8b4ac6b28555@gmail.com
On 28/05/2020 10:22, Tobias Geerinckx-Rice wrote:
Toggle quote (14 lines)
> Vincent,
>
> Strange, it works fine here on 023eea68f53a6d2979f558fc7590f43aee3aff43:
>
>  ~/guix λ guix environment guix -- make update-guix-package
>  git rev-parse HEAD
>  aa77b5745dea6591f162c3f2260425479c0da596
>  ./pre-inst-env "/gnu/store/…-profile/bin/guile"  \
>     ./build-aux/update-guix-package.scm    \
>     "`git rev-parse HEAD`"
>  source code for commit aa77b5745dea6591f162c3f2260425479c0da596:
>  /gnu/store/…-guix-1.1.0-5.aa77b57-checkout
>  (GC root: guix-1.1.0-5.aa77b57-checkout)

That's strange indeed, I tried multiple times with various attempts
at fixing it, and got the failure every time.

Toggle quote (7 lines)
> Vincent Legoll 写道:
>> * gnu/packages/package-management.scm (main): Use 'origin-hash' instead
>> of 'origin-sha256'.
>
> Your change still looks correct so I've pushed it as
> 6bfb3eb75dc012e3a0e53da2dc29777c10b6a1ee.

Thanks

--
Vincent Legoll
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41568@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41568
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help