Morgan.J.Smith wrote 5 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/mspdebug.scm (mspdebug): New variable.
---
gnu/packages/mspdebug.scm | 44 +++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
create mode 100644 gnu/packages/mspdebug.scm
Toggle diff (52 lines)
diff --git a/gnu/packages/mspdebug.scm b/gnu/packages/mspdebug.scm
new file mode 100644
index 0000000000..fcabcae472
--- /dev/null
+++ b/gnu/packages/mspdebug.scm
@@ -0,0 +1,44 @@
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+
+(define-module (gnu packages mspdebug)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages libusb)
+ #:use-module (gnu packages readline))
+
+
+(define-public mspdebug
+ (package
+ (name "mspdebug")
+ (version "0.25")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlbeer/mspdebug.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0prgwb5vx6fd4bj12ss1bbb6axj2kjyriyjxqrzd58s5jyyy8d3c"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases (delete 'configure) (delete 'check))
+ #:make-flags
+ (let ((target ,(%current-target-system)))
+ (list (string-append "CC=" (if target
+ (string-append target "-gcc")
+ "gcc"))
+ "INSTALL=install"
+ (string-append "PREFIX=" %output)))))
+ (inputs
+ `(("libusb-compat" ,libusb-compat)
+ ("readline" ,readline)))
+ (synopsis "Free debugger for use with MSP430 MCUs")
+ (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
+MSP430-JTAG-TINY programmers, as well as many other compatible
+devices. It can be used as a proxy for gdb or as an independent
+debugger with support for programming, disassembly and reverse
+engineering.")
+ (home-page "https://github.com/dlbeer/mspdebug")
+ (license gpl2)))
--
2.26.2