[PATCH] gnu: Add emacs-erc-status-sidebar.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Marius Bakke
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87367le0xu.fsf@rohleder.de
From 2c47a49177ab0a8ceee52910007a998b73f3bf81 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Wed, 27 May 2020 19:31:46 +0200
Subject: [PATCH] gnu: Add emacs-erc-status-sidebar.

* gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 45a10f4689..338bd270e0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3216,6 +3216,28 @@ appropriate console.")
IRC bouncer with ERC.")
(license license:expat)))
+(define-public emacs-erc-status-sidebar
+ (package
+ (name "emacs-erc-status-sidebar")
+ (version "20171223.2124")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/erc-status-sidebar-"
+ version ".el"))
+ (sha256
+ (base32 "1jjz4zs4fx45i9nvy2h7nfzkv0qrpp1pfhr8fx3hb6wxvi6zjis0"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-seq" ,emacs-seq)))
+ (home-page "https://github.com/drewbarbs/erc-status-sidebar")
+ (synopsis "Hexchat-like activity overview for ERC channels")
+ (description
+ "This package is provides a hexchat-like status bar for joined
+channels in ERC. It relies on the @code{erc-track} module, and displays
+all the same information erc-track does in the mode line, but in an
+alternative format.")
+ (license license:gpl3)))
+
(define-public emacs-shut-up
(package
(name "emacs-shut-up")
--
2.26.2
--
A vegan, an IntelliJ user, a Mac user, and a Linux user walked into a bar.
How do I know?
AFTER 2 MINUTES, THE WHOLE DARN BAR KNEW!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl7OpL0ACgkQfHr/vv7y
yyUiDQf/SAXfhhbRxRdMLQpZeucUm5am8icAysqDa4lHFilEmaX4kfYkV9h0es5v
bji9tT6R1iUcutb+7H9Rzs30pAi0LDRItc6yzFwte/OP9Pr7p/eTSTuzzysCbWjC
pWnLSMOQSf89fWlOvb48FJ02eLGZAzRU3VXYfHweGndegYGxMsg5/7trpkcbRkQg
Nhipy/qsxNTDOFLGbeAy4UOLtaJg/5ZFepgz1e4El38mD3vpSASgCaZAVwe0rqyd
UOFNvddqKUcwUuOqhujWvvDeldH18aM66tQvImq/K+QDnvlYLut31dY7Ylp3oOmW
Pf4GctumxU13Kuny+N4EYaKEb4kYfg==
=PJLG
-----END PGP SIGNATURE-----

Marius Bakke wrote 5 years ago
87tuzxzfn8.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (7 lines)
> From 2c47a49177ab0a8ceee52910007a998b73f3bf81 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Wed, 27 May 2020 19:31:46 +0200
> Subject: [PATCH] gnu: Add emacs-erc-status-sidebar.
>
> * gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable.

Thanks!
Toggle quote (12 lines)
> +(define-public emacs-erc-status-sidebar
> + (package
> + (name "emacs-erc-status-sidebar")
> + (version "20171223.2124")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://melpa.org/packages/erc-status-sidebar-"
> + version ".el"))
> + (sha256
> + (base32 "1jjz4zs4fx45i9nvy2h7nfzkv0qrpp1pfhr8fx3hb6wxvi6zjis0"))))

IIRC melpa.org purges old versions, so we should probably change to
'git-fetch' here.

Toggle quote (11 lines)
> + (build-system emacs-build-system)
> + (propagated-inputs `(("emacs-seq" ,emacs-seq)))
> + (home-page "https://github.com/drewbarbs/erc-status-sidebar")
> + (synopsis "Hexchat-like activity overview for ERC channels")
> + (description
> + "This package is provides a hexchat-like status bar for joined
> +channels in ERC. It relies on the @code{erc-track} module, and displays
> +all the same information erc-track does in the mode line, but in an
> +alternative format.")
> + (license license:gpl3)))

Well this is awkward, the LICENSE file is GPL3, but the headers in
erc-status-sidebar.el actually uses the Expat license. So this should
be license:expat.

It would be good to notify upstream about this inconstency, but not a
blocking issue.

Can you send an updated patch?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SZwsACgkQoqBt8qM6
VPqJmAf8DsASX/jiqcjfO46JO6ed56SciBQ5gJ9NspSGWuk6mjnQnhPIsYTNZgZH
4UYOKGXGo/qrfBZ56PKLqLOTq+WD98uoK+j/MXS0ZuVM4FyylsXW/ddgAnOOTiqW
G9ns/iUGaRUxG8/PafosojPSv3L8uL1E82vNH6YWnL7vBYlXBbxM9Zp7XjgEU4VQ
d0gly9swqaN0KN+xArB42HpIZyzWPS8OlQB+FN0SXlrMmQj7MI/icCtXLBED9w76
ojZwc06Ru7niZb2Y9XZCo3AiDYZciN5MMggu6/TbNUnqxLPnfPFtq9VQcd+Jt4vz
xW0pqvgmXBexFrBuvKFqMT5noIyYKw==
=jWRb
-----END PGP SIGNATURE-----

Michael Rohleder wrote 5 years ago
(name . Marius Bakke)(address . marius@gnu.org)(address . 41566@debbugs.gnu.org)
87a71mvv6l.fsf@rohleder.de
Hi Marius,

thank you reviewing!

Marius Bakke <marius@gnu.org> writes:
Toggle quote (3 lines)
> IIRC melpa.org purges old versions, so we should probably change to
> 'git-fetch' here.

done.

Toggle quote (6 lines)
>> + (license license:gpl3)))
>
> Well this is awkward, the LICENSE file is GPL3, but the headers in
> erc-status-sidebar.el actually uses the Expat license. So this should
> be license:expat.

oh, good catch, I didnt notice!
From 5da5a1e7322dc00f8900724060de3d5fe2a826e0 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Tue, 2 Jun 2020 08:20:18 +0200
Subject: [PATCH] gnu: Add emacs-erc-status-sidebar.

* gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b64a964916..76c67d859e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3280,6 +3280,31 @@ appropriate console.")
IRC bouncer with ERC.")
(license license:expat)))
+(define-public emacs-erc-status-sidebar
+ (let ((commit "ea4189a1dbfe60117359c36e681ad7c389e2968c")
+ (revision "1"))
+ (package
+ (name "emacs-erc-status-sidebar")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/drewbarbs/erc-status-sidebar.git")
+ (commit commit)))
+ (sha256
+ (base32 "1hwlhzgx03z8891sblz56zdp8zj0izh72kxykgcnz5rrkyc3vfi3"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-seq" ,emacs-seq)))
+ (home-page "https://github.com/drewbarbs/erc-status-sidebar")
+ (synopsis "A hexchat-like activity overview for ERC channels")
+ (description
+ "This package is provides a hexchat-like status bar for joined
+channels in ERC. It relies on the `erc-track' module, and displays
+all the same information erc-track does in the mode line, but in an
+alternative format.")
+ (license license:expat))))
+
(define-public emacs-shut-up
(package
(name "emacs-shut-up")
--
2.26.2
--
In most countries selling harmful things like drugs is punishable.
Then howcome people can sell Microsoft software and go unpunished?
(By hasku@rost.abo.fi, Hasse Skrifvars)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl7V8WMACgkQfHr/vv7y
yyXZ5QgAsECTUPQBbnITDtOz6lRlb7i04t1cssJX10HAlDz9zSpp68RqBNMvSOv5
uQHUhO2mPWIcQzboMBuYtVxD9uZGumXEWzYv3zot83/1nWmtfeh9w0ekzWXfiFvU
bfvjqnyw2DSY1iJRN4b2axq1sTvrYC0iREmg2p/dweBPRRFBRY9zZbC1aPVE/zDZ
wXqCFp/vMiCEtX8vMeTQQTgNqzPtzgffDSrj4ytdHD6SFruCKl/Mx+/uzLdT4Iwm
5OsNuJxWz/SN+iBBVj7UQFzT9MPG8LtSCUTAlPEyE2XIKIz26VK3DuGP5SOb1h58
zCjHvjpjtBdQGRxF1Y6vJ0M1ayURRA==
=nqf+
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)
87eeqhs6hi.fsf@gnu.org
Hi Michael,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (10 lines)
> From 5da5a1e7322dc00f8900724060de3d5fe2a826e0 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Tue, 2 Jun 2020 08:20:18 +0200
> Subject: [PATCH] gnu: Add emacs-erc-status-sidebar.
>
> * gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)

This seems to address what Marius commented on so I went ahead and
applied it. I followed up with small changes to placate ‘guix lint’.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41566@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41566
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help