Josh Marshall wrote 5 years ago
(address . guix-patches@gnu.org)(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)
* gnu/packages/version-control.scm (aegis): Update homepage link and fix build failure
---
gnu/packages/version-control.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Toggle diff (27 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 09ffd8f271..deb746db26 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1885,7 +1885,10 @@ accessed and migrated on modern systems.")
("ed" ,ed)))
(arguments
`(#:configure-flags (list "--with-no-aegis-configured"
- "--sharedstatedir=/var/com/aegis")
+ "--sharedstatedir=/var/com/aegis"
+ ;; Uses the old 'throw()' specifier with 'new'
+ ;; which changed in C++11.
+ "CXXFLAGS=-std=c++03")
#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
#:phases
(modify-phases %standard-phases
@@ -1928,7 +1931,7 @@ accessed and migrated on modern systems.")
;; The author decided to call the check rule "sure".
(invoke "make" "sure")))))))
- (home-page "http://aegis.sourceforge.net")
+ (home-page "https://sourceforge.net/projects/aegis/")
(synopsis "Project change supervisor")
(description "Aegis is a project change supervisor, and performs some of
the Software Configuration Management needed in a CASE environment. Aegis
--
2.26.2