[PATCH] Moved gettext to use git to better conform to better bootstrapping, better integration with Software Heritage, and what looks like emerging best practices for package sources.

  • Open
  • quality assurance status badge
Details
4 participants
  • joshua.r.marshall.1991
  • Leo Famulari
  • Marius Bakke
  • zimoun
Owner
unassigned
Submitted by
joshua.r.marshall.1991
Severity
normal
J
J
joshua.r.marshall.1991 wrote on 17 May 2020 21:44
(address . guix-patches@gnu.org)(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)
20200517194400.349638-1-joshua.r.marshall.1991@gmail.com
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>

---
gnu/packages/gettext.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 202acf25d4..19920aa210 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (gnu packages docbook)
@@ -46,12 +47,13 @@
(name "gettext-minimal")
(version "0.20.1")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/gettext/gettext-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/gettext.git")
+ (commit (string-append "v" version))))
(sha256
- (base32
- "0p3zwkk27wm2m2ccfqm57nj7vqkmfpn7ja1nf65zmhz8qqs5chb6"))))
+ (base32
+ "0p3zwkk27wm2m2ccfqm57nj7vqkmfpn7ja1nf65zmhz8qqs5chb6"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;9 MiB of HTML
--
2.25.1
M
M
Marius Bakke wrote on 17 May 2020 21:56
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)
87r1vis5cu.fsf@devup.no
joshua.r.marshall.1991@gmail.com writes:

Toggle quote (2 lines)
> From: Josh Marshall <joshua.r.marshall.1991@gmail.com>

Please add commit messages following the GNU ChangeLog style to your
patches.

I'm surprised that this does not require adding Autoconf etc as
native-inputs, do you know why that is?

Also, won't this cause a circular dependency on 'git-minimal'? If it
works for you I guess we got lucky in this case.

AIUI the lack of tarball integration in Software Heritage is temporary,
i.e. it will eventually be sorted, and of course back-dated. So I don't
think we need to move everything to git while we wait for that.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7BluEACgkQoqBt8qM6
VPq+TAgAh/YiPQ/o9C39vjj72jt0oIqSATuAQ+m7V2Dt3ogOmEmnmxDnKizJhqok
JZQlKvm95E9HvJVbR6AefFfokNE3OBIN2uxL8YHSKhcls015+sUSgJjKs47XXff7
G9vPUu1uh6qyVaplEQsNqGRNnU/GrISyDFkv7dNK8yuZ20ygJX8mVibXxreAWFEz
tELkHMXk0yu22r4YPK2aPYypdVuxVs1x/9DvUK1LZOP8xhRL2D9GKmrjionEegyS
vCsH+hGir4TNfq4A+3jD/Dxo57WSUZAIFosUO8VadiynYxdcFR54jUZnLJGeA3Fs
RFbtwtdvtDieLMuLeJ+6P5ABaxeGCg==
=mXhG
-----END PGP SIGNATURE-----

J
J
Josh Marshall wrote on 17 May 2020 22:30
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 41368@debbugs.gnu.org)
CAFkJGRd2bKX5=LULU8jc_uLEz5+qM0ZQUi8fiTM3CJxfVGkXiw@mail.gmail.com
On Sun, May 17, 2020, 15:56 Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (8 lines)
> joshua.r.marshall.1991@gmail.com writes:
>
> > From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
>
> Please add commit messages following the GNU ChangeLog style to your
> patches.
>

How do I do that? This was in large part an exercise to clean up my
development and contribution practice.

I'm surprised that this does not require adding Autoconf etc as
Toggle quote (3 lines)
> native-inputs, do you know why that is?
>

I think I let my environment leak, I'll check into in.

Also, won't this cause a circular dependency on 'git-minimal'? If it
Toggle quote (3 lines)
> works for you I guess we got lucky in this case.
>

I'm not sure. I'll test more in a little bit.

AIUI the lack of tarball integration in Software Heritage is temporary,
Toggle quote (4 lines)
> i.e. it will eventually be sorted, and of course back-dated. So I don't
> think we need to move everything to git while we wait for that.
>

When I looked into it, there appears to have been no progress in a year and
a half.

Toggle quote (1 lines)
>
Attachment: file
M
M
Marius Bakke wrote on 17 May 2020 22:34
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)(address . 41368@debbugs.gnu.org)
87o8qms3kr.fsf@devup.no
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

Toggle quote (13 lines)
> On Sun, May 17, 2020, 15:56 Marius Bakke <mbakke@fastmail.com> wrote:
>
>> joshua.r.marshall.1991@gmail.com writes:
>>
>> > From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
>>
>> Please add commit messages following the GNU ChangeLog style to your
>> patches.
>>
>
> How do I do that? This was in large part an exercise to clean up my
> development and contribution practice.

When doing 'git commit', add a one-line "title" for your change and
mention the changed files and variables in the commit message "body".

See the git log for examples.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7Bn+UACgkQoqBt8qM6
VPpL4wf/Rkfqd46mTDRNgY8rLCJCKSDH6VbcLE7VoZVJ/nJ3F0r5Qy9QWjqVKbrw
99R/fw4fnZ5VycUDCw0piTNm4iJZfgwxtgj6t1Y7H56Iaa/k1ab+Pm4ZRv9Y6ReK
RtcC0kd44ZI2ePh5YKjI9YUTvivfZzJxeVtQCG/FNeF5S4uun6TMofoz+Bpiv81/
gtkxW/xL4/O1oAXetj255VkL9qm96f3MINkEApZn9hWHWKOgXmvXKOrH3jJmKD9k
Cj0hr1GZ0duNXqlB8lyHFPdzR83Bt32xb/ldONKYmIMbhME3Rm57ZNQNpct2xV/6
0Cq97Gzz4Dyf8aygejCkxEBKZpbwbg==
=VkCC
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 18 May 2020 20:04
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)
20200518180445.GA30166@jasmine.lan
On Sun, May 17, 2020 at 04:30:52PM -0400, Josh Marshall wrote:
Toggle quote (4 lines)
> Subject: Moved gettext to use git to better conform to better
> bootstrapping, better integration with Software Heritage, and what looks
> like emerging best practices for package sources.

Based on the previous discussion of this topic [0], I don't think there
was a consensus about whether or not using tarballs or Git sources was
better.


Toggle quote (9 lines)
> On Sun, May 17, 2020, 15:56 Marius Bakke <mbakke@fastmail.com> wrote:
> > joshua.r.marshall.1991@gmail.com writes:
> AIUI the lack of tarball integration in Software Heritage is temporary,
> > i.e. it will eventually be sorted, and of course back-dated. So I don't
> > think we need to move everything to git while we wait for that.
>
> When I looked into it, there appears to have been no progress in a year and
> a half.

Software Heritage is a cool project, but I don't see it as a reason to
start changing our packages yet. For one thing, it hasn't demonstrated
long-term stability in the way that the GNU tarball servers have. And
the apparent lack of progress on this feature (tarball hosting) does not
make me more confident.

There's no reason to avoid SWH, but also no reason to move away from
tarballs where we are already using them. I don't think there is any
danger of losing the gettext source code the way that there is for minor
GitHub projects and scientific computing packages.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl7CzjkACgkQJkb6MLrK
fwiYnQ/8DqfHjrR7eDHxwgM7B0po0FWfNaDR1U5royH+Nt/5MmLmd2n02PXr4SHg
mawkr4H7/tLeLe26j2384xx6I5nTw7vhmWm3m4yUhFOJIhZ5PO1FvNQJFi4WdvGi
3iyAHoYjJ1bzDDSUR0Q03jz7WTV7StipPEThNbT/Q47hY3zSauuftVGIX7k/hdRq
wY9nwr+d7e4UqRBmTwiVeL7866Xsm66hQNUzcESrB5SOCuB2H7zOqGmDFHeCC1uR
7pLES3bowbUfbArUQ5XVKN2FyXD36akzgw0EQWlG3a0vymzHZeQ6YpYD054tj48j
HriFy5piAOjYEMEKGkvAYMRy2n5zjoxK5HHtnTL2eZ4de14UYgA+VjGoqZ4nHc/M
YI7s4EUiSGZoJx9zlW7FubD/vWUUekmEC1dw+iILi3IBcwKvb1Iv+zTAHlbpwtt5
JOwqntt41FZV8wK6EhkpVIPl3v9eYb6S6kNJqIPnSgvmTiWOGT5zQ8aWVGkoZr6C
86vfzeF0515/3OmQafrjlsCQ7UvHuQOCeFo6nqz789AOAdJteE7GhApTBvLOQclo
vUBCsCI+3o0KX5zVjHR/6xO0Ig3U1rVFwRt0W1liwi+h1hCp+yDdrfeo0bdvRyTK
9IhCPNeVGT7vxVvCdCvAlSu9Hi7kyg9pFgrjD4X6Thv4nSgTQpc=
=oOdo
-----END PGP SIGNATURE-----


Z
Z
zimoun wrote on 28 Oct 2020 19:26
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)
86361y1a27.fsf@gmail.com
Hi,

On Sun, 17 May 2020 at 16:30, Josh Marshall <joshua.r.marshall.1991@gmail.com> wrote:

Toggle quote (5 lines)
> I'm surprised that this does not require adding Autoconf etc as
> native-inputs, do you know why that is?
>
> I think I let my environment leak, I'll check into in.

Did you check?


Toggle quote (5 lines)
>> Also, won't this cause a circular dependency on 'git-minimal'? If it
>> works for you I guess we got lucky in this case.
>
> I'm not sure. I'll test more in a little bit.

How the tests are going?


Toggle quote (2 lines)
> When I looked into it, there appears to have been no progress in a year and a half.

No progress in a year and half, maybe it is an exaggeration. For
example the ’sources.json’ format which allows SWH to ingest all the
tarballs had been cooked over this year and implemented less than 6
months ago:

87884f2de25559fca11892187953261cee8224ef
AuthorDate: Mon Feb 10 17:52:13 2020 +0100
CommitDate: Mon Mar 9 10:50:30 2020 +0100
[..]
35bb77108fc7f2339da0b5be139043a5f3f21493
AuthorDate: Mon Jun 29 18:50:57 2020 +0200
CommitDate: Mon Jul 6 12:19:32 2020 +0200

Even, the ingestion by SWH at the production level (not the
testing/staging level) dates from Sept. 15th.



Be patient. :-)
The work is in progress… but for sure, it is not a priority of the SWH
side. Well, I am aligned with the Marius and Leo’s words. :-)


All the best,
simon
?