(address . bug-guix@gnu.org)
Command:
```bash
sudo /tmp/guix-install.sh
```
Result:
```bash
cp: cannot stat '/root/.config/guix/current
/lib/systemd/system/gnu-store.mount': No such file or directory
chmod: cannot access '/etc/systemd/system/gnu-store.mount': No such file or
directory
```
Workaround:
Comment out `cp` at lines 347-348
Insert @ line 347
```bash
cat <<EOF > /etc/systemd/system/gnu-store.mount
[Unit]
Description=Read-only /gnu/store for GNU Guix
DefaultDependencies=no
ConditionPathExists=/gnu/store
Before=guix-daemon.service
[Install]
WantedBy=guix-daemon.service
[Mount]
What=/gnu/store
Where=/gnu/store
Type=none
Options=bind,ro
EOF
```
HTH
--
Kind Regards
Begley Brothers Inc.
1. *The content of this email is confidential and intended for the
recipient specified in message only. It is strictly forbidden to share any
part of this message with any third party, without a written consent of the
sender. If you received this message by mistake, please reply to this
message and follow with its deletion, so that we can ensure such a mistake
does not occur in the future.*
2. *This message has been sent as a part of discussion between Begley
Brothers Inc. and the addressee whose name is specified above. Should you
receive this message by mistake, we would be most grateful if you informed
us that the message has been sent to you. In this case, we also ask that
you delete this message from your mailbox, and do not forward it or any
part of it to anyone else. Thank you for your cooperation and
understanding.*
3. *Begley Brothers Inc. puts the security of the client at a high
priority. Therefore, we have put efforts into ensuring that the message is
error and virus-free. Unfortunately, full security of the email cannot be
ensured as, despite our efforts, the data included in emails could be
infected, intercepted, or corrupted. Therefore, the recipient should check
the email for threats with proper software, as the sender does not accept
liability for any damage inflicted by viewing the content of this email.*
4. *The views and opinions included in this email belong to their author
and do not necessarily mirror the views and opinions of the company. Our
employees are obliged not to make any defamatory clauses, infringe, or
authorize infringement of any legal right. Therefore, the company will not
take any liability for such statements included in emails. In case of any
damages or other liabilities arising, employees are fully responsible for
the content of their emails.*