Install script fails on Ubuntu 18.04 x86_64: Workaround

  • Done
  • quality assurance status badge
Details
3 participants
  • Trevor Lee
  • Ben Sturmfels
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Trevor Lee
Severity
normal
T
T
Trevor Lee wrote on 17 May 2020 12:39
(address . bug-guix@gnu.org)
CAJsH2Qk4aWbpGciirdEBExMjnyuajxcfsfY-u2NotQKjtT4tSQ@mail.gmail.com
Command:

```bash
sudo /tmp/guix-install.sh
```

Result:

```bash
cp: cannot stat '/root/.config/guix/current
/lib/systemd/system/gnu-store.mount': No such file or directory
chmod: cannot access '/etc/systemd/system/gnu-store.mount': No such file or
directory
```

Workaround:
Comment out `cp` at lines 347-348
Insert @ line 347

```bash
cat <<EOF > /etc/systemd/system/gnu-store.mount
[Unit]
Description=Read-only /gnu/store for GNU Guix
DefaultDependencies=no
ConditionPathExists=/gnu/store
Before=guix-daemon.service

[Install]
WantedBy=guix-daemon.service

[Mount]
What=/gnu/store
Where=/gnu/store
Type=none
Options=bind,ro
EOF
```

HTH

--
Kind Regards

Begley Brothers Inc.


1. *The content of this email is confidential and intended for the
recipient specified in message only. It is strictly forbidden to share any
part of this message with any third party, without a written consent of the
sender. If you received this message by mistake, please reply to this
message and follow with its deletion, so that we can ensure such a mistake
does not occur in the future.*
2. *This message has been sent as a part of discussion between Begley
Brothers Inc. and the addressee whose name is specified above. Should you
receive this message by mistake, we would be most grateful if you informed
us that the message has been sent to you. In this case, we also ask that
you delete this message from your mailbox, and do not forward it or any
part of it to anyone else. Thank you for your cooperation and
understanding.*
3. *Begley Brothers Inc. puts the security of the client at a high
priority. Therefore, we have put efforts into ensuring that the message is
error and virus-free. Unfortunately, full security of the email cannot be
ensured as, despite our efforts, the data included in emails could be
infected, intercepted, or corrupted. Therefore, the recipient should check
the email for threats with proper software, as the sender does not accept
liability for any damage inflicted by viewing the content of this email.*
4. *The views and opinions included in this email belong to their author
and do not necessarily mirror the views and opinions of the company. Our
employees are obliged not to make any defamatory clauses, infringe, or
authorize infringement of any legal right. Therefore, the company will not
take any liability for such statements included in emails. In case of any
damages or other liabilities arising, employees are fully responsible for
the content of their emails.*
Attachment: file
T
T
Tobias Geerinckx-Rice wrote on 17 May 2020 14:26
(name . Trevor Lee)(address . begleybrothers@gmail.com)
87ftbyvjby.fsf@nckx
Trevor,

Thanks for the report!

Trevor Lee ???
Toggle quote (8 lines)
> ```bash
> cp: cannot stat '/root/.config/guix/current
> /lib/systemd/system/gnu-store.mount': No such file or directory
> chmod: cannot access '/etc/systemd/system/gnu-store.mount': No
> such file or
> directory
> ```

This happens because [0] links to guix-install.sh on (git) master,
which contains new code to install gnu-store.mount, but then
downloads an older (release) archive that doesn't contain that
file yet.

The above error is harmless, in that there's no regression from
1.1.0. New installations just won't benefit from Guix Advanced
System Protection(ZOMG™) just yet.
ebbf91542269fcb36d64928d4a4992e6afbf2acf avoids the error.

With that I'm closing this bug with little sense of satisfaction.

Your manual work-around is totes valid but (and do keep it), but
while not mounting /gnu/store ro on foreign distributions was a
serious oversight I don't think it warrants bundling or
downloading a copy of the .mount unit.

IMO it does warrant a 1.1.1 release once Vincent's non-systemd
work gets merged.

Kind regards,

T G-R

[0]:
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXsEtYQAKCRANsP+IT1Vt
ebtKAP0Q1Umcfm4iGX44b6EqIwOrtzxpsgnj7FMlI2GH3w9oHwD8D7TxU12xUzuw
0LQv7K7Q4VYN7b8wNuq/ZPwGnNrl0Qc=
=1Vqr
-----END PGP SIGNATURE-----

Closed
B
B
Ben Sturmfels wrote on 25 May 2020 13:37
Re: bug#41356: closed (Re: bug#41356: Install script fails on Ubuntu 18.04 x86_64: Workaround)
(name . GNU bug Tracking System)(address . help-debbugs@gnu.org)
87k110qm8u.fsf@sturm.com.au
unarchive 41356

On Sun, 17 May 2020, GNU bug Tracking System wrote:

Toggle quote (15 lines)
>> ```bash
>> cp: cannot stat '/root/.config/guix/current
>> /lib/systemd/system/gnu-store.mount': No such file or directory
>> chmod: cannot access '/etc/systemd/system/gnu-store.mount': No such file or
>> directory
>> ```
>
> This happens because [0] links to guix-install.sh on (git) master, which
> contains new code to install gnu-store.mount, but then downloads an older
> (release) archive that doesn't contain that file yet.
>
> The above error is harmless, in that there's no regression from 1.1.0. New
> installations just won't benefit from Guix Advanced System Protection(ZOMG™)
> just yet. ebbf91542269fcb36d64928d4a4992e6afbf2acf avoids the error.

The manual install has a similar issue where in 2.1 Binary Installation
step 5, it asks you to run:

# cp ~root/.config/guix/current/lib/systemd/system/gnu-store.mount \
~root/.config/guix/current/lib/systemd/system/guix-daemon.service \
/etc/systemd/system/

Which confused me during an install with the same "No such file" error
as above. I see that guix-install.sh now includes a conditional around
this `cp`. Perhaps it would be worth a small note in the documentation
to advise that this will issue a harmless error on Guix <= 1.1.1?

Regards,
Ben
?