Patch to expose #:scheme-file-regexp in guile build system

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Sassmannshausen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alex Sassmannshausen
Severity
normal
A
A
Alex Sassmannshausen wrote on 16 May 2020 15:37
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
87lflsc85w.fsf@komputilo.eu
Hello,

Please see proposition below. Exposing this argument makes it possible
to only install specific scheme files in a project using the
guile-build-system.

WDYT?

Alex
From b798fef327c86b82f336e3fec0e96b791032f470 Mon Sep 17 00:00:00 2001
From: Alex Sassmannshausen <alex@komputilo.eu>
Date: Sat, 16 May 2020 15:32:45 +0200
Subject: [PATCH] build-system/guile: Expose #:scheme-file-regexp.

* guix/build-system/guile.scm (%scheme-file-regexp): New variable.
(guile-build): Accept #:scheme-file-regexp and pass it on to builder.
---
guix/build-system/guile.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (33 lines)
diff --git a/guix/build-system/guile.scm b/guix/build-system/guile.scm
index 3693014694..45e735b987 100644
--- a/guix/build-system/guile.scm
+++ b/guix/build-system/guile.scm
@@ -29,6 +29,10 @@
#:export (%guile-build-system-modules
guile-build-system))
+(define %scheme-file-regexp
+ ;; Regexp to match Scheme files.
+ "\\.(scm|sls)$")
+
(define %guile-build-system-modules
;; Build-side modules imported by default.
`((guix build guile-build-system)
@@ -80,6 +84,7 @@
(system (%current-system))
(source-directory ".")
not-compiled-file-regexp
+ (scheme-file-regexp %scheme-file-regexp)
(compile-flags %compile-flags)
(imported-modules %guile-build-system-modules)
(modules '((guix build guile-build-system)
@@ -97,6 +102,7 @@
(source
source))
#:source-directory ,source-directory
+ #:scheme-file-regexp ,scheme-file-regexp
#:not-compiled-file-regexp ,not-compiled-file-regexp
#:compile-flags ,compile-flags
#:phases ,phases
--
2.23.0
L
L
Ludovic Courtès wrote on 18 May 2020 14:30
(name . Alex Sassmannshausen)(address . alex@komputilo.eu)(address . 41330@debbugs.gnu.org)
87pnb1ifwe.fsf@gnu.org
Hi Alex,

Alex Sassmannshausen <alex@komputilo.eu> skribis:

Toggle quote (8 lines)
>>From b798fef327c86b82f336e3fec0e96b791032f470 Mon Sep 17 00:00:00 2001
> From: Alex Sassmannshausen <alex@komputilo.eu>
> Date: Sat, 16 May 2020 15:32:45 +0200
> Subject: [PATCH] build-system/guile: Expose #:scheme-file-regexp.
>
> * guix/build-system/guile.scm (%scheme-file-regexp): New variable.
> (guile-build): Accept #:scheme-file-regexp and pass it on to builder.

LGTM, dankon! :-)

Ludo’.
A
A
Alex Sassmannshausen wrote on 18 May 2020 15:38
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 41330@debbugs.gnu.org)
87tv0dcqhk.fsf@komputilo.eu
Saluton,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (16 lines)
> Hi Alex,
>
> Alex Sassmannshausen <alex@komputilo.eu> skribis:
>
>>>From b798fef327c86b82f336e3fec0e96b791032f470 Mon Sep 17 00:00:00 2001
>> From: Alex Sassmannshausen <alex@komputilo.eu>
>> Date: Sat, 16 May 2020 15:32:45 +0200
>> Subject: [PATCH] build-system/guile: Expose #:scheme-file-regexp.
>>
>> * guix/build-system/guile.scm (%scheme-file-regexp): New variable.
>> (guile-build): Accept #:scheme-file-regexp and pass it on to builder.
>
> LGTM, dankon! :-)
>
> Ludo’.

Pushed now.

Thanks for the review!

Alex
L
L
Ludovic Courtès wrote on 23 May 2020 15:54
control message for bug #41330
(address . control@debbugs.gnu.org)
87o8qe7o4v.fsf@gnu.org
tags 41330 fixed
close 41330
quit
?