Django 3 dependency: gettext

  • Done
  • quality assurance status badge
Details
2 participants
  • Josh Marshall
  • Marius Bakke
Owner
unassigned
Submitted by
Josh Marshall
Severity
normal

Debbugs page

Josh Marshall wrote 5 years ago
(address . bug-guix@gnu.org)
CAFkJGReqYPX_eHMSJXd2AbBh-AM85QJ-htPTZfu85Gt1OeT2tg@mail.gmail.com
The following needs to be updated: gettext
Marius Bakke wrote 5 years ago
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)(address . 41301@debbugs.gnu.org)
87blmot4j2.fsf@devup.no
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

Toggle quote (2 lines)
> The following needs to be updated: gettext

Why does it need to be updated? gettext 0.20.2 was released just a
month ago[0], and Django runs on a wide range of distributions that
surely has older versions.

Updating gettext is also a full-rebuild change which means this will
have to wait for the next "core-updates" branch.

Note that if you really need the newer gettext, you can give Django a
special variant like so without having to wait for core-updates:

(define-public gettext-0.20.2
(package
(inherit gettext)
(version "0.20.2")
(source (origin ...))))

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6/5NEACgkQoqBt8qM6
VPoYjQgAmsvjh7d/n+KWygra+69Z5vmFJuqsodZKTbAAtPZpRuetPOGZLEb1uUSh
zk/l4UtO1LjzzKnbud/hzWobJLL69Dr16X9Po30DyiKMXwd/fAcSw3agZ/5TaGf7
GHyTFy+nc4UGmfA4Epj1Tzw46rbH9BJ2yijKcBuxMdnOvwYGfmZGJtkzSonx4e8d
gUZ+PMHPw3WTMIv11gv9uKUuSIUCD76N9jTS5NTy0+ZzNEEDCpXImuz/KfqfyKFX
vQQHeLPyW6JMfggtROSDTdd0VtXQ04lh52HXSrNSXYVZPU+66BX/TSa56nTtTA65
ONzB0cI40D5tQZeTj/7gzpSSi86NOg==
=uEcd
-----END PGP SIGNATURE-----

Josh Marshall wrote 5 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 41301@debbugs.gnu.org)
CAFkJGRcbfmRsE-3mHt2SrS3-sHOrVL5BR1OqqaK+wbsQ4gK9Xg@mail.gmail.com
I just saw that lint said it was out of date. I'm doing this to track down
a dep tree to order my work in packaging and to become more familiar with
packaging.

On Sat, May 16, 2020, 09:04 Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (22 lines)
> Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:
>
> > The following needs to be updated: gettext
>
> Why does it need to be updated? gettext 0.20.2 was released just a
> month ago[0], and Django runs on a wide range of distributions that
> surely has older versions.
>
> Updating gettext is also a full-rebuild change which means this will
> have to wait for the next "core-updates" branch.
>
> Note that if you really need the newer gettext, you can give Django a
> special variant like so without having to wait for core-updates:
>
> (define-public gettext-0.20.2
> (package
> (inherit gettext)
> (version "0.20.2")
> (source (origin ...))))
>
> 0: https://savannah.gnu.org/forum/forum.php?forum_id=9716
>
Attachment: file
Josh Marshall wrote 5 years ago
Re: bug#41301: Acknowledgement (Django 3 dependency: gettext)
(address . 41301@debbugs.gnu.org)
CAFkJGReeuBQQ0+p94kCN__Ue5u1S57d4_TtNqcHqUcGcGKGp=g@mail.gmail.com
Fixed by #41335

On Sat, May 16, 2020 at 1:00 AM GNU bug Tracking System
<help-debbugs@gnu.org> wrote:
Toggle quote (22 lines)
>
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> bug-guix@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 41301@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 41301: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=41301
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
Marius Bakke wrote 5 years ago
Re: [bug#41335] 000-gettext.patch
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)(address . 41335-done@debbugs.gnu.org)(address . 41301-done@debbugs.gnu.org)
87wo5asugx.fsf@devup.no
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

Toggle quote (22 lines)
> diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
> index 202acf25d4..7ca0acbf8b 100644
> --- a/gnu/packages/gettext.scm
> +++ b/gnu/packages/gettext.scm
> @@ -44,14 +44,14 @@
> (define-public gettext-minimal
> (package
> (name "gettext-minimal")
> - (version "0.20.1")
> + (version "0.20.2")
> (source (origin
> (method url-fetch)
> (uri (string-append "mirror://gnu/gettext/gettext-"
> version ".tar.gz"))
> (sha256
> (base32
> - "0p3zwkk27wm2m2ccfqm57nj7vqkmfpn7ja1nf65zmhz8qqs5chb6"))))
> + "1wc9q3y8rsbd757v985vxqcyqsxs7cxk4x7rzsjmq7d4ij8d1fgc"))))
> (build-system gnu-build-system)
> (outputs '("out"
> "doc")) ;9 MiB of HTML

Pushed to core-updates (with a commit message), thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7BF78ACgkQoqBt8qM6
VPoKeAf5Ae+ANPhgD76Lz2jy1kDVHqSTX/s3adHMMtqwSawg29FIIjgF2/E20En8
DXpAdeKYlkGsYISF+OSEAv0uQiQjOmmQ/+SNDA/zx2Hsg7TGCP8gh/C168Vv4v0R
XvXKfParSwhdtTS8Qwljxb3D5uCJoWTlBr31Yro3IeTHWa32fE0I7nvoKCKJKHAp
9fJqJ5GdH5R8WZOWf2XNAnZceAx4RmLMMr3MazQrCVFfl7EpVWvdJ2wMs6G1On3K
kelSKn5r3a/zN9WaTsLL5HXzStqequQel8ndF6XsWEU8kDHQKktuBHz6iwRVofmn
ApBoSsst/h4Ws4ZPD5OZnbYeIsB77w==
=cyfB
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41301@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41301
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help