Ekaitz Zarraga wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hi,
Added `--list-formats` option to `guix describe` in order to improve user experience as discussed here:
Hope it's useful.
Ekaitz
---
From 75f16431475fb692228f69be06baa635eb6fa5b7 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Thu, 14 May 2020 17:25:03 +0200
Subject: [PATCH] guix describe: Add '--list-formats'
* guix/scripts/describe.scm (%available-formats): New variable.
(list-fortmats): New procedure.
(%options, show-help): Add --list-formats
---
guix/scripts/describe.scm | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)
Toggle diff (49 lines)
diff --git a/guix/scripts/describe.scm b/guix/scripts/describe.scm
index f13f221da9..029098cea2 100644
--- a/guix/scripts/describe.scm
+++ b/guix/scripts/describe.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,13 +43,26 @@
;;; Command-line options.
;;;
+(define %available-formats '("human" "channels" "json" "recutils"))
+
+(define (list-formats)
+ (display (G_ "The available formats are:\n"))
+ (newline)
+ (for-each (lambda (f)
+ (format #t " - ~a~%" f))
+ %available-formats))
+
(define %options
;; Specifications of the command-line options.
(list (option '(#\f "format") #t #f
(lambda (opt name arg result)
- (unless (member arg '("human" "channels" "json" "recutils"))
+ (unless (member arg %available-formats)
(leave (G_ "~a: unsupported output format~%") arg))
(alist-cons 'format (string->symbol arg) result)))
+ (option '("list-formats") #f #f
+ (lambda (opt name arg result)
+ (list-formats)
+ (exit 0)))
(option '(#\p "profile") #t #f
(lambda (opt name arg result)
(alist-cons 'profile (canonicalize-profile arg)
@@ -70,6 +84,8 @@
Display information about the channels currently in use.\n"))
(display (G_ "
-f, --format=FORMAT display information in the given FORMAT"))
+ (display (G_ "
+ --list-formats display available formats"))
(display (G_ "
-p, --profile=PROFILE display information about PROFILE"))
(newline)
--
2.26.1