[PATCH] gnu: exo: Fix exo-compose-mail.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 5 years ago
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200514102846.309-1-jonathan.brielmaier@web.de

* gnu/packages/xfce.scm (exo)[arguments]: Add wrap-exo-compose-mail phase so it can find URI::Escape from perl-uri.
---
gnu/packages/xfce.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 4217023cf8..ce26c62857 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -213,6 +213,19 @@ to share commonly used Xfce widgets among the Xfce applications.")
(base32
"1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; exo won't find URI::Escape otherwise
+ (add-after 'install 'wrap-exo-compose-mail
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (perl5lib (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
+ `("PERL5LIB" ":" prefix
+ (,(string-append perl5lib ":" out
+ "/lib/perl5/site_perl")))))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
--
2.26.2
Jonathan Brielmaier wrote 5 years ago
[v2 PATCH] gnu: exo: Fix exo-compose-mail.
(address . 41255@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200514105341.1195-1-jonathan.brielmaier@web.de

* gnu/packages/xfce.scm (exo)[arguments]: Add wrap-exo-compose-mail phase so it can find URI::Escape from perl-uri.
---
gnu/packages/xfce.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 4217023cf8..61b64ef553 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2019 L p R n d n <guix@lprndn.info>
;;; Copyright © 2019 Ingo Ruhnke <grumbel@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -213,6 +214,19 @@ to share commonly used Xfce widgets among the Xfce applications.")
(base32
"1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; exo won't find URI::Escape otherwise
+ (add-after 'install 'wrap-exo-compose-mail
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (perl5lib (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
+ `("PERL5LIB" ":" prefix
+ (,(string-append perl5lib ":" out
+ "/lib/perl5/site_perl")))))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
--
2.26.2
Ricardo Wurmus wrote 5 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 41255-done@debbugs.gnu.org)
871rnmk1vi.fsf@elephly.net
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

Toggle quote (5 lines)
>
> * gnu/packages/xfce.scm (exo)[arguments]: Add wrap-exo-compose-mail
> phase so it can find URI::Escape from perl-uri.

Applied and pushed with commit 5c7e477c6cfe89aa4dfce557ea181e5aa8ba8a05.
Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41255@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41255
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help