Jonathan Brielmaier wrote 5 years ago
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
* gnu/packages/xfce.scm (exo)[arguments]: Add wrap-exo-compose-mail phase so it can find URI::Escape from perl-uri.
---
gnu/packages/xfce.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)
Toggle diff (24 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 4217023cf8..ce26c62857 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -213,6 +213,19 @@ to share commonly used Xfce widgets among the Xfce applications.")
(base32
"1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; exo won't find URI::Escape otherwise
+ (add-after 'install 'wrap-exo-compose-mail
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (perl5lib (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
+ `("PERL5LIB" ":" prefix
+ (,(string-append perl5lib ":" out
+ "/lib/perl5/site_perl")))))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
--
2.26.2