[PATCH] gnu: boost: Add which to native-inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 5 years ago
(address . guix-patches@gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20200514101353.27963-1-vincent.legoll@gmail.com
To fix:
./bootstrap.sh: line 28: which: command not found

* gnu/packages/boost.scm (boost)[native-inputs]: Add which.
---
gnu/packages/boost.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 2f2ca289ab..f6f442c5bf 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -38,6 +38,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
+ #:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
@@ -82,7 +83,8 @@
,@(if (%current-target-system)
'()
`(("python" ,python-wrapper)))
- ("tcsh" ,tcsh)))
+ ("tcsh" ,tcsh)
+ ("which" ,which)))
(arguments
`(#:imported-modules ((guix build python-build-system)
,@%gnu-build-system-modules)
--
2.26.2
Tobias Geerinckx-Rice wrote 5 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 41254@debbugs.gnu.org)
87blmqep4r.fsf@nckx
Vincent,

Thanks for the patch!

Vincent Legoll 写道:
Toggle quote (3 lines)
> To fix:
> ./bootstrap.sh: line 28: which: command not found

I'm not convinced that increasing the number of inputs to silence
(harmless) warnings in the build logs is a way to go.

Is there another reason to add ‘which’? The resulting boost
appears identical to one built without it.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXr0qRQAKCRANsP+IT1Vt
eZFuAP9d1L4yX2DT1Tnk2c8GRmZMTgWDsqTLthZVk9LVvgvW5QD/azcmTnQPbIwh
9pAW/0u6SuGjPbDRBjDc6gC0xbZDKQ4=
=qpq7
-----END PGP SIGNATURE-----

Vincent Legoll wrote 5 years ago
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 41254@debbugs.gnu.org)
a5710ceb-9a0b-572d-9902-5be013692ab2@gmail.com
On 14/05/2020 13:23, Tobias Geerinckx-Rice wrote:
Toggle quote (3 lines)
> I'm not convinced that increasing the number of inputs to silence
> (harmless) warnings in the build logs is a way to go.

It did not look harmless to me...

> The resulting boost appears identical to one built without it.

...but it looks like I'm wrong.

Toggle quote (2 lines)
> Is there another reason to add ‘which’?

Nope, feel free to close the issue

--
Vincent Legoll
Tobias Geerinckx-Rice wrote 5 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 41254-done@debbugs.gnu.org)
87tv0id8a3.fsf@nckx
Vincent Legoll 写道:
Toggle quote (7 lines)
> On 14/05/2020 13:23, Tobias Geerinckx-Rice wrote:
>> I'm not convinced that increasing the number of inputs to
>> silence
>> (harmless) warnings in the build logs is a way to go.
>
> It did not look harmless to me...

I understand. It's actually quite common (as these things go) but
tends to go unnoticed exactly because it's harmless. Once you
notice it you see it everywhere.

Toggle quote (2 lines)
> Nope, feel free to close the issue

Done!

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXr011AAKCRANsP+IT1Vt
eUZVAQCk55RXoG6BCKHtz9cpdUgQ6MtgbK82coaVV88HiLKxDgD/YlHf3KWyAYpP
Pgz1ZhpcJlphVeGjUcac9KC+8SWHnwI=
=J0xy
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41254@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41254
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help