[PATCH 0/2] Fix bitcoin-core build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Marius Bakke
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
87h7wmpcsk.fsf@cbaines.net
Christopher Baines (2):
gnu: finance: bitcoin-core: Reformat the package definition.
gnu: finance: bitcoin-core: Disable a test that spuriously fails.

gnu/packages/finance.scm | 69 +++++++++++++++++++++-------------------
1 file changed, 37 insertions(+), 32 deletions(-)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl65k/tfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdQXg/9FAAGc20crCV9U46ctwQihr7qe3zu+/LJQe1PcYrVfAEtKDJEYCgEnLbN
3mS1Y1WHMkqNS4MvmdBOjtFC4262zxeMOD6stCwgtzw2p3HG8ng6kCWff1D4d4Be
nY+X5y8nldw0OfT0L29/zBTONkfZsGXLTc2PTTB7JRGmvmdr8+UZwj0Bw2+KL0z5
SANtSM1o3qcFb9+5G2tX+SUNWwf9+fA0wkgXIqdHSlNgbJzLVrDX4+o16YFn2qzz
KbQpddufEOwu7qNNfbwfb8wPwF9Gk8hxiR6FQO4iUI+O86AsJVgCBKbe0D5Q3vBi
KM4ComaF1kH9Qv0aCgKN8CMAaJnyUPsrXkHUSeOIaWuKfvLwbL62SxanBvJDuFEl
Gyc2Lj+yh37krnflv0b3AbW1FX2bKGRJwAdBBbqcB5Q59JlEWVv3KkCtrBABLjq+
p0Qq7LSsVluIWZTDf3EcApyV1/IsUFR6vwkdOoDNVsI6Ta1MPGB8x/lwx04E6gld
jYZa0RRGIpk41zRntDg5nyfXbTnaMn9vZFcwRQxrhVGb9deYbHUWKOKVTeGrXQ6H
GKz/E32Ey1m/YL4hUjvmAYUhHano3YWUxACD+Ulr0FkRuN7EEIpQsRDd1PBA7DoH
CeI+qedxdMlCiLxZvD2x6ChYCJENBhOUSYtBKBR/U87S+wBk4lg=
=QKX/
-----END PGP SIGNATURE-----

Christopher Baines wrote 5 years ago
[PATCH 2/2] gnu: finance: bitcoin-core: Disable a test that spuriously fails.
(address . 41190@debbugs.gnu.org)
20200511181656.25849-2-mail@cbaines.net
* gnu/packages/finance.scm (bitcoin-core)[arguments]: Disable a test.
---
gnu/packages/finance.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 094b25c9fe..85023f556c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -155,6 +155,10 @@
(lambda _
(invoke
"python3" "./test/functional/test_runner.py"
+ ;; Test fails due to Python deprecation warning in the
+ ;; test. This is fixed upstream
+ ;; https://github.com/bitcoin/bitcoin/pull/17931
+ "--exclude=p2p_invalid_messages"
(string-append "--jobs=" (number->string (parallel-job-count))))
#t)))))
(home-page "https://bitcoin.org/en/")
--
2.26.2
Christopher Baines wrote 5 years ago
[PATCH 1/2] gnu: finance: bitcoin-core: Reformat the package definition.
(address . 41190@debbugs.gnu.org)
20200511181656.25849-1-mail@cbaines.net
Change the indentation to match what Emacs does.

* gnu/packages/finance.scm (bitcoin-core): Change indentation of many lines.
---
gnu/packages/finance.scm | 65 ++++++++++++++++++++--------------------
1 file changed, 33 insertions(+), 32 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index dfc89cae1e..094b25c9fe 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -104,13 +104,13 @@
(name "bitcoin-core")
(version "0.19.1")
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://bitcoincore.org/bin/bitcoin-core-"
- version "/bitcoin-" version ".tar.gz"))
- (sha256
- (base32
- "1h3w7brc18145np920vy7j5ms5hym59hvr40swdjx34fbdaisngj"))))
+ (method url-fetch)
+ (uri
+ (string-append "https://bitcoincore.org/bin/bitcoin-core-"
+ version "/bitcoin-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1h3w7brc18145np920vy7j5ms5hym59hvr40swdjx34fbdaisngj"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -127,35 +127,36 @@
("qtbase" ,qtbase)))
(arguments
`(#:configure-flags
- (list
- ;; Boost is not found unless specified manually.
- (string-append "--with-boost="
- (assoc-ref %build-inputs "boost"))
- ;; XXX: The configure script looks up Qt paths by
- ;; `pkg-config --variable=host_bins Qt5Core`, which fails to pick
- ;; up executables residing in 'qttools', so we specify them here.
- (string-append "ac_cv_path_LRELEASE="
- (assoc-ref %build-inputs "qttools")
- "/bin/lrelease")
- (string-append "ac_cv_path_LUPDATE="
- (assoc-ref %build-inputs "qttools")
- "/bin/lupdate"))
+ (list
+ ;; Boost is not found unless specified manually.
+ (string-append "--with-boost="
+ (assoc-ref %build-inputs "boost"))
+ ;; XXX: The configure script looks up Qt paths by
+ ;; `pkg-config --variable=host_bins Qt5Core`, which fails to pick
+ ;; up executables residing in 'qttools', so we specify them here.
+ (string-append "ac_cv_path_LRELEASE="
+ (assoc-ref %build-inputs "qttools")
+ "/bin/lrelease")
+ (string-append "ac_cv_path_LUPDATE="
+ (assoc-ref %build-inputs "qttools")
+ "/bin/lupdate"))
#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'make-qt-deterministic
+ (modify-phases %standard-phases
+ (add-before 'configure 'make-qt-deterministic
(lambda _
- ;; Make Qt deterministic.
- (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
- #t))
- (add-before 'check 'set-home
+ ;; Make Qt deterministic.
+ (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
+ #t))
+ (add-before 'check 'set-home
(lambda _
- (setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
- #t))
- (add-after 'check 'check-functional
+ (setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
+ #t))
+ (add-after 'check 'check-functional
(lambda _
- (invoke "python3" "./test/functional/test_runner.py"
- (string-append "--jobs=" (number->string (parallel-job-count))))
- #t)))))
+ (invoke
+ "python3" "./test/functional/test_runner.py"
+ (string-append "--jobs=" (number->string (parallel-job-count))))
+ #t)))))
(home-page "https://bitcoin.org/en/")
(synopsis "Bitcoin peer-to-peer client")
(description
--
2.26.2
Marius Bakke wrote 5 years ago
Re: [bug#41190] [PATCH 2/2] gnu: finance: bitcoin-core: Disable a test that spuriously fails.
878shyw7yt.fsf@devup.no
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (2 lines)
> * gnu/packages/finance.scm (bitcoin-core)[arguments]: Disable a test.

Uff, I pushed a fix for this in 46bbdef24701db8e61326b0645fd426a17111a11
that took the upstream patch.

You are too polite, asking for reviews instead of pushing straight to
master! :-P

Sorry for the duplicate work.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl65sKsACgkQoqBt8qM6
VPrVOAgA0FoAMrvLYOwBk6PGKT54cnSmRVUowa4LwvTecQyDPo3GdayMEGCaXdkL
Pj27bDC+SXNAfnT6sofwMOUe1C0R+HydfxBDPTKXGPbBEetwYqOZ3ZbblYul+3H3
IkNS/NOD5g1p6fQhgXe9WrZr2r0nukUQyRCw4QYlKSZd5i9L3xcHzABnE/zbOq9h
C+Lar1ZBA+NhPiE+s6NcmijteUxUn0N+qG0CQx/Ob3DH9E2eCiaJ7XT/fsVfYJwu
rwBmtmgPhmUgVxNovhsT/Me9IozaWuqZrt2mgmyaNqiL/sywfhuFn58qo/K25YVu
j2u4p8f+DCq7mEalNQ5wYk5aNYb3rw==
=m/Bc
-----END PGP SIGNATURE-----

Marius Bakke wrote 5 years ago
Re: [bug#41190] [PATCH 1/2] gnu: finance: bitcoin-core: Reformat the package definition.
875zd2w7xo.fsf@devup.no
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (4 lines)
> Change the indentation to match what Emacs does.
>
> * gnu/packages/finance.scm (bitcoin-core): Change indentation of many lines.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl65sNMACgkQoqBt8qM6
VPoPtggAtXbXCMoWX6j7oqXm8obrbWmTKzZRwP9MxcuU8EW4fTpe9heDJDDUsM7k
3BAJyM5v0DnzqoX9fYcHL83E5ksRMqDwVuKhl0MuUsrLXoTdtlTwl3zeEk+Enul5
S/N/iuhRU1wnqhCAk9WcUemW/BY1vHp3cL5O1bZWUTI4skEPIxVHoF4ENhXnW3on
lQfZ9jMjZ+GO6cETLitYtjTO2t1rELE4r2TwwovlsH08gjtoi6xwk4kp/q0/Txx+
vy/gfa6w2qm+3sOTSvA16pJn+N9DOxiGEpKnA8Uvyv71WCdDOZxWSXGeI137lymn
t54MzAWrT4NheSL5dMQlcntO47IBZg==
=6pgI
-----END PGP SIGNATURE-----

Marius Bakke wrote 5 years ago
873686w7ui.fsf@devup.no
I don't think mentioning the module in the commit header is necessary,
as it is only an implementation detail. Referring to 'gnu: finance: '.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl65sUUACgkQoqBt8qM6
VPqbYgf9HgyLSEYP1GO7C0A+D/Njwrd8GVaHSGXBvamppArTjNMr/vqRlnDUVRv+
8CIVjoPN/ieYbgQovlKX4qOlhnA7WXJ1Q2MyXOvGmpYyXq3kX0wPUMwfiOrYsnxz
wBTqNGaEUyqnhr4eCRTRKgADl8JbsL6UTl/1HoMlTR51PShTQQlAoncSDW84CC2m
pg8HoZfepQa6THowoFNJZpugaim1eS7hMorFmnQp60GQBNuDapcHL14wqWtgtaVD
CsxrKkUOkivlQK77LBcnRdaRdZ4aKtLGI9oMekNyu4MzC6pVfgHqVHnKOt0d46Jg
5F3zmHOfD8hO2bz1suEelIO+gZEyTQ==
=dzqk
-----END PGP SIGNATURE-----

Christopher Baines wrote 5 years ago
Re: [bug#41190] [PATCH 2/2] gnu: finance: bitcoin-core: Disable a test that spuriously fails.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 41190@debbugs.gnu.org)
87o8qrogv2.fsf@cbaines.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (12 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/packages/finance.scm (bitcoin-core)[arguments]: Disable a test.
>
> Uff, I pushed a fix for this in 46bbdef24701db8e61326b0645fd426a17111a11
> that took the upstream patch.
>
> You are too polite, asking for reviews instead of pushing straight to
> master! :-P
>
> Sorry for the duplicate work.

No problem, at least both of us have looked at it, which is sort of like
patch review :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl68NaFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfAIw//fjf8oVuNmU0kb4oUcbXCe9w956sqE/L87pV54GwAfryxnwc4AslOLLhb
S6O+V6cM7HpQInZze7EfXyEAQNd5sayEsRnMp72TuhjEDgwloxMru/Q97xG93yTj
H/iT8AWdQgEaTSKJqFb9fL7j9YAXLRIy/mFcjcKTcmzVfBU6caADeX2MQUpBaYji
aOH7toAyGy5AXphuYNBFb7gJh0nRq3E1s8wSgcnd2TmS69p6N9YY1GVck3obgOt5
1tbrgIAnrY0Bk1iWG4PELdF3lNVhhflWmt76hq6ID3BTHYIULdS8dBfqRqgQ+W20
UybUI9aLMwLvB+9CYDe6DXkch4/zYLPbXlxPOp8OlcdMD7QqSFE23fQVwzB8Xtbh
+62MTO5nOozshzbFI1DJpYMbWZDtGp4INm951cT2AqS3J4ITPS8gj94f0a5A6a8F
eVA4XlQyJePKq7RsTvTNRXSDA0isU7LFezaCrZXfYP6a+9b5g4y1/zehM7xbfwxe
VC2CvQ8tCQ1Yle2JhMGgnW+VqRlMdGooHMayDo5OOFk6WVFfDvk9xApc5Crxaq3o
4DF+5TGODA4SCdF79ShkgXyzOWoVBkkYta5as8gdmBk/Fv/fDDJ24HDZhDz9brPV
WLn/pejvirpFo1zg5eHzjBmOL9N9WoGIl6sWsNfknyCZqD6ww84=
=49IQ
-----END PGP SIGNATURE-----

Christopher Baines wrote 5 years ago
Re: [bug#41190] [PATCH 1/2] gnu: finance: bitcoin-core: Reformat the package definition.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 41190-done@debbugs.gnu.org)
87mu6bogpv.fsf@cbaines.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (8 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> Change the indentation to match what Emacs does.
>>
>> * gnu/packages/finance.scm (bitcoin-core): Change indentation of many lines.
>
> LGTM.

Great, I've gone ahead and pushed this as
8ba4d8a347fbdf9fe09e8ac801b4ac0586ac382a.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl68NlxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xen/A//fuoynr7ypAAU3A3RHyLpKEWXxPZSETOCjDxCzUmK0F9uBGOyJ26gOZuY
TS6uL+Hj+EKZfmVTn3A/hIODp2F7RiIGa3G6/hVbaQya5RzENtimYxsdOPJBbzzn
cFdNFnIk7OuIVHzlx/dP/zwnpOCyW/l8QOHGYfpAHQ/YkvgVZznYqguqD3OHSSeP
rklTp1b4Uz0ypSxRPSOVTruKZaZQFUIiwIvJiuf1lcyBd0hYL6T7By+g5hmtpuPV
+hZwAxxYPN8hgGr2GdWHuT+Iw6UicSPcz/g0C4aHi15sbo4Gg+7MyC4ORTBNW1vp
6autguSWuLvzFwzs+SZVEfZpQ0Vjna8dHaRpyvhRdJHbsr3K6ZdAgovE8XqJf6jk
xtuWuDVKDGFjmlwRkh0xi0uLGOKVg0++cOE0DsCVgstX7A8QicPanUD8U8axs9gj
gJzlpCRZweX7shBRbpK1VDCraJQTzi4jhX3QbOna7drn5JyP88HOzFV2Amfy1Nj/
s7JNkqagq/S1XR8wZtC7hv17+j8wm9PmtGO28R9/OoGpCWcI2eE+OzTXxVLcyzAZ
29MZrHcSVDufUeNV5BFdAOZqpAyeJgu3JlmpR4s0oFltxElur1hHjaR7I3GiY2eV
now7IORsY3/c1agNpD7Gj+KjXu0P3PEQg1SNJtrqKqPs4i95YVg=
=u0qZ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41190@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41190
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help