[PATCH] gnu: Add ecm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 5 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20200510174450.5540-1-kkebreau@posteo.net
* gnu/packages/compression.scm (ecm): New variable.
---
gnu/packages/compression.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index b599f3a603..a71981374e 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016, 2019 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2019, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
@@ -2189,3 +2189,33 @@ computations.")
;; Blosc itself is released under BSD-3 but it incorporates code under
;; other non-copyleft licenses.
(license license:bsd-3)))
+
+(define-public ecm
+ (package
+ (name "ecm")
+ (version "1.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alucryd/ecm-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rvyx5gcy8lfklgj80szlz3312x45wzx0d9jsgwyvy8f6m4nnb0c"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags (list "CC=gcc"
+ (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "Makefile"
+ (("\\$\\(DESTDIR\\)/usr") "$(DESTDIR)"))
+ #t)))))
+ (home-page "https://github.com/alucryd/ecm-tools")
+ (synopsis "Error code modeler")
+ (description "ECM is a utility that converts ECM files to BIN CD format.")
+ (license license:gpl3+)))
--
2.26.0
Mathieu Othacehe wrote 5 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 41179@debbugs.gnu.org)
87lflw42co.fsf@gnu.org
Hello,

Toggle quote (11 lines)
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1rvyx5gcy8lfklgj80szlz3312x45wzx0d9jsgwyvy8f6m4nnb0c"))))
> + (build-system gnu-build-system)
> + (arguments
> + '(#:tests? #f ; no check target
> + #:make-flags (list "CC=gcc"

Hard-coding CC breaks cross-compilation. See 'powerstat' package for how
to fix it.

Toggle quote (13 lines)
> + (string-append "DESTDIR=" (assoc-ref %outputs "out")))
> + #:phases
> + (modify-phases %standard-phases
> + (replace 'configure
> + (lambda _
> + (substitute* "Makefile"
> + (("\\$\\(DESTDIR\\)/usr") "$(DESTDIR)"))
> + #t)))))
> + (home-page "https://github.com/alucryd/ecm-tools")
> + (synopsis "Error code modeler")
> + (description "ECM is a utility that converts ECM files to BIN CD format.")
> + (license license:gpl3+)))

Maybe you could elaborate a bit on what are ECM files.

Otherwise, seems fine :)

Thanks,

Mathieu
Kei wrote 5 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 41179-done@debbugs.gnu.org)
5034689eda7d9757057b8d64915040f33b6630fb.camel@posteo.net
On Wed, 2020-05-13 at 11:21 +0200, Mathieu Othacehe wrote:
Toggle quote (19 lines)
> Hello,
>
> > + (url "https://github.com/alucryd/ecm-tools")
> > + (commit (string-append "v" version))))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32
> > + "1rvyx5gcy8lfklgj80szlz3312x45wzx0d9jsgwyvy8f6m4nn
> > b0c"))))
> > + (build-system gnu-build-system)
> > + (arguments
> > + '(#:tests? #f ; no check target
> > + #:make-flags (list "CC=gcc"
>
> Hard-coding CC breaks cross-compilation. See 'powerstat' package for
> how
> to fix it.
>

Thanks for the pointer! It's been fixed.

Toggle quote (18 lines)
> > + (string-append "DESTDIR=" (assoc-ref
> > %outputs "out")))
> > + #:phases
> > + (modify-phases %standard-phases
> > + (replace 'configure
> > + (lambda _
> > + (substitute* "Makefile"
> > + (("\\$\\(DESTDIR\\)/usr") "$(DESTDIR)"))
> > + #t)))))
> > + (home-page "https://github.com/alucryd/ecm-tools")
> > + (synopsis "Error code modeler")
> > + (description "ECM is a utility that converts ECM files to BIN
> > CD format.")
> > + (license license:gpl3+)))
>
> Maybe you could elaborate a bit on what are ECM files.
>

Done!

Toggle quote (6 lines)
> Otherwise, seems fine :)
>
> Thanks,
>
> Mathieu

Thanks for reviewing. This patch has been pushed to master as commit
3480ceb10a.

Kei
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41179@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41179
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help