[PATCH] Update epiphany and enable tests

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
ac4576446260bf3e6ca18aa867f5e59f919748b3.camel@student.tugraz.at
I've noticed, that 3.34.2 is not the latest 3.34 version of epiphany
and in thus updated it to 3.34.4 in hope it would fix an annoyance,
that I'm currently experiencing. It did not. Still, I'd like to share
my patch.

I also saw, that tests are currently disabled, so I've isolated the
breaking tests and skip only those, as is customary.
Leo Prikler wrote 5 years ago
[PATCH 2/2] gnu: epiphany: enable tests.
(address . 41173@debbugs.gnu.org)
20200510133157.8950-2-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (epiphany)[arguments]<#:tests?>: Drop it.
<#:phases>: Add disable-failing-tests and pre-check.
[inputs]: Add xorg-server-for-tests.
---
gnu/packages/gnome.scm | 26 ++++++++++++++++++--------
1 file changed, 18 insertions(+), 8 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6ff1e6772d..9eee85227d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5410,13 +5410,7 @@ a secret password store, an adblocker, and a modern UI.")
(build-system meson-build-system)
(arguments
- ;; FIXME: tests run under Xvfb, but fail with:
- ;; /src/bookmarks/ephy-bookmarks/create:
- ;; ** (test-ephy-bookmarks:19591): WARNING **: Unable to start Zeroconf
- ;; subsystem
- ;; FAIL
- '(#:tests? #f
- #:glib-or-gtk? #t
+ '(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -5424,6 +5418,21 @@ a secret password store, an adblocker, and a modern UI.")
(lambda _
(substitute* "post_install.py"
(("gtk-update-icon-cache") "true"))
+ #t))
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/meson.build"
+ ;; embed_shell fails, because webkitgtk apparently no longer supports
+ ;; overriding the ftp schema
+ ;; web_app_utils fails due to missing network access
+ (("(embed_shell|web_app_utils)_test,")
+ "find_program('sh'), args: ['-c', 'exit 77'],"))
+ #t))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
#t)))
#:configure-flags
;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
@@ -5437,7 +5446,8 @@ a secret password store, an adblocker, and a modern UI.")
("intltool" ,intltool)
("itstool" ,itstool)
("pkg-config" ,pkg-config)
- ("xmllint" ,libxml2)))
+ ("xmllint" ,libxml2)
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("avahi" ,avahi)
("gcr" ,gcr)
--
2.26.2
Leo Prikler wrote 5 years ago
[PATCH 1/2] gnu: epiphany: Update to 3.34.4.
(address . 41173@debbugs.gnu.org)
20200510133157.8950-1-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (epiphany): Update to 3.34.4.
---
gnu/packages/gnome.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d5a2032ccf..6ff1e6772d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5398,7 +5398,7 @@ a secret password store, an adblocker, and a modern UI.")
(define-public epiphany
(package
(name "epiphany")
- (version "3.34.2")
+ (version "3.34.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/epiphany/"
@@ -5406,7 +5406,7 @@ a secret password store, an adblocker, and a modern UI.")
"epiphany-" version ".tar.xz"))
(sha256
(base32
- "18d48vcp2nxs63bddkdplslgbnlfq79pm2ivl8hk38kkggy3dahf"))))
+ "13ar3s40cds1rplwbzx0fzigf120w0rydiv05r3k6zpc0zy91qb0"))))
(build-system meson-build-system)
(arguments
--
2.26.2
Ricardo Wurmus wrote 5 years ago
Re: [bug#41173] [PATCH] Update epiphany and enable tests
(address . 41173-done@debbugs.gnu.org)
87lflw26e7.fsf@elephly.net
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (8 lines)
> I've noticed, that 3.34.2 is not the latest 3.34 version of epiphany
> and in thus updated it to 3.34.4 in hope it would fix an annoyance,
> that I'm currently experiencing. It did not. Still, I'd like to share
> my patch.
>
> I also saw, that tests are currently disabled, so I've isolated the
> breaking tests and skip only those, as is customary.

Thank you. Looks like your patches have already been applied with
commit 20710b911f7784c5602799181d6f108814695b31, so I’m closing this
issue.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41173@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41173
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help