[PATCH] gnu: vis: Fix #39394

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub Kądziołka
  • tsmish
Owner
unassigned
Submitted by
tsmish
Severity
normal

Debbugs page

tsmish wrote 5 years ago
(address . guix-patches@gnu.org)
CAMaATaNQBPNbx6GGcnSgR5h1C6s2CpOsSEYscTWTMRKn-cPQwA@mail.gmail.com
There is no need to set $VIS_PATH to $prefix/share/vis as VIS_PATH
(#define), which is also in search path
is already set by Makefile to $prefix/share/vis

---
gnu/packages/text-editors.scm | 4 ----
1 file changed, 4 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 886babf3fa..5b17a5082f 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -101,10 +101,6 @@
`("LUA_PATH" ":" prefix (,LUA_PATH))
`("LUA_CPATH" ":" prefix (,LUA_CPATH)))
#t))))))
- (native-search-paths
- (list (search-path-specification
- (variable "VIS_PATH")
- (files '("share/vis")))))
(inputs `(("lua" ,lua)
("ncurses" ,ncurses)
("libtermkey" ,libtermkey)
--
2.26.2
Jakub Kądziołka wrote 5 years ago
(name . tsmish)(address . tsymsh@gmail.com)(address . 41151-done@debbugs.gnu.org)
20200601134413.m65s76owjlhlqg5e@gravity
On Sat, May 09, 2020 at 03:51:53PM +0000, tsmish wrote:
Toggle quote (6 lines)
> There is no need to set $VIS_PATH to $prefix/share/vis as VIS_PATH
> (#define), which is also in search path
> (https://github.com/martanne/vis/blob/7648280a95954304e5e935e2cead16d836b86eda/vis-lua.c#L2662),
> is already set by Makefile to $prefix/share/vis
> (https://github.com/martanne/vis/blob/7648280a95954304e5e935e2cead16d836b86eda/Makefile#L37).

Thanks for the patch! We usually avoid putting a bug number as the only
information in the commit title, so I took the liberty to rewrite the
commit message a bit:

commit 5b588f2c9ba9c40dc32aed7c3cdaa45e8f920509 (HEAD -> master, upstream/master)
Author: tsmish <tsymsh@gmail.com>
Date: Sat May 9 15:51:53 2020 +0000

gnu: vis: Fix configuration load order.

* gnu/packages/text-editors.scm (vis)[native-search-paths]: Remove.

There is no need to set $VIS_PATH to $prefix/share/vis as VIS_PATH
(#define), which is also in search path
is already set by Makefile to $prefix/share/vis


Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>

Cheers!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl7VBiwACgkQ4xWnWEYT
FWRsGxAA0c+TRI73gNXvOoHHpwMz4Al9jBzPSxVbUlQAghBIulRF9c0lIx8P7kDv
/rUXQHHYFCKx6xNx+xaosYmcm8dHGfPAWfns+t0aRnb8fik0EwVnSM+zBJZohah4
SUSxG/UlkuaQ6odPgwGqu6XSAppQ8FdaqKWzg9u0AqxiUXM1nmGiKWrPrHNld4yp
nwLbZg2Qn3mfTz4snR0Q5r4//Bluhs2il2XdkChh/zQ+HXVuXpmZkcB/SgO4x5n/
YRllSRlMFkfwTZoTkm9D0qIKl8u7D396tdIk/pGroWbFQFO4lkMSNuF89A652GQH
XXjL9vjeiyiVn/3mPniSuDz7b1u89rfMiZnNiR+sQ+O3r7Eb6bACqBMx9dPS36Ep
NXCyTnXXBlbnhKUseEMaKTIFIFULXivJtPb0V6B+mJZF97Uv3f3PSf1W86wVOaTG
LZl4NajDVp8flAwIJUyYSYWm+gzi518lHDyEKOeFc/doTM9RSV+acWBr04bVRZTw
CZBs790XdwsCYBEvyOl7tyXZkxC8GK3lLhUVzddZIwE1upwVivlqFq/I3j7yj0vs
+VsLxjdVdGscRCO9jXaLh4RgCy/Oiyvs8+8DlPWRjciBSDljnS3lL54OFjSjHGyF
Vyf9r00wKUbbJZ6NXZ6cvefkJupNuwHEqgQsxUI7nwU6jZyERjQ=
=6As7
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41151@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41151
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help