Josh Marshall wrote 5 years ago
(address . guix-patches@gnu.org)
Here's an addition for the python-pytest-asyncio package. I'm not sure how
to merge the patches, but the two patches attached refer to the same
package.
From c881b474072b4d8eb62a16624d0f193671b72b0c Mon Sep 17 00:00:00 2001
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
Date: Sun, 3 May 2020 18:58:56 -0400
Subject: [PATCH 2/2] Linting
To: guix-patches@gnu.org
---
gnu/packages/check.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index eda33e283c..93d9da946b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1427,7 +1427,7 @@ executed.")
("python-async-generator" ,python-async-generator)
("python-hypothesis" ,python-hypothesis)))
(home-page "https://github.com/pytest-dev/pytest-asyncio")
- (synopsis "Pytest support for asyncio.")
+ (synopsis "Pytest support for asyncio")
(description "Python asyncio code is usually written in the form of
coroutines, which makes it slightly more difficult to test using normal
testing tools. pytest-asyncio provides useful fixtures and markers to make
--
2.25.1
From 66c95e2d01d194fd95d3a96e5fe513aa07b4a92f Mon Sep 17 00:00:00 2001
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
Date: Sun, 3 May 2020 18:22:23 -0400
Subject: [PATCH 1/2] Merged adding authors
To: guix-patches@gnu.org
---
gnu/packages/check.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 427607e6de..eda33e283c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1408,6 +1409,32 @@ executed.")
(define-public python2-coverage
(package-with-python2 python-coverage))
+(define-public python-pytest-asyncio
+ (package
+ (name "python-pytest-asyncio")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-asyncio" version))
+ (sha256
+ (base32 "1bysy4nii13bm7h345wxf8fxcjhab7l374pqdv7vwv3izl053b4z"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-async-generator" ,python-async-generator)
+ ("python-hypothesis" ,python-hypothesis)))
+ (home-page "https://github.com/pytest-dev/pytest-asyncio")
+ (synopsis "Pytest support for asyncio.")
+ (description "Python asyncio code is usually written in the form of
+coroutines, which makes it slightly more difficult to test using normal
+testing tools. pytest-asyncio provides useful fixtures and markers to make
+testing easier.")
+ (license license:asl2.0)))
+
+
(define-public python-cov-core
(package
(name "python-cov-core")
--
2.25.1