Add python-pytest-asyncio

  • Done
  • quality assurance status badge
Details
2 participants
  • Josh Marshall
  • Marius Bakke
Owner
unassigned
Submitted by
Josh Marshall
Severity
normal

Debbugs page

Josh Marshall wrote 5 years ago
(address . guix-patches@gnu.org)
CAFkJGRdXz=GfarOjDM3c-rxyNkei7_taM=0iLEgGdhcC279t1A@mail.gmail.com
Here's an addition for the python-pytest-asyncio package. I'm not sure how
to merge the patches, but the two patches attached refer to the same
package.
Attachment: file
From c881b474072b4d8eb62a16624d0f193671b72b0c Mon Sep 17 00:00:00 2001
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
Date: Sun, 3 May 2020 18:58:56 -0400
Subject: [PATCH 2/2] Linting
To: guix-patches@gnu.org

---
gnu/packages/check.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index eda33e283c..93d9da946b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1427,7 +1427,7 @@ executed.")
("python-async-generator" ,python-async-generator)
("python-hypothesis" ,python-hypothesis)))
(home-page "https://github.com/pytest-dev/pytest-asyncio")
- (synopsis "Pytest support for asyncio.")
+ (synopsis "Pytest support for asyncio")
(description "Python asyncio code is usually written in the form of
coroutines, which makes it slightly more difficult to test using normal
testing tools. pytest-asyncio provides useful fixtures and markers to make
--
2.25.1
From 66c95e2d01d194fd95d3a96e5fe513aa07b4a92f Mon Sep 17 00:00:00 2001
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
Date: Sun, 3 May 2020 18:22:23 -0400
Subject: [PATCH 1/2] Merged adding authors
To: guix-patches@gnu.org

---
gnu/packages/check.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 427607e6de..eda33e283c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1408,6 +1409,32 @@ executed.")
(define-public python2-coverage
(package-with-python2 python-coverage))
+(define-public python-pytest-asyncio
+ (package
+ (name "python-pytest-asyncio")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-asyncio" version))
+ (sha256
+ (base32 "1bysy4nii13bm7h345wxf8fxcjhab7l374pqdv7vwv3izl053b4z"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-async-generator" ,python-async-generator)
+ ("python-hypothesis" ,python-hypothesis)))
+ (home-page "https://github.com/pytest-dev/pytest-asyncio")
+ (synopsis "Pytest support for asyncio.")
+ (description "Python asyncio code is usually written in the form of
+coroutines, which makes it slightly more difficult to test using normal
+testing tools. pytest-asyncio provides useful fixtures and markers to make
+testing easier.")
+ (license license:asl2.0)))
+
+
(define-public python-cov-core
(package
(name "python-cov-core")
--
2.25.1
Marius Bakke wrote 5 years ago
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)(address . 41067-done@debbugs.gnu.org)
87r1vyxnve.fsf@devup.no
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

Toggle quote (4 lines)
> Here's an addition for the python-pytest-asyncio package. I'm not sure how
> to merge the patches, but the two patches attached refer to the same
> package.

Thanks! You can use 'git commit --amend' to adjust the current commit.
For multiple commit there is 'git rebase --interactive HEAD~2' to open a
menu where you can "squash" the last two patches together.

Regardless, I've squashed the patches, fixed the indentation, added
double spacing and a little extra context in the description, and
finally provided a proper commit message.

Applied!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6xqeUACgkQoqBt8qM6
VPrN8wf/dcK23gVnwPvRrt2LKlZJKVcwPDcpXEHVfxfMzXsCUdeSH1Va9fx+cEtj
8ZLNgwWZdhIle8iZY7Hq8MnTKvN3lz85NqlqkUPhxMssRlA9EMrLl+Mr4EqbdUVU
yTTiuQkvghg5ZQhPveulj76ylHhY2RxUfLDBYcpdBmGGbzoCMZ0J/19z/wvikasS
TbNeRcJjltZs8XwPZMPvoHIQcsEw//waroIZTEUb+glDqd5H057wPSAcfS/yE0iH
CIGxAz5UGCa0E9GLre8rLcRvIAkWsylH0GP5Zf+8VH8CRXVuqeK9R7hZb6pxol+y
NpjZ3Qg42g+LLB/bYQXHQAmvfvpKPg==
=tMyW
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41067@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41067
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help