Contributing section from manual does not work when I'm working on some patches

  • Done
  • quality assurance status badge
Details
2 participants
  • Josh Marshall
  • Marius Bakke
Owner
unassigned
Submitted by
Josh Marshall
Severity
normal

Debbugs page

Josh Marshall wrote 5 years ago
(address . bug-guix@gnu.org)
CAFkJGRc7E6QJbKxPywQuMXBzuuNv_kJpwvb2UjERdOPp_5oRfA@mail.gmail.com
Hello all,

So I'm trying to get individual patches for the django overhaul I've been
working on polished up and ready for submission. Trying to follow the
steps in the manual for running and testing builds of these is not
working. lfam from IRC suggested that guile-gcrypt might be missing, but
that implies that required dependencies are missing.

Working off of commit 223e920abc023be91fe1e6747c599d547ad12bc5

with patch
```
Toggle diff (105 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 2cfaddbc5f..e2f90c1240 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1398,6 +1399,32 @@ executed.")
(define-public python2-coverage
(package-with-python2 python-coverage))

+(define-public python-pytest-asyncio
+ (package
+ (name "python-pytest-asyncio")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-asyncio" version))
+ (sha256
+ (base32
"1bysy4nii13bm7h345wxf8fxcjhab7l374pqdv7vwv3izl053b4z"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-async-generator" ,python-async-generator)
+ ("python-hypothesis" ,python-hypothesis)))
+ (home-page "https://github.com/pytest-dev/pytest-asyncio")
+ (synopsis "Pytest support for asyncio.")
+ (description "Python asyncio code is usually written in the form of
+coroutines, which makes it slightly more difficult to test using normal
+testing tools. pytest-asyncio provides useful fixtures and markers to make
+testing easier.")
+ (license license:asl2.0)))
+
+
(define-public python-cov-core
(package
(name "python-cov-core")
```

has the following results from various invocations:

```
anadon@goodadvicemallard:~/documents/code/guix$ ./pre-inst-env guix
guile: warning: failed to install locale
Backtrace:
In ice-9/threads.scm:
390:8 19 (_ _)
In ice-9/boot-9.scm:
2994:20 18 (_)
2312:4 17 (save-module-excursion _)
3014:26 16 (_)
In unknown file:
15 (primitive-load-path "guix/store" #<procedure 7fa451b4a?>)
In guix/store.scm:
22:0 14 (_)
In ice-9/boot-9.scm:
2874:4 13 (define-module* _ #:filename _ #:pure _ #:version _ # _ ?)
2887:24 12 (_)
222:29 11 (map1 (((guix utils)) ((guix config)) ((guix #)) ((?)) ?))
222:29 10 (map1 (((guix config)) ((guix deprecation)) ((guix ?)) ?))
222:29 9 (map1 (((guix deprecation)) ((guix memoization)) ((?)) ?))
222:29 8 (map1 (((guix memoization)) ((guix serialization)) (#) ?))
222:29 7 (map1 (((guix serialization)) ((guix monads)) ((# #)) ?))
222:29 6 (map1 (((guix monads)) ((guix records)) ((guix #)) (#) ?))
222:29 5 (map1 (((guix records)) ((guix base16)) ((guix #)) (#) ?))
222:29 4 (map1 (((guix base16)) ((guix base32)) ((gcrypt #)) # ?))
222:29 3 (map1 (((guix base32)) ((gcrypt hash)) ((guix #)) (#) ?))
222:17 2 (map1 (((gcrypt hash)) ((guix profiling)) ((rnrs #)) # ?))
2803:6 1 (resolve-interface _ #:select _ #:hide _ #:prefix _ # _ ?)
In unknown file:
0 (scm-error misc-error #f "~A ~S" ("no code for modu?" ?) ?)

ERROR: In procedure scm-error:
no code for module (gcrypt hash)
```

```
anadon@goodadvicemallard:~/documents/code/guix$ guix environment guix --
./pre-inst-env guix
guile: warning: failed to install locale
guix environment: error: failed to connect to
`/var/guix/daemon-socket/socket': Connection refused
```

```
anadon@goodadvicemallard:~/documents/code/guix$ guix environment guix --
./pre-inst-env guix build python-pytest-asyncio
guile: warning: failed to install locale
guix build: error: failed to connect to
`/usr/local/var/guix/daemon-socket/socket': Connection refused
```

The daemon has been run via systemd and
`anadon@goodadvicemallard:~/documents/code/guix$
sudo -E ./pre-inst-env guix-daemon --build-users-group=guixbuild` to
similar effect.
Attachment: file
Marius Bakke wrote 5 years ago
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)(address . 41059@debbugs.gnu.org)
87h7wv222b.fsf@devup.no
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

Toggle quote (37 lines)
> has the following results from various invocations:
>
> ```
> anadon@goodadvicemallard:~/documents/code/guix$ ./pre-inst-env guix
> guile: warning: failed to install locale
> Backtrace:
> In ice-9/threads.scm:
> 390:8 19 (_ _)
> In ice-9/boot-9.scm:
> 2994:20 18 (_)
> 2312:4 17 (save-module-excursion _)
> 3014:26 16 (_)
> In unknown file:
> 15 (primitive-load-path "guix/store" #<procedure 7fa451b4a?>)
> In guix/store.scm:
> 22:0 14 (_)
> In ice-9/boot-9.scm:
> 2874:4 13 (define-module* _ #:filename _ #:pure _ #:version _ # _ ?)
> 2887:24 12 (_)
> 222:29 11 (map1 (((guix utils)) ((guix config)) ((guix #)) ((?)) ?))
> 222:29 10 (map1 (((guix config)) ((guix deprecation)) ((guix ?)) ?))
> 222:29 9 (map1 (((guix deprecation)) ((guix memoization)) ((?)) ?))
> 222:29 8 (map1 (((guix memoization)) ((guix serialization)) (#) ?))
> 222:29 7 (map1 (((guix serialization)) ((guix monads)) ((# #)) ?))
> 222:29 6 (map1 (((guix monads)) ((guix records)) ((guix #)) (#) ?))
> 222:29 5 (map1 (((guix records)) ((guix base16)) ((guix #)) (#) ?))
> 222:29 4 (map1 (((guix base16)) ((guix base32)) ((gcrypt #)) # ?))
> 222:29 3 (map1 (((guix base32)) ((gcrypt hash)) ((guix #)) (#) ?))
> 222:17 2 (map1 (((gcrypt hash)) ((guix profiling)) ((rnrs #)) # ?))
> 2803:6 1 (resolve-interface _ #:select _ #:hide _ #:prefix _ # _ ?)
> In unknown file:
> 0 (scm-error misc-error #f "~A ~S" ("no code for modu?" ?) ?)
>
> ERROR: In procedure scm-error:
> no code for module (gcrypt hash)
> ```

You should use 'guix environment guix' to ensure the dependencies are
available.

Toggle quote (8 lines)
> ```
> anadon@goodadvicemallard:~/documents/code/guix$ guix environment guix --
> ./pre-inst-env guix
> guile: warning: failed to install locale
> guix environment: error: failed to connect to
> `/var/guix/daemon-socket/socket': Connection refused
> ```

This means the daemon is not running, or configured with a faulty
--localstatedir.

Toggle quote (8 lines)
> ```
> anadon@goodadvicemallard:~/documents/code/guix$ guix environment guix --
> ./pre-inst-env guix build python-pytest-asyncio
> guile: warning: failed to install locale
> guix build: error: failed to connect to
> `/usr/local/var/guix/daemon-socket/socket': Connection refused
> ```

Pass "--localstatedir=/var" when running the configure script to provide
the correct daemon state directory.

Toggle quote (5 lines)
> The daemon has been run via systemd and
> `anadon@goodadvicemallard:~/documents/code/guix$
> sudo -E ./pre-inst-env guix-daemon --build-users-group=guixbuild` to
> similar effect.

You don't need to run the daemon manually unless you want to hack on the
daemon itself. However if you do, make sure that it has been configured
with the correct "--localstatedir" and "--sysconfdir".

HTH,
Marius
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6wKgwACgkQoqBt8qM6
VPryswf8DHjotJ4/k7wep+/XhNXwkur8oyExLZdx0gSwAryKyttRFKB92FpIBRRK
zQ4f2PiEkn/JWywfw7XiwS7NYFYggDqcpmWaJgghYZVSkHJTRVEa4q7CJe58szjq
ckovAbdzbnQcZbBsCaA57sR+VRXxi/E/MoWVZilASRzvzVAUANcp7C7/7ddPrdZl
q3GJQAgXa1gJnwthiPhcWqHKglP4JOyYTCbaD34+UaaoQbtayOy3Zoi7StKyrxZl
g52jNmMKcTeJBPYAfWVPUdom2B03sxas3zJfc1A8/utfC4xLrQdMDF/bs/09a8S4
/wDyb2o4CTbvxXeGo5/w1uMMlqPLew==
=MUmk
-----END PGP SIGNATURE-----

Marius Bakke wrote 5 years ago
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)(address . 41059-done@debbugs.gnu.org)
875zdb1zjq.fsf@devup.no
Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:

Toggle quote (2 lines)
> Close fixed

OK, closing by adding -done to the bug email address.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6wNskACgkQoqBt8qM6
VPqwrQgAkcYZulQNB2YoDbQd9/tghyLbZoVtdv68/3wciuYHuF/4FTmZSGmK+lFi
mJBTCq1tKEIdQDw3JUVcSBvRMHbScOmkz9NcL5iCivlLpYA+BXV7yyUsifoMhxoV
KE2WDzdwhN+AYUyjZzbnVJgbea5/x6X+D//WMNAn4NnTgj9nKcDOSdrBQZqLZ3QE
DNY0MFhP5LroMz6HA68UkX6saBkmJQD56duYWtmpvoGUphpahlxVf7A7CnNy0B9a
FKJk0RylPxTxxun4eoqBJ0/JWoECoADdPu6rGGC7O7oU8rlBkqkbix39qEUEBue+
CLI0i+2e3SF07y9R2jnujuuCaPuZsA==
=/ByE
-----END PGP SIGNATURE-----

Closed
Josh Marshall wrote 5 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 41059@debbugs.gnu.org)
CAFkJGReD9aQLP1SfadX2=CpGN1s+YX8LFu9khhqf+dJgfmb54g@mail.gmail.com
Close fixed

On Mon, May 4, 2020, 10:43 Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (76 lines)
> Josh Marshall <joshua.r.marshall.1991@gmail.com> writes:
>
> > has the following results from various invocations:
> >
> > ```
> > anadon@goodadvicemallard:~/documents/code/guix$ ./pre-inst-env guix
> > guile: warning: failed to install locale
> > Backtrace:
> > In ice-9/threads.scm:
> > 390:8 19 (_ _)
> > In ice-9/boot-9.scm:
> > 2994:20 18 (_)
> > 2312:4 17 (save-module-excursion _)
> > 3014:26 16 (_)
> > In unknown file:
> > 15 (primitive-load-path "guix/store" #<procedure 7fa451b4a?>)
> > In guix/store.scm:
> > 22:0 14 (_)
> > In ice-9/boot-9.scm:
> > 2874:4 13 (define-module* _ #:filename _ #:pure _ #:version _ # _ ?)
> > 2887:24 12 (_)
> > 222:29 11 (map1 (((guix utils)) ((guix config)) ((guix #)) ((?)) ?))
> > 222:29 10 (map1 (((guix config)) ((guix deprecation)) ((guix ?)) ?))
> > 222:29 9 (map1 (((guix deprecation)) ((guix memoization)) ((?)) ?))
> > 222:29 8 (map1 (((guix memoization)) ((guix serialization)) (#) ?))
> > 222:29 7 (map1 (((guix serialization)) ((guix monads)) ((# #)) ?))
> > 222:29 6 (map1 (((guix monads)) ((guix records)) ((guix #)) (#) ?))
> > 222:29 5 (map1 (((guix records)) ((guix base16)) ((guix #)) (#) ?))
> > 222:29 4 (map1 (((guix base16)) ((guix base32)) ((gcrypt #)) # ?))
> > 222:29 3 (map1 (((guix base32)) ((gcrypt hash)) ((guix #)) (#) ?))
> > 222:17 2 (map1 (((gcrypt hash)) ((guix profiling)) ((rnrs #)) # ?))
> > 2803:6 1 (resolve-interface _ #:select _ #:hide _ #:prefix _ # _ ?)
> > In unknown file:
> > 0 (scm-error misc-error #f "~A ~S" ("no code for modu?" ?) ?)
> >
> > ERROR: In procedure scm-error:
> > no code for module (gcrypt hash)
> > ```
>
> You should use 'guix environment guix' to ensure the dependencies are
> available.
>
> > ```
> > anadon@goodadvicemallard:~/documents/code/guix$ guix environment guix --
> > ./pre-inst-env guix
> > guile: warning: failed to install locale
> > guix environment: error: failed to connect to
> > `/var/guix/daemon-socket/socket': Connection refused
> > ```
>
> This means the daemon is not running, or configured with a faulty
> --localstatedir.
>
> > ```
> > anadon@goodadvicemallard:~/documents/code/guix$ guix environment guix --
> > ./pre-inst-env guix build python-pytest-asyncio
> > guile: warning: failed to install locale
> > guix build: error: failed to connect to
> > `/usr/local/var/guix/daemon-socket/socket': Connection refused
> > ```
>
> Pass "--localstatedir=/var" when running the configure script to provide
> the correct daemon state directory.
>
> > The daemon has been run via systemd and
> > `anadon@goodadvicemallard:~/documents/code/guix$
> > sudo -E ./pre-inst-env guix-daemon --build-users-group=guixbuild` to
> > similar effect.
>
> You don't need to run the daemon manually unless you want to hack on the
> daemon itself. However if you do, make sure that it has been configured
> with the correct "--localstatedir" and "--sysconfdir".
>
> HTH,
> Marius
>
Attachment: file
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41059@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41059
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help