[PATCH] gnu: nix: Update to 2.3.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • goodoldpaul
  • Marius Bakke
Owner
unassigned
Submitted by
goodoldpaul
Severity
normal
G
G
goodoldpaul wrote on 3 May 2020 19:45
(address . guix-patches@gnu.org)
e858b36e4f60bcbd464f0a439c691c43@autistici.org
Hi everybody,
I'm sending a couple of patches upgrading Nix to 2.3.4 and adding
libeditline, a new dependency.

Thanks,

Giacomo
G
G
Giacomo Leidi wrote on 3 May 2020 19:46
[PATCH 1/2] gnu: Add editline.
(address . 41056@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20200503174620.9307-1-goodoldpaul@autistici.org
* gnu/packages/libedit.scm (editline): New variable.
---
gnu/packages/libedit.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/libedit.scm b/gnu/packages/libedit.scm
index 37638a2b6a..9ebe987b6c 100644
--- a/gnu/packages/libedit.scm
+++ b/gnu/packages/libedit.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,7 +24,9 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages ncurses))
(define-public libedit
@@ -48,3 +51,30 @@ library (libedit). This Berkeley-style licensed command line editor library
provides generic line editing, history, and tokenization functions, similar to
those found in GNU Readline.")
(license bsd-3)))
+
+(define-public editline
+ (package
+ (name "editline")
+ (version "1.17.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/troglobit/editline.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y7vis52kfq2km9isrlzakpf7bn1k7v9vf3xg3q1cslla18q6myh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)))
+ (home-page "https://troglobit.com/projects/editline/")
+ (synopsis "Small replacement for GNU readline() for UNIX")
+ (description
+ "@{editline} is a small line editing library. It can be linked into almost
+any program to provide command line editing and history functions. It is call
+compatible with the FSF @code{readline} library, but at a fraction of the size,
+and as a result fewer features.")
+ (license bsd-4)))
--
2.26.2
G
G
Giacomo Leidi wrote on 3 May 2020 19:46
[PATCH 2/2] gnu: nix: Update to 2.3.4.
(address . 41056@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20200503174620.9307-2-goodoldpaul@autistici.org
* gnu/packages/package-management.scm (nix): Update to 2.3.4,
[native-inputs]: Add autoconf, autoconf-archive, automake, bison and flex,
[inputs]: Add boost, brotli, editline.
---
gnu/packages/package-management.scm | 20 ++++++++++++++++----
1 file changed, 16 insertions(+), 4 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 44fcb514b7..253027bbe1 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages bootstrap) ;for 'bootstrap-guile-origin'
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -45,6 +47,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages dbm)
#:use-module (gnu packages docbook)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages file)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -54,6 +57,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
+ #:use-module (gnu packages libedit)
#:use-module (gnu packages linux)
#:use-module (gnu packages lisp)
#:use-module (gnu packages man)
@@ -480,18 +484,26 @@ out) and returning a package that uses that as its 'source'."
(define-public nix
(package
(name "nix")
- (version "2.0.4")
+ (version "2.3.4")
(source (origin
(method url-fetch)
(uri (string-append "http://nixos.org/releases/nix/nix-"
version "/nix-" version ".tar.xz"))
(sha256
(base32
- "0ss9svxlh1pvrdmnqjvjyqjmbqmrdbyfarvbb14i9d4bggzl0r8n"))))
+ "03fhbb8088sgz3709zd9n9rydavar79w87l9n4q9iimcw06nlqhw"))))
(build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("curl" ,curl)
+ (native-inputs `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("bison" ,bison)
+ ("flex" ,flex)
+ ("pkg-config" ,pkg-config)))
+ (inputs `(("boost" ,boost)
+ ("brotli" ,brotli)
("bzip2" ,bzip2)
+ ("curl" ,curl)
+ ("editline" ,editline)
("libgc" ,libgc)
("libseccomp" ,libseccomp)
("libsodium" ,libsodium)
--
2.26.2
M
M
Marius Bakke wrote on 5 May 2020 19:44
Re: [bug#41056] [PATCH 1/2] gnu: Add editline.
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
87wo5qxon4.fsf@devup.no
Giacomo Leidi <goodoldpaul@autistici.org> writes:

Toggle quote (2 lines)
> * gnu/packages/libedit.scm (editline): New variable.

[...]

Toggle quote (14 lines)
> +(define-public editline
> + (package
> + (name "editline")
> + (version "1.17.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/troglobit/editline.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0y7vis52kfq2km9isrlzakpf7bn1k7v9vf3xg3q1cslla18q6myh"))))

Upstream appears to provide bootstrapped tarballs, can you change to use
those instead?

Toggle quote (6 lines)
> + (build-system gnu-build-system)
> + (native-inputs
> + `(("automake" ,automake)
> + ("autoconf" ,autoconf)
> + ("libtool" ,libtool)))

Then you can also remove these inputs.

Toggle quote (3 lines)
> + (synopsis "Small replacement for GNU readline() for UNIX")

Just "Line editing library". The description has the juicy details.

Toggle quote (2 lines)
> + (description
> + "@{editline} is a small line editing library. It can be linked into almost
^^^
This should be @code{editline}.

Toggle quote (3 lines)
> +any program to provide command line editing and history functions. It is call
> +compatible with the FSF @code{readline} library, but at a fraction of the size,

s/FSF @code{readline}/GNU Readline/

Toggle quote (3 lines)
> +and as a result fewer features.")
> + (license bsd-4)))

Otherwise LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6xpf8ACgkQoqBt8qM6
VPp71Qf+IBXZ8w0D413tBQILD0CzqkScc0BLzKXFYT5daYfjiU3xeDnWoNN4wwUl
en50YtAIbgVZVqLZ2LdhO5u5s8PO1Q1afUa+sotNIU3kmM1ssB2FyxmXMewZBClg
HJfFW/3ldp37zUFxSj+DxRBk/WFX85ERf/ozOZfaCuhKlf7nY6f0K4n/cBwfWqZy
FX/CcYmZhr2lP8KOiDvCr8Xjbdpya+2guPefTmtdxG67bqsTSGoEkGwRuBEF+DFo
wNzm8Iw3atcOBU6qW3KFiRJ8m6seRxZW4teH6JXAIa9rcfw+fo32kzzH6eGrdRI1
L/Z5IP6gFKaiTlEYi9VTDF8BZrHVcw==
=NkKx
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 5 May 2020 19:48
Re: [bug#41056] [PATCH 2/2] gnu: nix: Update to 2.3.4.
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
87tv0uxog2.fsf@devup.no
Giacomo Leidi <goodoldpaul@autistici.org> writes:

Toggle quote (4 lines)
> * gnu/packages/package-management.scm (nix): Update to 2.3.4,
> [native-inputs]: Add autoconf, autoconf-archive, automake, bison and flex,
> [inputs]: Add boost, brotli, editline.

The new native-inputs are weird. Do you know why they are needed?
Typically those are only necessary when building from a git checkout,
not for release tarballs.

LGTM in any case, just curious! :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6xpv0ACgkQoqBt8qM6
VPr92QgAhXX+VuYpN+/OhxtfLuhZAku2eIHPhh2soqMwcxBFkMz28KI4J+uE/r7k
9k+ioYlBHntQrnkIyALCxjDS3ScNnmZW9xdqlxcRdCHC10YxjLSh8XqaDgY6h4Vx
+zm+xGXCgpBVRScPSLGpyOMQ50pB9zkTozRY+FJoKbK2WS2g94ur3DYqCwbkldi8
C0Tpxt6udKomiKwMkfPOCBJ1aR247PuVbTur9y9JSdKLh+fCXmW6OptLPYOz8EhR
3S8jZ42IhD+75I9RfRsXI4GAhp9f7BcRnlFPbw7fOaoqssad7gHCQPPlT/I0OIYK
Dip7faQ0LpWyWMatfAj6AmU0dcQiGg==
=GOI0
-----END PGP SIGNATURE-----

G
G
goodoldpaul wrote on 5 May 2020 22:53
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 41056@debbugs.gnu.org)
64a1e6cbe82f9950eae02d3abb610adf@autistici.org
Hi Marius,

On 2020-05-05 17:48, Marius Bakke wrote:
Toggle quote (11 lines)
> Giacomo Leidi <goodoldpaul@autistici.org> writes:
>
>> * gnu/packages/package-management.scm (nix): Update to 2.3.4,
>> [native-inputs]: Add autoconf, autoconf-archive, automake, bison and
>> flex,
>> [inputs]: Add boost, brotli, editline.
>
> The new native-inputs are weird. Do you know why they are needed?
> Typically those are only necessary when building from a git checkout,
> not for release tarballs.

Of course they are strange, I was trying to use the Git checkout
initially because of the wonderful support offered by SWH in storing Git
repositories but eventually I changed my mind and forgot to remove them
:(.

I fixed this and the problems in the other patch and I'm going to send
an updated version.

Thanks for your review,

Giacomo
G
G
Giacomo Leidi wrote on 5 May 2020 22:53
[PATCH 2/2] gnu: nix: Update to 2.3.4.
(address . 41056@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20200505205318.17668-2-goodoldpaul@autistici.org
* gnu/packages/package-management.scm (nix): Update to 2.3.4,
[inputs]: Add boost, brotli, editline.
---
gnu/packages/package-management.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 44fcb514b7..1fbc2baf33 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages bootstrap) ;for 'bootstrap-guile-origin'
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -54,6 +56,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
+ #:use-module (gnu packages libedit)
#:use-module (gnu packages linux)
#:use-module (gnu packages lisp)
#:use-module (gnu packages man)
@@ -480,18 +483,21 @@ out) and returning a package that uses that as its 'source'."
(define-public nix
(package
(name "nix")
- (version "2.0.4")
+ (version "2.3.4")
(source (origin
(method url-fetch)
(uri (string-append "http://nixos.org/releases/nix/nix-"
version "/nix-" version ".tar.xz"))
(sha256
(base32
- "0ss9svxlh1pvrdmnqjvjyqjmbqmrdbyfarvbb14i9d4bggzl0r8n"))))
+ "03fhbb8088sgz3709zd9n9rydavar79w87l9n4q9iimcw06nlqhw"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("curl" ,curl)
+ (inputs `(("boost" ,boost)
+ ("brotli" ,brotli)
("bzip2" ,bzip2)
+ ("curl" ,curl)
+ ("editline" ,editline)
("libgc" ,libgc)
("libseccomp" ,libseccomp)
("libsodium" ,libsodium)
--
2.26.2
G
G
Giacomo Leidi wrote on 5 May 2020 22:53
[PATCH 1/2] gnu: Add editline.
(address . 41056@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20200505205318.17668-1-goodoldpaul@autistici.org
* gnu/packages/libedit.scm (editline): New variable.
---
gnu/packages/libedit.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/libedit.scm b/gnu/packages/libedit.scm
index 37638a2b6a..38da02572a 100644
--- a/gnu/packages/libedit.scm
+++ b/gnu/packages/libedit.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,3 +49,24 @@ library (libedit). This Berkeley-style licensed command line editor library
provides generic line editing, history, and tokenization functions, similar to
those found in GNU Readline.")
(license bsd-3)))
+
+(define-public editline
+ (package
+ (name "editline")
+ (version "1.17.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ftp.troglobit.com/editline/editline-" version ".tar.xz"))
+ (sha256
+ (base32 "03pw3z6pz590v8xfnjx0yynnzij2sb9xwjbvqvdzsid56crkn8nz"))))
+ (build-system gnu-build-system)
+ (home-page "https://troglobit.com/projects/editline/")
+ (synopsis "Line editing library")
+ (description
+ "@code{editline} is a small line editing library. It can be linked into almost
+any program to provide command line editing and history functions. It is call
+compatible with the GNU Readline library, but at a fraction of the size,
+and as a result fewer features.")
+ (license bsd-4)))
--
2.26.2
M
M
Marius Bakke wrote on 6 May 2020 22:46
Re: [bug#41056] [PATCH 2/2] gnu: nix: Update to 2.3.4.
(address . goodoldpaul@autistici.org)(address . 41056-done@debbugs.gnu.org)
87y2q43i6e.fsf@devup.no
goodoldpaul@autistici.org writes:

Toggle quote (19 lines)
> Hi Marius,
>
> On 2020-05-05 17:48, Marius Bakke wrote:
>> Giacomo Leidi <goodoldpaul@autistici.org> writes:
>>
>>> * gnu/packages/package-management.scm (nix): Update to 2.3.4,
>>> [native-inputs]: Add autoconf, autoconf-archive, automake, bison and
>>> flex,
>>> [inputs]: Add boost, brotli, editline.
>>
>> The new native-inputs are weird. Do you know why they are needed?
>> Typically those are only necessary when building from a git checkout,
>> not for release tarballs.
>
> Of course they are strange, I was trying to use the Git checkout
> initially because of the wonderful support offered by SWH in storing Git
> repositories but eventually I changed my mind and forgot to remove them
> :(.

Easy mistake to make :-) good thing we have patch review processes to
catch such issues!

Toggle quote (3 lines)
> I fixed this and the problems in the other patch and I'm going to send
> an updated version.

Applied both patches, thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6zIjkACgkQoqBt8qM6
VPr0gAgAisHsvKwTxF0oxqlNkozP8BPVTXPXI/w3lOGmpIpVGuyvzVdHTAGBVj2c
75mpmCkU3Vv2t0erhBm7u7HCnnoTg6Pk8tHKbuDA0aY85N3Wt3a9ZXSXIO9E+phv
3DmnNsCz+e01eMTNta+tnBZD4WWW2Kmsh7I7RbsdVPUUnucXkLIH7Fc8oJoKtTMD
/KID3MmCPLdohDIsnCdqgyXjbX14oioavpvxz76dRmFVQSSnivXp/8vYYJ3iL0/b
+2nbT8VP1mvw6GjKucdCxL7LeVri1ezTBHnoc+AHV+0NWe3R/O9ByP9RyNmXzin9
6pEBWhWlB/RhuE2ptoHjGrjM+eQQUw==
=palg
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41056@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41056
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch