[PATCH] gnu: Add lesspipe

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 5 years ago
(address . guix-patches@gnu.org)
87mu6p46n8.fsf@rohleder.de
At least debian and gentoo include their own version of lesspipe in the
less package. Nor sure if we should do the same or include this package
here.
I use this since a week or so and it works well so far.

I'm not very creative on creating descriptions. Please feel free to
change it. ;)
From 9ee7d976ffa6cd6d8375fac2df0f50940f9d4877 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 3 May 2020 12:31:43 +0200
Subject: [PATCH] gnu: Add lesspipe

* gnu/packages/less.scm (lesspipe): New variable.
---
gnu/packages/less.scm | 50 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/less.scm b/gnu/packages/less.scm
index 91c269a67e..92e20a3705 100644
--- a/gnu/packages/less.scm
+++ b/gnu/packages/less.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,8 +21,11 @@
(define-module (gnu packages less)
#:use-module (guix licenses)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages file)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu))
(define-public less
@@ -48,3 +52,49 @@ backwards and forwards movement through the document. It also does not have
to read the entire input file before starting, so it starts faster than most
text editors.")
(license gpl3+))) ; some files are under GPLv2+
+
+(define-public lesspipe
+ (package
+ (name "lesspipe")
+ (version "1.84")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wofr06/lesspipe.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "124ffhzrikr88ab14rk6753n8adxijpmg7q3zx7nmqc52wpkfd8q"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file "Makefile") ; force generating
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ "--yes")
+ #t))))))
+ (inputs
+ `(("file" ,file)
+ ("ncurses" ,ncurses))) ; for tput
+ (native-inputs `(("perl" ,perl)))
+ (home-page "https://github.com/wofr06/lesspipe")
+ (synopsis "Input filter for less")
+ (description "To browse files under UNIX the excellent viewer less
+can be used. By setting the environment variable LESSOPEN, less can be
+enhanced by external filters to become even more powerful. Most Linux
+distributions come already with a \"lesspipe.sh\" that covers the most
+common situations.
+The input filter for less described here is called
+\"lesspipe.sh\". It is able to process a wide variety of file
+formats. It enables users to deeply inspect archives and to display
+the contents of files in archives without having to unpack them
+before. That means file contents can be properly interpreted even if
+the files are compressed and contained in a hierarchy of
+archives (often found in RPM or DEB archives containing source
+tarballs). The filter is easily extensible for new formats.")
+ (license gpl2)))
--
2.26.2
--
Murphy was an optimist.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl6uplsACgkQfHr/vv7y
yyWnMAf6A6dqzo1Y6D7XPm7FMPT5GS8L1uL6dCfKlL98pCZ+4W3XeACFInp8EzVW
oaJqfYPlY7Xdg/9IxnBPTD4qjswSXl3iTANnWmxwvTW2EAmQThiIbN+gvP96FJZh
7y1JmHLgjL05gnD7Md4W1/vbae6wbWu8DnFJVJISaeKF2SSfk3QWHXyqsXpKjSoM
Ek9/CHdy75Nla7Bp6rcM3lLeRmiXczn+1xw42EGpxJlJqdan2bqIEW+fV+mgxuhV
H22yFX4nPBXt5t/lYH6zwNLi5Hq7jG7V2nvgNqBJO2bP1YrVBILeDintTmKmxKDx
mgvpro6rtgkuHHDxtKCNFbw1TTgKzA==
=HDBS
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 5 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 41047-done@debbugs.gnu.org)
87lfm7pgxm.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (3 lines)
> I'm not very creative on creating descriptions. Please feel free to
> change it. ;)

Heheh.

Toggle quote (7 lines)
> From 9ee7d976ffa6cd6d8375fac2df0f50940f9d4877 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Sun, 3 May 2020 12:31:43 +0200
> Subject: [PATCH] gnu: Add lesspipe
>
> * gnu/packages/less.scm (lesspipe): New variable.

Applied with the following changes. Note that the license is GPLv2+
because there’s nothing stating “version 2 only”.

Thanks!

Ludo’.
Toggle diff (30 lines)
diff --git a/gnu/packages/less.scm b/gnu/packages/less.scm
index 92e20a3705..76a4d42dfd 100644
--- a/gnu/packages/less.scm
+++ b/gnu/packages/less.scm
@@ -84,17 +84,11 @@ text editors.")
(native-inputs `(("perl" ,perl)))
(home-page "https://github.com/wofr06/lesspipe")
(synopsis "Input filter for less")
- (description "To browse files under UNIX the excellent viewer less
-can be used. By setting the environment variable LESSOPEN, less can be
-enhanced by external filters to become even more powerful. Most Linux
-distributions come already with a \"lesspipe.sh\" that covers the most
-common situations.
-The input filter for less described here is called
-\"lesspipe.sh\". It is able to process a wide variety of file
-formats. It enables users to deeply inspect archives and to display
-the contents of files in archives without having to unpack them
-before. That means file contents can be properly interpreted even if
-the files are compressed and contained in a hierarchy of
-archives (often found in RPM or DEB archives containing source
-tarballs). The filter is easily extensible for new formats.")
- (license gpl2)))
+ (description "To browse files, the excellent viewer @code{less} can be
+used. By setting the environment variable @code{LESSOPEN}, less can be
+enhanced by external filters to become more powerful. The input filter for
+less described here is called @code{lesspipe.sh}. It is able to process a
+wide variety of file formats. It enables users to inspect archives and
+display their contents without having to unpack them before. The filter is
+easily extensible for new formats.")
+ (license gpl2+)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41047@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41047
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help