Christopher Howard wrote 5 years ago
(address . guix-patches@gnu.org)
I need libusb-0.1 to build some older software, but libusb-0.1 build
fails due to a warning from the current GCC version. (Evidently libusb-
0.1 is set to die on any warning.) The attached patch silences the
warning.
--
Christopher Howard
p: +1 (907) 374-0257
gpg: ADDEAADE5D607C8D (keys.gnupg.net)
From 351bb7004f9bbe8d50bbc7a2e2a1cb3900551e27 Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Sat, 2 May 2020 14:41:00 -0800
Subject: [PATCH] gnu: libusb-0.1: fix build failure on newer gcc
Package build fails on truncation warning from current gcc. Silences
this warning.
---
gnu/packages/libusb.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 01c138cb4e..3bb2dcd186 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2020 Christopher Howard <christopher@librehacker.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -113,7 +114,8 @@ version of libusb to run with newer libusb.")
(sha256
(base32
"0i4bacxkyr7xyqxbmb00ypkrv4swkgm0mghbzjsnw6blvvczgxip"))
- (patches (search-patches "libusb-0.1-disable-tests.patch"))))))
+ (patches (search-patches "libusb-0.1-disable-tests.patch"))))
+ (arguments `(#:configure-flags (list "CFLAGS=-Wno-format-truncation")))))
(define-public libusb4java
;; There is no public release so we take the latest version from git.
--
2.26.2