Channel/inferior error with core-updates: Unbound variable: call-with-new-thread
(address . bug-guix@gnu.org)
Noticed this when testing guix system build with core-updates. Here's a
small example which reproduces the issue:
(use-modules (guix channels)
(guix inferior))
(define channels
(list (channel
(name 'guix)
(commit
"e02c2f85b36ce1c733bd908a210ce1182bdd2560"))))
(define inferior
(inferior-for-channels channels))
(first (lookup-inferior-packages inferior "linux-libre" "5.2.21"))
If you save that as a file then attempt to build it:
→ guix build -f test.scm
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Backtrace:
4 (primitive-load "/gnu/store/8mv5bpjgxg9c369xnbb5rf1kv9r?")
In ice-9/eval.scm:
619:8 3 (_ #(#(#(#(#(#(#(#(#(#(#(?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?))
182:19 2 (proc #(#(#(#(#(#(#(#(#(#(# ?) ?) ?) ?) ?) ?) ?) ?) ?) ?))
142:16 1 (compile-top-call #<directory (guile-user) 7f1e0abc1f00> ?)
In unknown file:
0 (%resolve-variable (7 . call-with-new-thread) #<directo?>)
ERROR: In procedure %resolve-variable:
Unbound variable: call-with-new-thread
guix build: error: You found a bug: the program '/gnu/store/8mv5bpjgxg9c369xnbb5rf1kv9r6z5hw-compute-guix-derivation'
failed to compute the derivation for Guix (version: "e02c2f85b36ce1c733bd908a210ce1182bdd2560"; system: "x86_64-linux";
host version: "a8cb1e72ef351330d1521833c1b270dcc0da593f"; pull-version: 1).
Please report it by email to <bug-guix@gnu.org>.
-----BEGIN PGP SIGNATURE-----
iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl6tliVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfE1g/9H69j+hNwEfbN/lS3gA5ErpkPvI85iRIyKwEDLKSu6PcjalvwsXdnSM4l
9JC6kTFJiWpBGnXnYTiwLP8D/LGo6XBNyqVw0nbtsB8MQlR1DxMOo4aHroOMzAFv
POoSdVvVuDK+tNY/XePiI8fk67hZ7wWor83WUueL355d3vSVZvmyWQia1z2tx6DW
k8Pb5rmCY+/KX3kxh7T2LTLUAZcnP78zUKiJVujnzYgci9++cmbsfe2svj0juwgg
1Aqu+zKx+kfjMaHHEfak/a9DGwh0K13u+Qf80d5kIb8+lFkPCbZDcIcjT4AG2dQ3
GZcXSCNnOjJQBH9jtCikvNgUOA5b47nwuAxSb9APVlTdSWwiJZk7JcnIBFhm8Koz
mPOFIILKirErKkPlBsDX/eiOnL/jkcNzfCpfcjMQn5lcVry6thXVwnW9992KnCLM
E1CuH/oo9emLLfmVDW4PrFBHma0zJ6cjw4mmP4t8P20JXuhPWMPVqMoTaxy2UGj6
1kJQ9tH+vBoI5KuOYFZkXzz4JMqPkUDJWyDmJx/XtSZBGpXutXz56+yNO/djK1N3
4H+D7/DUciigdznofDVwefqfSi7j3F3zJcrwz40H1eb8C8Wmn2WxPkDdMUjQt5G1
bQxMQ27JEdTWzjE8VmxWdaZR81pl45WAg3DTVpBmNr8qYpnD6y0=
=AyHo
-----END PGP SIGNATURE-----