[PATCH core-updates] gnu: python-s3transfer: Fix build with Python 3.8.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
20200502144441.1489-1-mail@cbaines.net
* gnu/packages/python-web.scm (python-s3transfer)[arguments]: Add a 'patch
phase to fix a test to work under Python 3.8.
---
gnu/packages/python-web.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 27749246d8..56887ef9d4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2204,6 +2204,15 @@ Betamax.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ ;; There's a small issue with one test with Python 3.8, this
+ ;; change has been suggested upstream:
+ ;; https://github.com/boto/s3transfer/pull/164
+ (substitute* "tests/unit/test_s3transfer.py"
+ (("super\\(FailedDownloadParts, self\\)\\.submit\\(function\\)")
+ "futures.Future()"))
+ #t))
(replace 'check
(lambda _
;; Some of the 'integration' tests require network access or
--
2.26.0
Christopher Baines wrote 5 years ago
(address . 41027-done@debbugs.gnu.org)
87lflvogdu.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (27 lines)
> * gnu/packages/python-web.scm (python-s3transfer)[arguments]: Add a 'patch
> phase to fix a test to work under Python 3.8.
> ---
> gnu/packages/python-web.scm | 9 +++++++++
> 1 file changed, 9 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 27749246d8..56887ef9d4 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -2204,6 +2204,15 @@ Betamax.")
> (arguments
> `(#:phases
> (modify-phases %standard-phases
> + (add-after 'unpack 'patch
> + (lambda _
> + ;; There's a small issue with one test with Python 3.8, this
> + ;; change has been suggested upstream:
> + ;; https://github.com/boto/s3transfer/pull/164
> + (substitute* "tests/unit/test_s3transfer.py"
> + (("super\\(FailedDownloadParts, self\\)\\.submit\\(function\\)")
> + "futures.Future()"))
> + #t))
> (replace 'check
> (lambda _
> ;; Some of the 'integration' tests require network access or

I pushed this as c63bd847816061e76389e93dc094df98800f081b back on the
4th of May, but forgot to close the bug.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl68OA1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd/MhAAjelg8WdRe7ayUxJPN5zd/T1YC0ZAoFdMqj7Bj9MEdsjqyFWqG5dyZ+xe
foBbp27zI/tF15GBxLL38uY937sW3rq4QhM0Q5UKrbdCFSvS1v3tBbuAm4bY7iba
mJs2BLb124xuOxbbRqQ8u8HP7mZ4CROk0CeiW0uQECyRyp0zD41y5FHSHVbJi0aY
7vDq6KwR2cQo5w+/Vl1OOLQB9mWF0yQeXgkDpblw0AWY/8pnO7sTpjPi84Xdw1NP
oWtHQNinRY19dpwxpoPoh2Wg/B5o/RDA8d0v9MncNau8nsCaNtqsTubuFud5ulj+
ILU95iWkKqMjWOZFnGWt5aHBLbxniq55Qcg8lehehZDYMEFAKP1MHEcLTPVbjvfH
6zUZfzEaJf6dxLuItsDKlqBLDkftxRNnN3sNRXSBJ9nhPLLAuiihD9Vr2vlsRxom
7u7Yr2CFrfzRwXMeC+2CAGhRoGcGbXSP2IeWMSNM0DTAp45rJiS1Qmw8wfeUf7CA
xtMjpGhugrgoJKid4EZKoA8RVqk0ynCeu04FqaSUd6NLbNHTMAgWFt8hcZxiD6zB
THzaqkndLHaxDyYHvDAYJtWpv/HgIfOWlA1nnH+AfmxCWw0LcIlf8PYnCr+vhpNt
T1IIE0qM8UXLg0o6zYNENCbuJ2sdiaNWflcnsaXb5hGQ4rDLdeA=
=9M5J
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41027@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41027
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help