[raid] The bootloader can only be installed to a single drive

  • Done
  • quality assurance status badge
Details
One participant
  • maxim.cournoyer
Owner
unassigned
Submitted by
maxim.cournoyer
Severity
normal
M
M
maxim.cournoyer wrote on 1 May 2020 15:45
(name . bug-guix)(address . bug-guix@gnu.org)
87wo5vkbvn.fsf@hurd.i-did-not-set--mail-host-address--so-tickle-me
Using Guix System, the bootloader declaration doesn't currently seem to
support being installed to multiple drives:

Toggle snippet (8 lines)
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")
(terminal-outputs '(console))))
--8<---------------cut here---------------end--------------->8---

I suggest to change it so that target can be passed a list like
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target '("/dev/sda" "/dev/sdb"))
(terminal-outputs '(console))))
--8<---------------cut here---------------end--------------->8---

This is useful when trying to boot a degraded RAID array.

Maxim
M
M
Maxim Cournoyer wrote on 8 Aug 2021 06:25
(address . 40997@debbugs.gnu.org)
877dgw36n6.fsf@gmail.com
Hello,

maxim.cournoyer@gmail.com writes:

Toggle quote (19 lines)
> Using Guix System, the bootloader declaration doesn't currently seem to
> support being installed to multiple drives:
>
> (bootloader (bootloader-configuration
> (bootloader grub-bootloader)
> (target "/dev/sda")
> (terminal-outputs '(console))))
> --8<---------------cut here---------------end--------------->8---
>
> I suggest to change it so that target can be passed a list like
>
> (bootloader (bootloader-configuration
> (bootloader grub-bootloader)
> (target '("/dev/sda" "/dev/sdb"))
> (terminal-outputs '(console))))
> --8<---------------cut here---------------end--------------->8---
>
> This is useful when trying to boot a degraded RAID array.

The following patches do exactly this (target becomes the plural
targets). I tested it on my system, disconnecting the first drive of my
RAID1 array, and could at least boot to GRUB fine (although full boot

Booting a VM using an image generated from the bare-bones.tmpl template
also worked fine.
Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 9 Aug 2021 17:07
control message for bug #40997
(address . control@debbugs.gnu.org)
87sfzi1wsm.fsf@gmail.com
tags 40997 + patch
quit
M
M
Maxim Cournoyer wrote on 29 Aug 2021 07:19
Re: bug#40997: [raid] The bootloader can only be installed to a single drive
(address . 40997-done@debbugs.gnu.org)
87v93orfoh.fsf@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (31 lines)
> Hello,
>
> maxim.cournoyer@gmail.com writes:
>
>> Using Guix System, the bootloader declaration doesn't currently seem to
>> support being installed to multiple drives:
>>
>> (bootloader (bootloader-configuration
>> (bootloader grub-bootloader)
>> (target "/dev/sda")
>> (terminal-outputs '(console))))
>> --8<---------------cut here---------------end--------------->8---
>>
>> I suggest to change it so that target can be passed a list like
>>
>> (bootloader (bootloader-configuration
>> (bootloader grub-bootloader)
>> (target '("/dev/sda" "/dev/sdb"))
>> (terminal-outputs '(console))))
>> --8<---------------cut here---------------end--------------->8---
>>
>> This is useful when trying to boot a degraded RAID array.
>
> The following patches do exactly this (target becomes the plural
> targets). I tested it on my system, disconnecting the first drive of my
> RAID1 array, and could at least boot to GRUB fine (although full boot
> failed due to https://issues.guix.gnu.org/40999).
>
> Booting a VM using an image generated from the bare-bones.tmpl template
> also worked fine.

Pushed with commit 2ca982ff41270288913ad6b7d5d9e1cad87b06d9.

Closing!

Maxim
Closed
?